Beatstep Pro won't send MIDI after playback

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
Digital Larry
Posts: 55
Joined: Thu Aug 08, 2019 3:13 am

Beatstep Pro won't send MIDI after playback

Post by Digital Larry » Sun Dec 29, 2019 6:00 am

Here's the setup.
  • Ableton Live 10 Intro
    Arturia Beatstep Pro fw 2.0.1
    I am using the XLN Addictive Drums plugin.
Right after I start the BSP, it will send MIDI from the buttons when I have the Drum Sequence selected.
I have the BSP connected via USB to my Windows 10 PC,
The BSP is set to "USB" sync.
Now I press "Play" in Live.
The BSP sequence appears to play back (the lights are flashing), but no MIDI is received and of course nothing is heard.
I can stop playback and the buttons on the BSP flash when I press them but nothing happens in Live.
If I power cycle the BSP then I can again get MIDI and sounds from pressing the buttons.
I also have an Arturia Keystation 32 which is connected via USB and it plays the Addictive Drums fine from the keyboard, as well as the arpeggiator triggering AD when I start playback in Live.

Also will probably ask over at Arturia forum.

jklinger
Posts: 1
Joined: Wed Jun 10, 2020 4:44 pm

Re: Beatstep Pro won't send MIDI after playback

Post by jklinger » Wed Jun 10, 2020 4:44 pm

Have you heard anything back regarding this? I am having the same issue.

jaytriana
Posts: 1
Joined: Mon Oct 26, 2020 1:02 am

Re: Beatstep Pro won't send MIDI after playback

Post by jaytriana » Mon Oct 26, 2020 1:02 am

Hey I’m still having this problem October 2020 and it comes and goes. I can’t replicate it but when it starts happening it does so until one day it just stops happening.

It’s fucking maddening.

virtualreverie
Posts: 2
Joined: Thu Nov 12, 2020 12:28 am

Re: Beatstep Pro won't send MIDI after playback

Post by virtualreverie » Wed Dec 02, 2020 1:25 am

I'm having this problem in December 2020 and can agree it's maddening. I think I'm gonna have to sell this piece of kit because I can barely go a half hour of using it without issues

virtualreverie
Posts: 2
Joined: Thu Nov 12, 2020 12:28 am

Re: Beatstep Pro won't send MIDI after playback

Post by virtualreverie » Wed Jan 20, 2021 5:19 pm

Bump. I've resorted to listing my BSP for sale precisely because of this issue. There doesn't seem to be any answers anywhere. I have the exact same setup minus the plugins.

scruffyfox
Posts: 1
Joined: Sat Apr 17, 2021 9:39 am

Re: Beatstep Pro won't send MIDI after playback

Post by scruffyfox » Sat Apr 17, 2021 9:40 am

Having the same issue except the BSP isnt syncing with ableton at all. Hitting the drum pads sends notes fine but its just not syncing with ableton's clock...

for a $500 software, I expect much better.

Mark Williams
Posts: 643
Joined: Sun Aug 10, 2014 2:43 pm
Location: Kent

Re: Beatstep Pro won't send MIDI after playback

Post by Mark Williams » Sat Apr 17, 2021 11:19 am

scruffyfox wrote:
Sat Apr 17, 2021 9:40 am
Having the same issue except the BSP isnt syncing with ableton at all. Hitting the drum pads sends notes fine but its just not syncing with ableton's clock...

for a $500 software, I expect much better.
That's down to you to setup gear properly. Not an Ableton problem, more user error
Live 11, Win10, Push 2, KK S61 MK2, Focusrite Scarlett 18i20 & ADA8200, Softube Console 1 Mk2, Deepmind12D, Eventide H9, Line 6 M5, Komplete 12, Hydrasynth, Cobalt 8M, NDLR, Bass Station2, MicroFreak, Alesis Multi Strike Pad

Post Reply