Kore sound variations grid slow update in Live 8

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
dburns
Posts: 139
Joined: Sat Feb 14, 2009 6:04 am
Contact:

Kore sound variations grid slow update in Live 8

Post by dburns » Sun Aug 16, 2009 3:57 pm

Im using Kore 2 as a plugin in Live 8.0.4. When I choose any of the eight Sound Variation cells by clicking directly on it, or by using Kore's buttons, the sound changes and the screen updates as expected. But when I use the mouse, or Kore's knobs, to drag among cells, the sound seems to change alright, but the screen and Kore's display don't update responsively, and often don't change at all. Sometimes they move a little, then freeze.

There seems to be some lag (MIDI caused?) when using the mouse or knobs to drag, but not when directly clicking or pressing the cell buttons.

Anybody else see this? Is there something I can do to fix it?

Thanks!
Dave Burns
Lowell, MA

More equipment than skill.

33tetragammon
Posts: 903
Joined: Fri Dec 26, 2008 8:34 pm
Location: The Universe
Contact:

Re: Kore sound variations grid slow update in Live 8

Post by 33tetragammon » Sun Aug 16, 2009 6:10 pm

dburns wrote:Im using Kore 2 as a plugin in Live 8.0.4. When I choose any of the eight Sound Variation cells by clicking directly on it, or by using Kore's buttons, the sound changes and the screen updates as expected. But when I use the mouse, or Kore's knobs, to drag among cells, the sound seems to change alright, but the screen and Kore's display don't update responsively, and often don't change at all. Sometimes they move a little, then freeze.

There seems to be some lag (MIDI caused?) when using the mouse or knobs to drag, but not when directly clicking or pressing the cell buttons.

Anybody else see this? Is there something I can do to fix it?

Thanks!
hi there,

i have exactly the same problem,first it was with the knobs "jumping"(i believe it was a graphics problem of some sort,and they fixed that,but now the soundvariations are rendered useless)
every new beta i tried after that had the same problem.
reported it everytime,but i guess the Abes are jampacked with bugreports.

i went back to Live 7.016,Live 8 is useless for me at this point(if i'm using Kore 2 that is)

cheers!

Peripatetic
Posts: 78
Joined: Mon Dec 21, 2009 4:00 am
Location: Mpls, MN

Re: Kore sound variations grid slow update in Live 8

Post by Peripatetic » Thu Mar 11, 2010 4:23 am

Bump.

I just got Kore 2 last week and finally had some time to mess around with it tonight. I'm having the exact problem that the OP described. When I'm doing the sound morphing, clicking the buttons to change to a different sound on the grid works fine, but using the knobs is really slow and jumpy and a couple times it froze Kore and Live for a number of seconds. The sound responds the way it should all the time though (the morphs sound perfectly smooth, etc.)

Also, when I'm not in "Sound" mode and just using the knobs to control the 8 macros, they are smooth as can be.

Anyone else have this problem/know what's causing it?
iMac, Ableton Suite 8, NI Komplete 7, NI Maschine, NI Kore 2, Reason 5, Arturia V-Collection, Akai APC40, Novation SL49 MKII, Akai MPK88, NI Audio Kontrol 1

dburns
Posts: 139
Joined: Sat Feb 14, 2009 6:04 am
Contact:

Re: Kore sound variations grid slow update in Live 8

Post by dburns » Thu Mar 11, 2010 6:13 am

Peripatetic,

Please submit this to Ableton Support. Maybe if enough of us tell them about it they will look at it.

Thanks.
Dave Burns
Lowell, MA

More equipment than skill.

Peripatetic
Posts: 78
Joined: Mon Dec 21, 2009 4:00 am
Location: Mpls, MN

Re: Kore sound variations grid slow update in Live 8

Post by Peripatetic » Thu Mar 11, 2010 3:38 pm

dburns wrote:Peripatetic,

Please submit this to Ableton Support. Maybe if enough of us tell them about it they will look at it.

Thanks.
Will do. I sent in a different crash report last night but figured I would wait on this one because I didn't know if it was a Kore issue or an Ableton issue.
iMac, Ableton Suite 8, NI Komplete 7, NI Maschine, NI Kore 2, Reason 5, Arturia V-Collection, Akai APC40, Novation SL49 MKII, Akai MPK88, NI Audio Kontrol 1

ark
Posts: 1349
Joined: Thu Feb 26, 2009 4:25 pm
Location: New Jersey, USA
Contact:

Re: Kore sound variations grid slow update in Live 8

Post by ark » Thu Mar 11, 2010 3:52 pm

I wonder if this might be related to another problem I'm having with knobs.

I have a MIDI controller for which I have written a config file that lets its knobs instantly map to macro controls. The knobs have LED indicators that handle MIDI feedback.

What's happening is that when I turn a knob, there is a noticeable delay before the MIDI feedback happens. It is as if Live is collecting incoming MIDI messages into batches and sending out the updates a batch at a time, rather than handling each message as soon as it comes in.

I wonder if something similar is happening to the Kore knob movements.

Post Reply