Live 8.0.5 change log

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Alex
Posts: 4006
Joined: Wed Apr 03, 2002 1:07 pm
Location: Ableton Headquarter

Live 8.0.5 change log

Post by Alex » Wed Sep 09, 2009 3:24 pm

Dear All,

following you will find the list of improvements contained in Live 8.0.5.

Kind Regards,
/Alex




Changes from Live 8.0.4 to Live 8.0.5


Improvements:

Updated manuals

Updated Help Pages

When using the APC40 Controller surface script, we check if the selection MIDI ports are the one from the APC40

Improved graphic performance when using Live on Windows 7 RC 1

On Mac OS X, Cocoa support for Audio Units

Having an unfolded Live set file in the browser, now the tracks from that Live set can be inserted into the current set by double clicking too. In earlier versions it was only possible via drag'n drop.

Controller surface support for the AKAI MPD-18, MPK-25, MPK-61 and MPK-88 controllers.

Controller surface support for OpenLabs devices




Bugfixes:

When record quantization is on, MIDI loop recording in the arranger would not behave properly [5603]

The state of the tempo nudge up/down would be saved within a Live set by mistake [5421]

Under certain conditions and depending on its settings, the Beat Repeat device would not work properly [5612]

The display representation of the Axiom Pro's endless encoders would not update when the knobs itself are turned[5627]

When having collapsed group tracks in the arranger, the 'Select All' command would not work properly and moving/copying the selection could even crash Live [5597]

Using Live as ReWire master with several ReWire slaves at the same time could not behave properly when sending/receiving MIDI to/from these ReWire slaves [5517]

Under certain conditions, drag and hover would 'unfold' the wrong track [5544]

The Auto/Range parameter of the Spectrum device could not be saved within a preset [5637]

A Live set from a Windows machine, saved on OS X 10.4.x would show a wrong icon [5579]

After grouping tracks, the APC40 would not always show the respective track states [5620]

The Looper could produce audio clicks when changing from play to overdub mode [5473]

Moving grouped tracks in the arranger could crash Live [5639]

When installing content packages, the progress dialog could show a too high number of processed items [5629]

Using MIDI remote mappings in Live running as ReWire slave could crash the Live and the ReWire master [5642]

Select on launch would not work when using the APC 40, when recording clips [5648]

With low update rates, the Spectrum display would “wobble” even for constant signals [5643]

Mapping a foot switch to step forward/backward would not work properly [5451]

Under certain conditions, using the warper's transient beats mode could cause drop outs [5625]

Under certain conditions, renaming a browser entry could crash Live [5641]

Dragging a Live set into Live would not always updated the corresponding macro names [5500]

Uploading a Live set without freezing necessary tracks would crash Live [5049]

Using the APC40 would not properly display follow actions [5610]

On Windows 7 RC 1, 'Show in Explorer' would not work properly

Committing a groove would not respect a change of the 'Base' parameter [5662]

using the absolute mouse mode, several edit boxes of the Sampler would not work properly [5654]

In the Sampler, setting loop start or end would not work via Mouse click + Modifier [5653]

Having a selection of a group track contain an audio and a MIDI track, arming the MIDI track could crash Live [5693]

On Mac OS X, closing a particular Live set containing a FabFilter One plug-in would crash Live [5609]

Having a device chain with an effect or instrument before a Spectrum device could crash when deleting the effect or instrument [5695]

Under certain conditions, the extension of a track selection would not work properly [5639]

Having a Live set containing many transient data could require a huge amount of memory during the opening of that Live set [5679]

Using +/- keys to control the zoom factor while highlighting a selection area would not work properly [5536]

When dragging devices from the browser into Session view, Live would not auto scroll to "out of sight" tracks [5710]

In a clip view, moving the loop brace would be constrained by the left border of the view [5719]

A Live set with devices locked to a particular controller surface would not work with that controller surface after reopening [5723]

On Windows, when allowing several instances of Live, processing a share link or the unlocking of Live would still start a second instance [5523]

Uninstalling a content package would fail when a sample contained in the package is currently active, like browser preview [5557]

'Gray' level meters would not become red on overload [2695]

Copy/Duplicate a track with input routing 'Resampling' would create a track with default input routing [5726]

On OS X, clicking into Live's video window could let the main window lose the focus

In a drum rack, changing the content of a pad would not update the arrow color [5709]

Reopening a set could show default name for a macro automation [5567]

Setting the scale factor via arrow up/down would not work for certain values [5160]

In some cases the Fade commands would be missing from context menus [5702]

A deactivated clip would still appear in the Arranger overview [5746]

Duplicate time or duplicate envelopes command would erase Live's global clipboard [5745]

Flatten a frozen MIDI track could crash Live depending on the currently selected envelope [5773]

Converting Simpler to Sampler while receiving parameter changes via MIDI controller would crash Live [5303]

If activated, a second running instance of Live would always show the Bug Reporting dialog on startup [4588]

Instant mappings for Multiband Dynamics and Vocoder would not work properly

Turning a knob on the APC 40 while toggling the Macro map mode could crash Live [5810]

Instant mappings for Collision would not work properly [5814]

Under certain conditions, the Utility effect would not take a gain automation into account [5721]

'Fold' would not work properly in a Drum Rack with 128 chains [5784]

Delay compensation would not work properly for devices before an External Audio Effect instance [5813]

Rendering tracks containing an Overdrive could lead to different results depending on the Overdrive parameter settings [5822]

Loading a Live set with a particular third party plug-in could crash Live when the plug-in instance could not be created [5795]

The AKAI MPD XX REW/FF buttons would not work when properly [5737]

Changing a track routing could make third party plugin window visible when it was hidden via Cmd/Ctrl+Alt+P [5799]

On Mac OS X, switching on the APC 40 or the Remote SL after Live is already started could still not allow to use the controller until its MIDI port was closed and reopened [1795]

On Mac OS X, exporting audio files could lead to Live hanging [5697]

magestro
Posts: 135
Joined: Fri Mar 14, 2008 10:11 am

Re: Live 8.0.5 change log

Post by magestro » Mon Sep 14, 2009 12:52 pm

on the DL, wow Abes that is a huge list, worth 12 betas :)

sacredgeometry
Posts: 197
Joined: Wed Feb 21, 2007 5:10 am

Re: Live 8.0.5 change log

Post by sacredgeometry » Mon Sep 14, 2009 3:26 pm

Beautiful im sure this will fix alot of the issues i was having, thank you for taking the time to release a extensive bugfix :) you guys are the best!
Peace + Hugs

Brian

WaveRider
Posts: 627
Joined: Mon May 16, 2005 2:33 pm
Location: Montreal

Re: Live 8.0.5 change log

Post by WaveRider » Mon Sep 14, 2009 3:46 pm

...so what's the deal with the 1 gig + download? (for the suite) .previously it used to be much smaller?

madlab
Posts: 1384
Joined: Fri May 02, 2003 6:38 am
Location: France

Re: Live 8.0.5 change log

Post by madlab » Mon Sep 14, 2009 4:17 pm

Nice but shall we ever see real control surface for the novation remote 25 ? Been waiting for this one for a very, very long time, specially considering there is support for the SL series.
Aboard from V. 1
MBP 2.5 Ghz I7 16 Go SSD OSX 10.12
MBP 2.3 ghz I7 16 Go SSD + HD 10.8.5 iPad2+Mira+Lemur/PadKontrol/BCR2000/ Livid Code+DS1
RME FF UC Live 9.7.7 MFL Max 8 + Max 7.3.5
Madlab sound unit / objects, guitar, electronics / end_of_transmission

simpli.cissimus
Posts: 518
Joined: Mon May 18, 2009 5:33 pm

Re: Live 8.0.5 change log

Post by simpli.cissimus » Mon Sep 14, 2009 4:17 pm

WaveRider wrote:...so what's the deal with the 1 gig + download? (for the suite) .previously it used to be much smaller?

So someone finds allways a reason to complain...!

This one is the most funniest of all...

Get more and cry...! LoL, what a ....!!!

Go and bye some other DAW...!
No! I'll never use the Push-App Live 9 !!!

sacredgeometry
Posts: 197
Joined: Wed Feb 21, 2007 5:10 am

Re: Live 8.0.5 change log

Post by sacredgeometry » Mon Sep 14, 2009 4:21 pm

I am still getting the crash problems i was getting before i am uploading a video showing this to youtube now.
Peace + Hugs

Brian

ark
Posts: 1354
Joined: Thu Feb 26, 2009 4:25 pm
Location: New Jersey, USA
Contact:

Re: Live 8.0.5 change log

Post by ark » Mon Sep 14, 2009 4:30 pm

WaveRider wrote:...so what's the deal with the 1 gig + download? (for the suite) .previously it used to be much smaller?
Not that I can recall.

posssu
Posts: 1117
Joined: Mon Dec 04, 2006 12:58 am

Re: Live 8.0.5 change log

Post by posssu » Mon Sep 14, 2009 5:45 pm

ark wrote:
WaveRider wrote:...so what's the deal with the 1 gig + download? (for the suite) .previously it used to be much smaller?
Not that I can recall.
It's always this big with the Suite-download, since the Suite-version contains the installation-files to Suite content.
Juhana Lehtiniemi - Film composer with Ableton Live

nuxnamon
Posts: 1770
Joined: Sun Oct 21, 2007 10:59 pm
Location: 650 area

Re: Live 8.0.5 change log

Post by nuxnamon » Mon Sep 14, 2009 9:48 pm

no bug fix for the multifunction looper button when using a pedal?

bagginz
Posts: 206
Joined: Fri Jan 19, 2007 5:51 pm
Location: Switzerland
Contact:

Re: Live 8.0.5 change log

Post by bagginz » Mon Sep 14, 2009 9:58 pm

Well done for your work Abe's :)

Cheers,
bagginz

madlab
Posts: 1384
Joined: Fri May 02, 2003 6:38 am
Location: France

Re: Live 8.0.5 change log

Post by madlab » Tue Sep 15, 2009 3:11 am

nuxnamon wrote:no bug fix for the multifunction looper button when using a pedal?
So sad :( :cry: :?
Aboard from V. 1
MBP 2.5 Ghz I7 16 Go SSD OSX 10.12
MBP 2.3 ghz I7 16 Go SSD + HD 10.8.5 iPad2+Mira+Lemur/PadKontrol/BCR2000/ Livid Code+DS1
RME FF UC Live 9.7.7 MFL Max 8 + Max 7.3.5
Madlab sound unit / objects, guitar, electronics / end_of_transmission

jbodango
Posts: 521
Joined: Tue Oct 05, 2004 11:25 pm
Contact:

Re: Live 8.0.5 change log

Post by jbodango » Tue Sep 15, 2009 4:04 am

On Mac OS X, exporting audio files could lead to Live hanging [5697]

OMG... i can't wait...

willrjmarshall
Posts: 87
Joined: Fri Apr 24, 2009 2:41 am

Re: Live 8.0.5 change log

Post by willrjmarshall » Tue Sep 15, 2009 4:13 am

When using the APC40 Controller surface script, we check if the selection MIDI ports are the one from the APC40
Please confirm: Will this stop my NativeControl APC40 scripts from working? They rely on MIDI interception between the APC40 and Ableton: which it sounds like this update will break.

8O
Posts: 5502
Joined: Fri Mar 28, 2008 9:29 am
Location: Berlin

Re: Live 8.0.5 change log

Post by 8O » Tue Sep 15, 2009 7:32 am

willrjmarshall wrote:
When using the APC40 Controller surface script, we check if the selection MIDI ports are the one from the APC40
Please confirm: Will this stop my NativeControl APC40 scripts from working? They rely on MIDI interception between the APC40 and Ableton: which it sounds like this update will break.
From the other thread: http://forum.ableton.com/viewtopic.php?f=1&t=124289...
clockwatcher wrote:
Fieldmedic wrote:
Changes from Live 8.0.4 to Live 8.0.5


Improvements:

When using the APC40 Controller surface script, we check if the selection MIDI ports are the one from the APC40
What does this mean? because it sounds like a safeguard against NativeKontrol and Bome's translator patches to me..
can anyone using a hacked APC40 setup and 8.0.5 speak on this?

thanks,
FM

NativeKontrol's apC-CL1 preset works fine with 8.0.5 for me.
Image

Post Reply