Page 1 of 1

APC40 Broken Fader (Fader 3)

Posted: Sun Nov 15, 2009 12:50 am
by blastique
Hey all,

As the topic name suggests, I'm in a bit of a dilemma and could really use your help!

My APC40 came outta my carry-bag with the fader AND the metal shaft seperate from the main unit - much like what happened to D K (http://forum.ableton.com/viewtopic.php?f=1&t=124493), however, in my case, the metal shaft seems to have taken some of it's plastic base (which would have been attached to the main board) with it! 8O

Desperate to DIY fix-it as soon as possible, I followed the methods posted by Illum on another thread to get into the unit. That proved successful, however, following removal of all the silver screws supposedly holding the mainboard to the top panel of the apc casing, I can't seem to pry them apart from each other (gently of course) in order to get to the topside of the mainboard :( Something seems to be holding it strongly on the right side of the unit (where the macro control / pan / send knobs are), contrary to the clip launch grid side.

The only reason I thought that I should sort this myself is that it seems like a relatively quick and simple thing fix, and I can hardly justify sending the unit off if it's going to take weeks to get back! (I live in Malaysia and I'd imagine this would require a fair bit of hassle, plus cost a fair bit to safely ship it off for repair to God-knows-where).

But, either way, I'm definitely stuck at this point. Any idea what I should do? What are my options?

It is just 3 months old and I've literally only played 9 gigs with it. I'm really disappointed with the build quality of this unit :( Even my shitty x-session pro faders took a better beating. :roll:

Looking forward to hearing everyone's thoughts. Cheers.

-Frustrated from KL

Re: APC40 Broken Fader (Fader 3)

Posted: Sun Nov 15, 2009 1:16 am
by deepdirtydub
Did you take off all the knobs on the top? afaik you have to in order to remove the top plate. Once thats off you'll have access to the faders. Sad to hear this. Good luck!

Re: APC40 Broken Fader (Fader 3)

Posted: Sun Nov 15, 2009 1:33 am
by blastique
Nope, no go. Unless you mean removing the washers and nuts. They seem to be responsible for holding it fast. This is a bigger pain in the ass than the time i had to repair a broken rotary knob on my BCF2000!

Should i take it that far (removing those nuts and washers) or admit defeat and have it fixed professionally?

Re: APC40 Broken Fader (Fader 3)

Posted: Sun Nov 15, 2009 1:44 am
by blastique
Ok removing the nuts and washers have done the trick. Almost done taking those off. Hope this fader issue is fixable! If not, i hope i haven't completely fucked up warranty (which I think I have, but didn't I lose that already by bringing this over from America?)

Re: APC40 Broken Fader (Fader 3)

Posted: Sun Nov 15, 2009 2:06 am
by blastique
Right, turns out the base of the fader to which it used to be attached to is completely wankered. No choice here but to figure out how to get it repaired officially. :cry: I guess it's for the better.

Posting pictures shortly...

Does anyone know what the the best way is to get this unit fixed in Asia, by qualified Akai technicians?