Surprise crackles during performance

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
ark
Posts: 1348
Joined: Thu Feb 26, 2009 4:25 pm
Location: New Jersey, USA
Contact:

Surprise crackles during performance

Post by ark » Mon May 17, 2010 3:04 pm

I played a set onstage using Live 8 yesterday, and one part of it had such severe crackling that I had to stop that part and play something else instead. Fortunately the audience liked the end product...but I'm still trying to figure out what happened.

Live 8.1.3, Windows XP SP3.

Here's what I know for certain.

1) I had tested the same Live set on the same laptop a couple of days before the performance. No problems.

2) I tested the same Live set on the same laptop again the night after the performance. No problems.

3) Before the actual performance, I set up everything, tested it (but unfortunately neglected to test that particular Live set), and put the laptop in standby before taking it onstage. In my home testing afterward, I did as much of the same stuff as I could remember.

4) I looked at the cpu meter while the problems were going on and do not recall it going above 50%.

5) I was running with 12ms latency. In my testing I could reduce it to 4ms before crackling started.

The Live set that failed was the one that used the most cpu of anything I did. The others all worked fine, which suggests that it was indeed a cpu problem. But what? Right now, all I can figure is that (a) Perhaps I inadvertently set the laptop's power management to something other than "maximum performance" and (b) the laptop became disconnected from its AC power source, therefore throttling back the cpu. But that's a pretty far-fetched theory.

I've heard about bugs that cause the machine to come back in slow-cpu mode after going into standby, so something like that could also be the problem. However, iin either this case or the last one, I would think I would see something anomalous about the cpu meter.

Any other suggestions for troubleshooting or experiments to try will be welcome.

Yeh
Posts: 71
Joined: Sat Jun 03, 2006 10:29 am
Location: Nijmegen, The Netherlands
Contact:

Re: Surprise crackles during performance

Post by Yeh » Mon May 17, 2010 5:09 pm

I use Live a lot live. In my experience it's starting with crackles if your laptop too long on (stand by or busy). A friend said something about memory getting full.

So if I play live. I turn the laptop on to test it and then swith it off until a few minutes before performing.
Kind regardz,

Jos
http://www.portonova.nl

Ableton Live 8, Cubase 7, Melodyne Editor 2, Halion 4, Presonus Audiobox 44VSL soundcard, Windows 8, 64 bit, i5, 6 Gig RAM

ark
Posts: 1348
Joined: Thu Feb 26, 2009 4:25 pm
Location: New Jersey, USA
Contact:

Re: Surprise crackles during performance

Post by ark » Mon May 17, 2010 5:31 pm

Yeh wrote:I use Live a lot live. In my experience it's starting with crackles if your laptop too long on (stand by or busy). A friend said something about memory getting full.
From when I first turned it on until I started playing was less than an hour, and Live was not running during that time.

chris vine
Posts: 674
Joined: Fri Jul 22, 2005 2:01 am
Location: Brazil

Re: Surprise crackles during performance

Post by chris vine » Tue May 18, 2010 12:27 am

Have also had some surprises.

On my laptop I have definitely noticed some strange stuff after coming out of standby and also even if the Live window is minimized for any length of time.

So yeh, I switch the machine off - or just leave it on all day.

On my last show I had to up the buffer to 512, was getting clicks from midi instruments when playing, CPU meter jumping about - same old set, as usual had disabled any other stuff like antivirus (actually, fuck it, I DELETED the AV, quite happy without that) and the firewall (which I didn't delete :) ) beats me why it was playing up.

also 8.1.3 and XP SP3.

Happy with 8.1.3 in general tho.........

bartosz szczesny
Posts: 26
Joined: Sun Jul 05, 2009 3:33 pm
Location: Poznan, Poland
Contact:

Re: Surprise crackles during performance

Post by bartosz szczesny » Tue May 18, 2010 8:09 am

I had a massive problems on my last gig. I playback 32bit .wav files: I`ve discovered, that RAM memory is actually shrinking when audio clip is played back. When the memory is filled (2,5 GB on my laptop) - a pause, drops and crackles occurs. I`ve reported it to support a week ago (Case ableton392541) but I`ve got still no response.

Win 7 x64, core2duo

Post Reply