Intel I7 not using Multicore???

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
olpo
Posts: 3
Joined: Thu Jul 08, 2010 10:24 pm

Intel I7 not using Multicore???

Post by olpo » Thu Jul 08, 2010 10:44 pm

Hello!
I moved from a 2 Ghz dual Core XP Machine to a 1.6-3.0 Ghz Quadcore Intel I7 on Windows 7 64 Bit.
I expected a strong performance boost - but - it is all the same. I have a few days left to be able to return the new machine and I would be very happy for any advice. I have a song with lots of PlugIns that keeps having dropouts on both machines. I wonder why?
I have multicore support turned on on both machines.

What is extremely strange: On the new machine (the I7) performance seems to get a bit better if I turn multicore support off!

Meter on the benchmark song is always around 50% with peaks up to 70% - on both the old and the new machine.

I have a (cheapo) Edirol UA-1ex soundcard running on its maximum buffer size. Might it be the problem?

How can I boost the performance on the new machine? If I can't I need to return it!

Many thanks for your help in advance!

fisto
Posts: 354
Joined: Fri Jun 26, 2009 4:06 pm

Re: Intel I7 not using Multicore???

Post by fisto » Thu Jul 08, 2010 11:21 pm

I've also got a new Win7 intel I7 machine with a few little tweaks and it runs perfect.
You should disable: - the "core parking" (googl it) and disable "Default tollerant heap".
Also look for blackvipers Win7 services list. I've disabled all the services under the"tweaked" column,
and the machine now runs as hell and very snappy too.
Also set the powermanagment to high performance.
Go to advanced system-settings and set the priority to "backround services"
There is great thread about windows 7 daw optimization on the cakewalk sonar homepage
After this you will have a boost for sure :-)

cheers

The Carpet Cleaner
Posts: 1128
Joined: Sat May 16, 2009 2:21 pm
Location: Paris

Re: Intel I7 not using Multicore???

Post by The Carpet Cleaner » Fri Jul 09, 2010 10:40 am

fisto wrote:I've also got a new Win7 intel I7 machine with a few little tweaks and it runs perfect.
You should disable: - the "core parking" (googl it) and disable "Default tollerant heap".
Also look for blackvipers Win7 services list. I've disabled all the services under the"tweaked" column,
and the machine now runs as hell and very snappy too.
Also set the powermanagment to high performance.
Go to advanced system-settings and set the priority to "backround services"
There is great thread about windows 7 daw optimization on the cakewalk sonar homepage
After this you will have a boost for sure :-)

cheers
lol hopefully I bought a mac.

fisto
Posts: 354
Joined: Fri Jun 26, 2009 4:06 pm

Re: Intel I7 not using Multicore???

Post by fisto » Fri Jul 09, 2010 11:04 am

@the carpet cleaner: great for you dude, but you've paid at least twice the price i paid so.....hmmmmm

Donnie
Posts: 810
Joined: Thu Aug 07, 2008 3:16 pm
Location: Chicago Suburbs
Contact:

Re: Intel I7 not using Multicore???

Post by Donnie » Fri Jul 09, 2010 12:03 pm

Twice the price is easily worth saving people 5 min of setting adjustment lol!

Seriously though, first thing id check is power management settings.

olpo
Posts: 3
Joined: Thu Jul 08, 2010 10:24 pm

Re: Intel I7 not using Multicore???

Post by olpo » Fri Jul 09, 2010 6:46 pm

Damn you Power Management!
I turned off core parking and this peak thing. This at least made the load appear on all of the cores in the task manager.
But performance still was not good.
Yes, it was this stupid power management setting, that finally lead to good results. Shame on me I should have known that!
But I think it is the combination of core parking off and power management that brought the best performance boost.

Many thanks to all of you who helped me out on this one, especially fisto and donnie.

Woohoo! Runs as slick as an eel now. Great!

Post Reply