Sound is distorted. Audio engine problems ?

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
forrestpiano
Posts: 4
Joined: Fri Oct 08, 2010 11:17 pm

Sound is distorted. Audio engine problems ?

Post by forrestpiano » Fri Oct 08, 2010 11:53 pm

- Especially one project is teasing me..
When I load it up the sound is distorted and kind of stutters.. It stops when i switch the audio engine off, and back on, though i do not see this as a long time solution...

This has been going on since i got live 8 suite and my mac 2,66 ghz processor, i have a lowbudget soundcard presonus firebox

I do big projects (i make soundtracks and such with a lot of audio samples, a lot of drums and a lot of bass ) In the mentioned project i have 8 audio tracks, 9 drum tracks, and about 20 live instruments... This might be a lot but it is my style, and id like to find a way to make it work

Any Ideas?

4.33
Posts: 1198
Joined: Tue Jul 03, 2007 12:49 pm
Location: Moscow

Re: Sound is distorted. Audio engine problems ?

Post by 4.33 » Sat Oct 09, 2010 4:23 am

- try increasing the buffer as the track count increases
- try asio4all driver instead of the stock one (oops, sorry you're a mac)
- see if any plugin is causing that

OCDaveWilcox
Posts: 36
Joined: Thu Sep 30, 2010 12:56 am

Re: Sound is distorted. Audio engine problems ?

Post by OCDaveWilcox » Sat Oct 09, 2010 4:38 am

forrestpiano wrote:- Especially one project is teasing me..
When I load it up the sound is distorted and kind of stutters.. It stops when i switch the audio engine off, and back on, though i do not see this as a long time solution...
I'm on a Mac Pro and I have an Apogee Ensemble (not a cheap unit at all) and I have had this happen to me more than once. One time it was so bad that I couldn't fix it at all. I had to format and reinstall the Mac. I never figured out what was plaguing Ableton.

It happened again serval months later but was some how resolved by updating to the latest version of Live.

It was because of all this I started to question even using a Mac at all, I thought with the Mac I should be free from these kind of lame ass issues. I would switch to PC in a heartbeat if only my stupid sound card had drivers for Windows.

Good luck. Let me know if you get it fixed.

Tarekith
Posts: 17457
Joined: Fri Jan 07, 2005 11:46 pm
Location: Ableton Forum Administrator
Contact:

Re: Sound is distorted. Audio engine problems ?

Post by Tarekith » Sat Oct 09, 2010 4:53 am

OMG you're doing it wrong.

LeifonMars
Posts: 1104
Joined: Fri Jan 12, 2007 11:48 am

Re: Sound is distorted. Audio engine problems ?

Post by LeifonMars » Sat Oct 09, 2010 6:27 am

Tarekith wrote:OMG you're doing it wrong.
No, he's not. Clearly, Lives audio engine has problems, and is inferior to that of PT. :D :) :( :o 8O :? 8) :lol: :x :P :oops:

To op: How about freezing some of those 200 synths and drumracks or flattening? Is HD full? That causes problems as well - try external HD to drive your projects from.
Last edited by LeifonMars on Sat Oct 09, 2010 6:01 pm, edited 2 times in total.
MBP OSX 10.6.8, Live 8.4, MFII, Evolver, Monomachine, Octatrack, APC40, Launchpad

forrestpiano
Posts: 4
Joined: Fri Oct 08, 2010 11:17 pm

Re: Sound is distorted. Audio engine problems ?

Post by forrestpiano » Sat Oct 09, 2010 1:56 pm

4.33 wrote:- try increasing the buffer as the track count increases
- try asio4all driver instead of the stock one (oops, sorry you're a mac)
- see if any plugin is causing that
I´ve tried increasing the buffer - it does not help a thing - but you´re right its the same stutter as when the buffersize can not drive the lot

Ill try see if I can find a different driver - thank you

forrestpiano
Posts: 4
Joined: Fri Oct 08, 2010 11:17 pm

Re: Sound is distorted. Audio engine problems ?

Post by forrestpiano » Sat Oct 09, 2010 2:12 pm

OCDaveWilcox wrote:
I'm on a Mac Pro and I have an Apogee Ensemble (not a cheap unit at all) and I have had this happen to me more than once. One time it was so bad that I couldn't fix it at all. I had to format and reinstall the Mac. I never figured out what was plaguing Ableton.

It happened again serval months later but was some how resolved by updating to the latest version of Live.

It was because of all this I started to question even using a Mac at all, I thought with the Mac I should be free from these kind of lame ass issues. I would switch to PC in a heartbeat if only my stupid sound card had drivers for Windows.

Good luck. Let me know if you get it fixed.
Actually I also started questioning my dedication to mac untill I saw this happen on pc´s aswell (never as bad though). I think its somewhat the driver for the soundcard and the sound engine that has issues. But its weird since mac is so good at integrating drivers.

Ill keep it up. Thank you for your response. Ill let you know

forrestpiano
Posts: 4
Joined: Fri Oct 08, 2010 11:17 pm

Re: Sound is distorted. Audio engine problems ?

Post by forrestpiano » Sat Oct 09, 2010 2:22 pm

LeifonMars wrote:
No, he's not. Clearly, Lives audio engine has problems, and is inferior.

To op: How about freezing some of those 200 synths and drumracks or flattening? Is HD full? That causes problems as well - try external HD to drive your projects from.
HD isnt full. It also happened with my old mac, but got more severe when i got the new one. Ableton was the first thing installed and the only thing for a long time, so its more than a full HD.

Ill definetly try freezing/flattening... Though I think its as you say its the audio engine thats the bad guy, but i just need it not to start stuttering, especially in live situations

Thank you for your response!

synnack
Posts: 2053
Joined: Fri Mar 02, 2007 10:55 pm
Location: Boston, MA
Contact:

Re: Sound is distorted. Audio engine problems ?

Post by synnack » Sun Oct 10, 2010 3:00 pm

Tarekith wrote:OMG you're doing it wrong.

These forums clearly need a facebook-style "like" button.
MBP | Live 9 Suite | Max for Live | Push | MOTU Ultralite | iPad | Analog Modular Synths | Moog Voyager
aka "Tempus3r" | Music | Blog | Twitter | Soundcloud

Image

dna598
Posts: 831
Joined: Tue Sep 23, 2008 3:42 am

Re: Sound is distorted. Audio engine problems ?

Post by dna598 » Sun Oct 10, 2010 3:25 pm

I often have to switch my Audiofire12 on and off when it starts crackling upon playback in OSX.

I think its a mac/firewire issue.
ctrl + left/right = select transient

ctrl + shift + left/right = select between transients

ctrl + space = play selection

OCDaveWilcox
Posts: 36
Joined: Thu Sep 30, 2010 12:56 am

Re: Sound is distorted. Audio engine problems ?

Post by OCDaveWilcox » Mon Oct 11, 2010 8:17 pm

I've had the exact same issue as the OP on fresh projects with only 1 instrument and buffers of all sizes on an interface better than most people here. I'm not doing it wrong. Also weird enough is the problem was only in Live, it would play perfectly in Logic and other apps.

It's Live's audio engine for whatever reason.

B3
Posts: 64
Joined: Sat Nov 06, 2004 1:25 am

Re: Sound is distorted. Audio engine problems ?

Post by B3 » Fri Oct 29, 2010 8:25 pm

Having the same audio crackling issues. Even small projects with 4 - 5 midi tracks. Have to switch audio engine off/on to make crackling stop.
iMac 27", 24 GB RAM, 3.4 GHz Intel Core i7
Mac OSX 10.9
Ableton Live 9.1.4 + Push
UAD Apollo Quad

Rave
Posts: 6152
Joined: Mon Oct 03, 2005 9:26 am

Re: Sound is distorted. Audio engine problems ?

Post by Rave » Sat Oct 30, 2010 7:24 am

I used to get this with my duet on my mini and the only cure was to switch the audio engine off and on in live.
I havent had this issue on my new iMac though. I think it is CPU related.

What version of live u using?

B3
Posts: 64
Joined: Sat Nov 06, 2004 1:25 am

Re: Sound is distorted. Audio engine problems ?

Post by B3 » Sat Oct 30, 2010 6:27 pm

I'm using 8.2.1.

I unhooked the duet and restarted my machine, then hooked the duet back up again. Problem seems to have gone away for a bit. I've also e-mailed Apogee support. This problem also affected my NI Kore Controller yesterday, so I'm not entirely sure it's duet related. Things seem to point to Live's Audio engine or ???
iMac 27", 24 GB RAM, 3.4 GHz Intel Core i7
Mac OSX 10.9
Ableton Live 9.1.4 + Push
UAD Apollo Quad

lapieuvre
Posts: 712
Joined: Wed Sep 26, 2007 9:29 pm

Re: Sound is distorted. Audio engine problems ?

Post by lapieuvre » Sat Oct 30, 2010 6:58 pm

Top right of the screen: do you see the D button light to orange?
Mac OSX 10.13.6
Live 9.7.6 Suite
Live 10.1.2 Suite
Soundcards : FF800, Apollo Twin duo

Post Reply