Crossfader and CPU usage

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
jtenney
Posts: 75
Joined: Mon Nov 08, 2004 8:11 am
Location: Lafayette CA USA
Contact:

Crossfader and CPU usage

Post by jtenney » Wed Mar 02, 2005 3:33 am

Hey all--

Is it always true that using the crossfader (especially fairly quickly) causes a spike in CPU? I notice it consistently jumping 15-20 points just for those few seconds. Settles back pretty OK, but there's the potential for audio dropouts at that point. Any thoughts? Could it be my Mac? I'm running a complex live set on 512 mb RAM, but I've made a point to close other programs so I've had an easier time beating the dropouts.

later,
John
www.soundclick.com/johntenney

iMac G5, Reason 3.0, Live 5, Peak 5.01 LE, mp3 Trimmer, Finale 2006, various VSTs, Yamaha PSR 170 keyboard (cheap midi controller), Evolution UC33e (not so cheap midi controller)

AdamJay
Posts: 4757
Joined: Thu Mar 11, 2004 7:17 pm
Location: Indianapolis, USA

Post by AdamJay » Wed Mar 02, 2005 3:39 am

jtenney
no spikes here... if only a 1% spike.
have you repaired permissions lately? thats the default "is something wrong with my mac?" recommendation.

jtenney
Posts: 75
Joined: Mon Nov 08, 2004 8:11 am
Location: Lafayette CA USA
Contact:

Post by jtenney » Wed Mar 02, 2005 3:44 am

Adamjay, I have Macaroni installed, which is routinely repairing permissions every week. I think that should be taking care of it, but I'll maybe do a manual extra just to be sure. Thanks.
www.soundclick.com/johntenney

iMac G5, Reason 3.0, Live 5, Peak 5.01 LE, mp3 Trimmer, Finale 2006, various VSTs, Yamaha PSR 170 keyboard (cheap midi controller), Evolution UC33e (not so cheap midi controller)

timothyallan
Posts: 5788
Joined: Wed Nov 24, 2004 11:05 pm
Location: Melbourne Australia
Contact:

Post by timothyallan » Thu Mar 03, 2005 12:44 am

are you using a controller?

I get big spikes while doing that, but using usb midi controller, i believe its either usb/midi transmission and not just limited to the crossfader (it does the same thing for any mapped control)... or is it only the crossfader on yours?

-tim

AdamJay
Posts: 4757
Joined: Thu Mar 11, 2004 7:17 pm
Location: Indianapolis, USA

Post by AdamJay » Thu Mar 03, 2005 12:55 am

i get no spikes using the UC33, with any of the sliders/knobs routed to the crossfader... :?

Post Reply