Page 1 of 1

Track MIDI filtering...

Posted: Fri Jul 27, 2012 1:36 pm
by Mister36
Is there any way to stop Live filtering out repeated MIDI messages sent into a MIDI track?

I have a MIDI controller that has three incremental encoders i.e., with "notches" like are often used for scrolling through tracks in DJ software and turning clockwise sends a CC message with value 65 and anti-clockwise sends the same CC message but with value 63, so using it with Live's "relative (binoffset)" mode, it can be used as a regular encoder.

HOWEVER, the subsequent repeats of either clockwise/anti-clockwise turns get swallowed up by Live. :(

I have tried the Options.txt commands found in this thread: viewtopic.php?f=4&t=177825
But the ones I want and think might work don't work ("MidiEventThinning" and "NoMidiEventFiltering"), but this might be because they only work on OS X and I'm on Windows 7 (x64).

NB The reason I don't just use the controller enabled as a remote is that I send all my controllers through MIDI tracks and out to Bome's for processing - never had a problem with it until now. I can confirm, though, that the MIDI controller is still sending the repeat messages i.e., MIDI in indicator lights up both in the top right and on the track just isn't sent out again.

Sorry for writing so much, but I hope someone can/will help me. Thanks.

Re: Track MIDI filtering...

Posted: Fri Jul 27, 2012 3:55 pm
by Mister36
The OP's second issue in this thread is what I, too, am experiencing: viewtopic.php?f=2&t=135797

Anyone know a way round it? Or is that just how Live works? Akin to the MIDI channel filtering when routing internally...

Re: Track MIDI filtering...

Posted: Fri Jul 27, 2012 4:38 pm
by Mister36
Thanks for responding, appreciated.

In order to do what I want, I enable the TRACK button just for input in Preferences, so that I can create a MIDI track to take the MIDI data from my controller and send it out to Bome's on a virtual cable (where it may be processed and returned to Live on another virtual cable enabled as REMOTE).
I have also tried enabling TRACK for the output, but, unsurprisingly, that has no positive effect.

The incremental encoders do work as expected when enabled directly as a REMOTE input and it is clear that something within a MIDI track filters repeated CC messages i.e., ones with identical data.

Re: Track MIDI filtering...

Posted: Sat Jul 28, 2012 9:51 am
by Mister36
Anyone? Driving me a bit mental... Though I realise that this is likely but unfortunately just the way Live works.

Re: Track MIDI filtering...

Posted: Sat Jul 28, 2012 11:41 am
by broc
Yes, it's a "feature" of Live.

As a workaround you could insert some app like BOME into the midi input path and generate a dummy CC with a different value immediately before passing the original message.

Re: Track MIDI filtering...

Posted: Sat Jul 28, 2012 11:53 am
by Mister36
Thanks for confirming. At least it's not me going crazy.

Unfortunately, I'm already using Bome's and the reason I wanted it to work the way I outlined above is so that all my controllers go through Live tracks and then to Bome's. But it's alright, I figured another workaround involving using a mixture of REMOTE mappings and the rerouted mappings, which will have to suffice. Seems a bit strange this is a "feature" that can't be bypassed. Even with those Options.txt commands.

Thanks again.