Changing default input for new MIDI track from "All Inputs"?

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
jasefos
Posts: 534
Joined: Sun Jan 11, 2004 6:31 am
Location: Melbourne, Australia
Contact:

Changing default input for new MIDI track from "All Inputs"?

Post by jasefos » Wed Aug 29, 2012 12:54 am

Hi Ableton Heads,

Long time no post!

I've been busy integrating a large array of elderly hardware synths back into my studio rig and having a blast enjoying sequencing them from Live 8.3.3. I've also integrated a Innerclock systems Sync Gen (goodbye MIDI clock problems for good!) which has resulted in the need for a fairly elaborate array of MIDI Merg/Split/Thru boxes and patch bays. In particular I wanted to give my hardware synths a SysEx output path back to various SysEx editor applications without needing dedicated MIDI ports for each synth - instead, I'm using a MIDI Solutions 8input 1output merge box.

I encountered a situation within my rig whereby if I have *any* one MIDI track in my Live projects set to "All Inputs" that I get a MIDI feedback loops. I found that the feedback problem is solved by ensuring all MIDI tracks in my Ableton projects have their inputs set to the specific port for my MIDI master keyboard (the Arturia Laboratory 61 note).

So here is my actual question:
Is there a special setting within Live to change the default port for any new MIDI track added from "All Inputs" to a specific MIDI port?

Of course, I can just make sure my template has this predefined for my MIDI tracks ... It's when I add new MIDI tracks to my template, I have to remind myself to change the Input port for the track each time.

Cheers

JaseFOS
JaseFOS

-Live10.1 |Push2|Maschinemk2|KeyLab61|LaunchPad|MCUpro|MCExt|MCExt|iPad2|TouchABLE2
-Mac Pro 5.1 (dual hex core Xeon 3.46gHz, 28Gb RAM) running MacOS 10.13.6
-Universal Audio Apollo Quad (firewire)
-SHITLOADS OF HARDWARE SYNTHS

Post Reply