Undo (Ctrl+Z) randomly does not work (Live 9.0.1)

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
BrunoAnthony
Posts: 15
Joined: Tue Dec 13, 2011 8:24 pm

Re: Undo (Ctrl+Z) randomly does not work (Live 9.0.1)

Post by BrunoAnthony » Tue Aug 06, 2013 11:27 pm

Hi have the same problem, does anyone know how to fix this??? As i can only undo 1 time.
Its driving me insane. I have been mucking about with some stuff out of my live 8 library for sounds with analog.
But this should not happen.

tigali
Posts: 452
Joined: Thu Dec 18, 2008 6:49 pm
Location: Ireland

Re: Undo (Ctrl+Z) randomly does not work (Live 9.0.1)

Post by tigali » Wed Aug 07, 2013 11:13 pm

Only two issues I have noticed with Live 9 so far is this randomly Cmd+z not working and the pencil tool not working on a couple of occasions. Seemed impossible to recreate either event.

noahmusic
Posts: 1
Joined: Tue Mar 11, 2014 11:29 pm

Re: Undo (Ctrl+Z) randomly does not work (Live 9.0.1)

Post by noahmusic » Tue Mar 11, 2014 11:32 pm

I have found the same issue.

Command Z and UNDO from the Menu Bar intermittently DO NOT WORK...

When I accidentally moved a region to another spot and tried to undo it... It did nothing.

When moving MIDI notes and trying to undo .. it did nothing.

This has happened several times lately and is very bad for work flow.

Please look into this.

Thanks.

CaptainU
Posts: 15
Joined: Sun Oct 13, 2013 4:56 pm

Re: Undo (Ctrl+Z) randomly does not work (Live 9.0.1)

Post by CaptainU » Tue Jul 08, 2014 2:55 pm

Same problems for me. If anyone still has this issue here's my solution.

I eventually found this article on the main Ableton site. Slightly different issue but it worked perfectly for me. 'Undo' restored to normal operations :-)
Please try trashing the Undo.cfg file and the Preferences.cfg file. You will find these files in the following paths:

Windows XP
\Documents and Settings\[username]\Application Data\Ableton\Live x.x.x\Preferences\
Windows Vista, Windows 7, Windows 8
\Users\[username]\AppData\Roaming\Ableton\Live x.x.x\Preferences\
Mac OS X
/Users/[username]/Library/Preferences/Ableton/Live x.x.x/

aukleive
Posts: 17
Joined: Sat Aug 13, 2005 6:56 pm
Location: Norway

Re: Undo (Ctrl+Z) randomly does not work (Live 9.0.1)

Post by aukleive » Sat Aug 02, 2014 4:58 pm

Still true in 9.1.4!
I have to bypass both a m4l-delay AND Eventide HD3000, which both have randomized parameters.
Hopeless!
For instance It means if you delete piece of a track in arrange-mode, you may have to undo maybe 50 times to restore…

!

mgunthe
Posts: 13
Joined: Tue Nov 22, 2011 7:02 am

Re: Undo (Ctrl+Z) randomly does not work (Live 9.0.1)

Post by mgunthe » Wed Feb 11, 2015 2:33 am

Same problem here.
This is a major issue.
Just had someone record a vocal track and didn't notice that record was armed for all live drum tracks (8 audio channels) because it was under a "drum" subgroup and the vocal track just wiped out all of the drum tracks.

Now control z does not work.

Fortunately I have backups so it will be ok but still a MAJOR headache for a pretty simple function that works fine in most software.

mgunthe
Posts: 13
Joined: Tue Nov 22, 2011 7:02 am

Re: Undo (Ctrl+Z) randomly does not work (Live 9.0.1)

Post by mgunthe » Wed Feb 11, 2015 2:39 am

Just figured out the answer (and correct me if I'm wrong here) but it looks like if you 'save' you can no longer undo changes.
Wow.

irrelevance
Posts: 463
Joined: Tue May 20, 2008 7:31 pm

Re: Undo (Ctrl+Z) randomly does not work (Live 9.0.1)

Post by irrelevance » Wed Feb 11, 2015 9:08 am

I get this also but always seem to cure it by deleting offending max devices.

H20nly
Posts: 15843
Joined: Sat Oct 27, 2007 9:15 pm
Location: The Wild West

Re: Undo (Ctrl+Z) randomly does not work (Live 9.0.1)

Post by H20nly » Fri Feb 13, 2015 3:19 am

mgunthe wrote:Just figured out the answer (and correct me if I'm wrong here) but it looks like if you 'save' you can no longer undo changes.
Wow.
that's pretty common.

i'm not saying i like it or dislike it, but i have seen that in a lot of applications during the years.

it looks like that could be the issue for some, but not for everyone.

doc$
Posts: 31
Joined: Wed Aug 15, 2007 11:16 pm

Re: Undo (Ctrl+Z) randomly does not work (Live 9.0.1)

Post by doc$ » Thu Apr 23, 2015 12:44 am

this is terrible.

I'm getting the 'Livetoggle.32' or some other random number under undo

I have had this problem before

I can't remember how to fix it

I guess I need to keep a text file of the 10's (maybe 100's) of Ableton problems so that I can fix them when they arise, because the problems are CONSTANT

ableton is too expensive for this shit support and all these problems. period.

Valiumdupeuple
Posts: 1044
Joined: Mon May 31, 2010 12:36 pm
Contact:

Re: Undo (Ctrl+Z) randomly does not work (Live 9.0.1)

Post by Valiumdupeuple » Thu Apr 23, 2015 8:58 am

Hey guys, this is not a Live bug; this is due to un-optimized M4L devices that you're using in your set.

ra78
Posts: 38
Joined: Tue Apr 12, 2011 12:47 pm
Location: Kiev, Ukraine
Contact:

Re: Undo (Ctrl+Z) randomly does not work (Live 9.0.1)

Post by ra78 » Wed Feb 24, 2016 8:39 am

Dont agree. Just meet this kind of behavior in the project with no M4L devices.

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Undo (Ctrl+Z) randomly does not work (Live 9.0.1)

Post by Stromkraft » Wed Feb 24, 2016 2:56 pm

ra78 wrote:Dont agree. Just meet this kind of behavior in the project with no M4L devices.
And you have not just saved the set?
Make some music!

gendhing
Posts: 2
Joined: Wed Aug 10, 2016 1:17 pm

Re: Undo (Ctrl+Z) randomly does not work (Live 9.0.1)

Post by gendhing » Wed Aug 10, 2016 1:25 pm

I hv same issue i just can do 1 step undo and i worked in live 8, can please someone help me?

Tarekith
Posts: 17411
Joined: Fri Jan 07, 2005 11:46 pm
Location: Ableton Forum Administrator
Contact:

Re: Undo (Ctrl+Z) randomly does not work (Live 9.0.1)

Post by Tarekith » Wed Aug 10, 2016 1:48 pm

Did you save the set before you tried to use Undo?

Post Reply