Live 9.0.1 Suite takes long to load and too long to save!

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
The Philosopher King
Posts: 190
Joined: Sun Oct 26, 2008 7:56 pm

Re: Live 9.0.1 Suite takes long to load and too long to save!

Post by The Philosopher King » Tue Jul 09, 2013 10:26 pm

OK, here are the results of Todays Testing:

files = 511,160 KB
files.db-shm = 32 KB
files.db-wal = 9,676 KB

Saving is a lot quicker than it was previously.
A serious program error has occurred.
Live will shut down after this message box is closed.

miekwave
Posts: 752
Joined: Fri Aug 03, 2012 8:49 pm
Location: Austin, TX
Contact:

Re: Live 9.0.1 Suite takes long to load and too long to save!

Post by miekwave » Wed Jul 10, 2013 3:59 am

The Philosopher King wrote:After restarting my Laptop and deleting all three files, I restarted Ableton:

Mesage: 'Setting up Core Library...'

File sizes are now as follows:

files = 1 KB
files.db-shm = 224 KB
files.db-wal = 25,373 KB

Quite a difference (see previous post for original values).

I'll see how Ableton behaves later on during the day.
Im glad that worked out for you. Files.db throttled my disk and I am currently waiting for feedback from ableton tech support. They told me about 50MB was typical for files.db, my files.db file was greater than 1.7GB and it took ableton more than 1 hour to open and reindex. If you Intend to index a large dataset indexed, install ableton live on a Ssd disc where the files.db is loaded at greater than 50MBs, wheras on hdd it is read at 1-2MBs.

My work around was to disable some security settings in order to allow me to drag clips from file explorer, which is inconvenient considering Its a alotvfaster to load from the libraries folder.
Check out some of my soundtracks. Also Ableton Live Performance video.

ImageImage

miekwave
Posts: 752
Joined: Fri Aug 03, 2012 8:49 pm
Location: Austin, TX
Contact:

Re: Live 9.0.1 Suite takes long to load and too long to save!

Post by miekwave » Wed Jul 10, 2013 4:09 am

The Philosopher King wrote:OK, here are the results of Todays Testing:

files = 511,160 KB
files.db-shm = 32 KB
files.db-wal = 9,676 KB

Saving is a lot quicker than it was previously.
Oh and one more thing for other PC users running large file sets.

I tested it again myself... deleting the Files.db file and restarting ableton gives it a fresh, faster loading index file. When you keep adding or deleting files or folder content contained in your ableton library custom folders it causes the files.db file to become fragmented.... I verified this using a 3rd party disc defrag tool and discovered that my files.db file was scattered across more than 100 sectors (sections on the hdd platter). This makes the index throttle causing longer load and wait times. So be sure to defragment your drive AFter deleting the files.db file and before loading ableton again... after performing this, my ableton live opens up in less than 10 seconds and my mega projects took less than 30 seconds to load, as opposed to 2 or 3 minutes.
Check out some of my soundtracks. Also Ableton Live Performance video.

ImageImage

miekwave
Posts: 752
Joined: Fri Aug 03, 2012 8:49 pm
Location: Austin, TX
Contact:

Re: Live 9.0.1 Suite takes long to load and too long to save!

Post by miekwave » Wed Jul 10, 2013 4:11 am

And lastly, disable realtime virus scanning while running ableton. The realtime file scans on your virus software also throttles the disc.
Check out some of my soundtracks. Also Ableton Live Performance video.

ImageImage

The Philosopher King
Posts: 190
Joined: Sun Oct 26, 2008 7:56 pm

Re: Live 9.0.1 Suite takes long to load and too long to save!

Post by The Philosopher King » Wed Jul 10, 2013 4:27 am

Some good tips in your posts there miekwave.
I've taken a note of all of them. I hope Ableton have too. :wink:

Thanks again for your advice.
A serious program error has occurred.
Live will shut down after this message box is closed.

tintala
Posts: 458
Joined: Mon Nov 29, 2010 5:37 pm

Re: Live 9.0.1 Suite takes long to load and too long to save!

Post by tintala » Thu Jul 11, 2013 1:18 am

Im on a PC w7 and it takes 10 minutes to shut down for me, I do have alot.. but it also takes 5 minutes to save... it is slower than 8.

phonographiq
Posts: 105
Joined: Thu Aug 26, 2010 7:08 pm

Re: Live 9.0.1 Suite takes long to load and too long to save!

Post by phonographiq » Mon Jul 29, 2013 12:01 am

My copy of Ableton 9.0.1 on a 2008 Macbook was running crisp as ever, never had a hiccup. The last two weeks I too have experienced up to ten minutes + multiple 'not responding' force quits. Got me pulling my freakin hair out, got deadlines I'm trying to meet and cannot for the life of me figure out what happened here. :( :( :(
rhythmic surrealism / philadelphia / $$$
http://soundcloud.com/phonographiq

miekwave
Posts: 752
Joined: Fri Aug 03, 2012 8:49 pm
Location: Austin, TX
Contact:

Re: Live 9.0.1 Suite takes long to load and too long to save!

Post by miekwave » Mon Jul 29, 2013 2:47 pm

phonographiq wrote:My copy of Ableton 9.0.1 on a 2008 Macbook was running crisp as ever, never had a hiccup. The last two weeks I too have experienced up to ten minutes + multiple 'not responding' force quits. Got me pulling my freakin hair out, got deadlines I'm trying to meet and cannot for the life of me figure out what happened here. :( :( :(
9.0.1 is buggy, upgrade to 9.0.4 or 9.0.5 as patches adressed some loadtime issues with saving
Check out some of my soundtracks. Also Ableton Live Performance video.

ImageImage

phonographiq
Posts: 105
Joined: Thu Aug 26, 2010 7:08 pm

Re: Live 9.0.1 Suite takes long to load and too long to save!

Post by phonographiq » Mon Aug 12, 2013 6:27 pm

I took the advice and bumped up to 9.0.4 and still it persists, no difference at all after a day or two of experimenting :(

I just wish I could go back to Live 8 for a while, or at least just for shows + djing but most of my stuff is saved as L9, ugh.
rhythmic surrealism / philadelphia / $$$
http://soundcloud.com/phonographiq

The Philosopher King
Posts: 190
Joined: Sun Oct 26, 2008 7:56 pm

Re: Live 9.0.1 Suite takes long to load and too long to save!

Post by The Philosopher King » Mon Aug 12, 2013 7:07 pm

phonographiq wrote:I took the advice and bumped up to 9.0.4 and still it persists, no difference at all after a day or two of experimenting :(

I just wish I could go back to Live 8 for a while, or at least just for shows + djing but most of my stuff is saved as L9, ugh.
Live 9.0.5 is no better.
A serious program error has occurred.
Live will shut down after this message box is closed.

eyeknow
Posts: 5822
Joined: Fri Jul 15, 2005 6:16 am

Re: Live 9.0.1 Suite takes long to load and too long to save!

Post by eyeknow » Mon Aug 12, 2013 7:43 pm

See, I don't agree. I think 9.05 is pretty fast unless you load a template with a bunch of slow stuff, and even then it's only slow the first launch of the day. Studio one takes quite some time to load the first time, much slower just as an example.

djadonis206
Posts: 6488
Joined: Thu Jun 17, 2004 4:23 pm
Location: Seattle, WA.

Re: Live 9.0.1 Suite takes long to load and too long to save!

Post by djadonis206 » Mon Aug 12, 2013 7:47 pm

Since updating to 9.0.5 Live loads, saves and closes much faster
Ableton | Elektron

Music

thegoodsirjames
Posts: 132
Joined: Fri Apr 01, 2011 6:18 am

Re: Live 9.0.1 Suite takes long to load and too long to save!

Post by thegoodsirjames » Tue Mar 11, 2014 12:55 pm

hey miekwave thanks for this, the approach works on a mac too. Just used easyfind to locate the latest files.db and deleted it. Live now much more responsive. You made my day.

Post Reply