Freeezes & crashes -> weird cure....

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
nemoy
Posts: 380
Joined: Thu Jun 04, 2009 1:45 pm
Contact:

Freeezes & crashes -> weird cure....

Post by nemoy » Mon Apr 01, 2013 3:18 pm

I mentioned it before, and i do it again: ableton live 9 crashes a LOT!
But this time, i've found something:

L9 often freezes, nothing works anymore, and I have to force quit it.
By Hazard, I found out that when ableton freezes again, and it's not responding,
launching just another programm from the Dock
(like firefox, illustrator, ical) fixes it.
I thought it was some random shit. but this has happened
quite a few times since, and it was always fixed by
launching another random program from the Dock...

So, what could that be? and has anyone seen something like that before?

oblique strategies
Posts: 3582
Joined: Thu Nov 02, 2006 9:57 pm
Location: Another Green World

Re: Freeezes & crashes -> weird cure....

Post by oblique strategies » Mon Apr 01, 2013 11:20 pm

Bizarre.

I have not experienced anything like this with any version of the Mac OS

nemoy
Posts: 380
Joined: Thu Jun 04, 2009 1:45 pm
Contact:

Re: Freeezes & crashes -> weird cure....

Post by nemoy » Mon Apr 01, 2013 11:40 pm

oh, by the way, it's a
2010 Macbook pro, 2.4 GHz intel
Mountain Lion (10.8.3)
live 9.0.3b2
RME Fireface 400

and just a few minutes ago, it happened again
Complete freeze, ableton is not responding,
start firefox -> voilà: Live is back...

as long as this works, it's ok for me...
i mean, if it absolutely has to freeze, then like that...

nemoy
Posts: 380
Joined: Thu Jun 04, 2009 1:45 pm
Contact:

Re: Freeezes & crashes -> weird cure....

Post by nemoy » Fri Apr 05, 2013 12:38 am

ok This happened again. several times today.

everytime i copied a max effect (envelope follover for example) into another channel by using cmd/c and cmd/V.
Abeton froze completely. Untill i opened another application from the dock.

Then it just continnued where it froze (without the last action)
alt&drag for copying effects however worked without any problems.

And it froze several times when i Tried to SAVE a set!
and again, launching a random application from the deck
made it work again.

This really is happening on a regular basis!
has noone else seen something similar?
Or do you know why ableton would behave that way?
it doesn't make much sense to me...

wjbuchanan
Posts: 143
Joined: Mon Aug 08, 2011 8:12 pm

Re: Freeezes & crashes -> weird cure....

Post by wjbuchanan » Fri Apr 05, 2013 1:30 am

Try creating a new user, then log in to the new profile test there.

If that doesn't work, use Disk Utility to repair permissions.

Failing that, maybe try safe mode to disable any 3rd party stuff. http://support.apple.com/kb/HT1455

Have the same setup as you, minus the soundcard and it's rock solid on L9.

Cheers

fishmonkey
Posts: 4216
Joined: Wed Oct 24, 2007 4:50 am

Re: Freeezes & crashes -> weird cure....

Post by fishmonkey » Fri Apr 05, 2013 1:56 am

maybe it's some third party GUI hack you have installed? like a fancy launcher or window manager or something...

nemoy
Posts: 380
Joined: Thu Jun 04, 2009 1:45 pm
Contact:

Re: Freeezes & crashes -> weird cure....

Post by nemoy » Fri Apr 05, 2013 10:16 am

...nope, just mountain lion...
no fancy aditional GUI Stuff...
ain't no party like a 3rd party :)

Maybe it's the RME drivers... and switching to another program that might use Sound too gives it a little poke and it's back... i dont know... i'll check for updates on the RME side of things...

oblique strategies
Posts: 3582
Joined: Thu Nov 02, 2006 9:57 pm
Location: Another Green World

Re: Freeezes & crashes -> weird cure....

Post by oblique strategies » Fri Apr 05, 2013 10:21 pm

I'm on a Mac & have used RME interfaces & drivers for over 10 years, & have never experienced this. I also spend a lot of time on the RME USB/Firewire forum, & have not seen any postings about this. Not to dissuade you from researching on the site, after all I currently use a Fireface UC & don't read all the posts addressing issues with firewire.

Have you done any troubleshooting without the RME interface connected? Does it still happen?

Might want to broaden your search on the Mac side of things.

Can you unfreeze Live by launching an app from the Applications folder or does Live unfreeze only when apps are launched from the Dock? Have you emptied out the Dock of everything you can to see what effect that has? Does Hiding/Showing the Dock have any impact?

Might want to try something like CacheOutX to empty caches (Who knows? I'm grasping at straws!)

Also: try this the next time Live freezes (if it will allow you):
Click on the Help menu
Click on Get support...

The Help view will open & provide a link to create an 'Ableton Status Report'
Send this along with any associated Console Ableton/Live messages (also check in your crash logs) to Ableton via their support address.

Even if you have to launch another app from the Dock before Live will unfreeze, you should still send the status report -it may contain something for the Ableton support to use to sort it out.


One more thing: you write:
nemoy wrote: Maybe it's the RME drivers... and switching to another program that might use Sound too gives it a little poke and it's back....
You also wrote that launching Illustrator will unfreeze Live -does Illustrator use sound/the RME interface?

steko
Posts: 3387
Joined: Thu Jan 22, 2009 8:29 pm

Re: Freeezes & crashes -> weird cure....

Post by steko » Fri Apr 05, 2013 11:43 pm

+1 Safe boot (followed by a reboot): http://support.apple.com/kb/HT1455 (cleans out some caches too) Basic troubleshooting step.

First thing I'd do:

Image

Open Activity Monitor (Applications/Utilities) - show "Active Processes" or "All Processes" - sort by CPU column.

Anything hogging CPU? (100% = one core)

You could also check your system.log in Console (Applications/Utilities) for errors.
Rahad Jackson wrote:My Awesome Mix Tape #6

Post Reply