CPU Issues

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
dboy
Posts: 92
Joined: Fri Feb 16, 2007 11:04 pm

CPU Issues

Post by dboy » Fri Apr 19, 2013 1:14 am

Getting really weird behavior where Live 9 randomly ramps up and spikes the CPU. It appears to get worse as the project sits for a while. No other processes running and never in the same place. I7 Macbook Pro 16 gigs of ram. Not sure if this is worse since I upgraded to 9.03. Anyone else seeing this?

lo.key
Posts: 360
Joined: Tue Dec 22, 2009 7:05 pm

Re: CPU Issues

Post by lo.key » Fri Apr 19, 2013 1:48 am

ive noticed that i get the spinning beachball after leaving the set sitting overnight...

darkenedsoul
Posts: 1223
Joined: Wed Jul 28, 2004 10:21 pm
Location: Massachusetts, USA
Contact:

Re: CPU Issues

Post by darkenedsoul » Fri Apr 19, 2013 6:58 pm

Not sure if there are any additional CPU issues with 9.0.3 but it was pulled for other reasons already posted (plugins in set previously on show as off and have to be toggled off/on to re-enable them). So be advised on that if you have any sets from 9.0.2 loading up in 9.0.3. If you still have 9.0.2 and nothing done in .3, I'd de-install .3 and wait for the re-release next week some time of it.

Mike
http://www.darkenedsoul.net - main website
Ableton Live 8.x/9.x : NI Komplete 8 : Home built 4690K 16GB 500GB SSD, 1TB 7200, 2x2TB.

fuzzyhead
Posts: 96
Joined: Fri Sep 14, 2007 12:40 pm
Location: Froggystan

Re: CPU Issues

Post by fuzzyhead » Tue Apr 23, 2013 8:15 am

No cpu peaks here but sudden heat peaks and fans speeding up randomly.
IE Macbook pro early 2011 2,3 quadcore 4GB ram SSD samsung 840 pro Live 9 a set with 7% cpu hits constantly 75°C with 3000prm fans (not much but randomly peaks to 5000rpm and 85°C without doing anything!)
Same thing on Macbook pro early 2008 2,6 C2D HD 7200rpm 4GB ram Live 8 set, no peak, same set in Live 9 hits 105°C randomly!
PRAM have been reset on both.
Some plugins like microtonic which are CPU light may run suddenly with fans peaks as well, and multicolor spinning wheel for 10 seconds when quiting it..

tecgen
Posts: 46
Joined: Wed Mar 03, 2010 4:14 pm
Location: Germany
Contact:

Re: CPU Issues

Post by tecgen » Tue Apr 23, 2013 10:29 am

Maybe you can decrease the CPU temps and the fan speed by forcing your Macbook to use only the integrated graphics of your CPU instead of the discrete GPU. As you can see here on the second picture the CPU and GPU are using the same heat sink.
http://www.ifixit.com/Teardown/MacBook+ ... own/4990/2

Unfortunately when you start Live, your OSX always switches to the discrete GPU. With gfxCardStatus you can prevent these switches. I always use it get as much battery life as possible when running Live.

fuzzyhead
Posts: 96
Joined: Fri Sep 14, 2007 12:40 pm
Location: Froggystan

Re: CPU Issues

Post by fuzzyhead » Tue Apr 23, 2013 5:10 pm

It does not change anything,same result switching to one GPU or the other, using Istat I can even see heat increase using integrated GPU, plus won't let me using external display.
CPU temp at 80°
CPU heatsink at 50°
GPU at 61°
GPU diode at 70°
Heatsink B at 57°
Fans at 4000rpm
live set CPU at 7% and IStat CPU user at 15%

After killing Microtonic track(AU), the values return to normal and fans run at 2000rpm, WTF??
This is happening randomly, there is no rule..
Even without Microtonic running it may happen,but Reaktor for instance or Massive won't provocate,I'm speechless.

chrissobo13
Posts: 168
Joined: Fri May 18, 2012 4:40 pm

Re: CPU Issues

Post by chrissobo13 » Tue Apr 23, 2013 7:33 pm

I also encounter a lot of CPU spikes, pretty much always 5 minutes into using Ableton. They don't always seem dependent on what's happening in live. I can run through the same parts and not go above 35% usage, but sooner or later it will always spike into 120%+ and cause stuttering. I can stop all clips while the session is still playing, and the spike will not go down like I feel it should (it should go down if clips stop and effects are off, right?). If I hit the stop button CPU usage goes down after a few seconds. The thing is, after it has spiked once, it will ALWAYS spike and cause slowdowns. Even if I stop it, wait for all delay and reverb tails to cancel, and run just one audio clip with no effects, it will instantly spike (even if I don't trigger any clips at all!). I have to close Ableton and reopen, as once it starts, it wont stop. It will run fine for a few minutes (regardless of what I'm doing in the program) and once again continue spiking until I close the program again.

Infuriating to say the least, and I think a lot of people have this issue. I've searched high and low for a solution and I always come up empty handed.

dboy
Posts: 92
Joined: Fri Feb 16, 2007 11:04 pm

Re: CPU Issues

Post by dboy » Tue Apr 23, 2013 10:19 pm

Definitely some major CPU issues in Live 9 on the Mac side, not sure about the windows side. Random spikes, high temps and fans kicking in on very small loads, etc... Reverted back to 9.02 and it's the same thing. This program does not seem to be optimized very well at all.

SuburbanThug
Posts: 1478
Joined: Wed Apr 03, 2013 9:22 am
Contact:

Re: CPU Issues

Post by SuburbanThug » Wed Apr 24, 2013 6:30 am

I get up to %50 sometimes playing a chord on some Bazille patches. I don't know if this is normal or not since it's a beta VST and I'm new to using synth plug-ins in Live but the patches don't seem particularly hefty just looking at them. 2012 Macbook pro. 8 gigs of RAM, 2.9 ghz quad core. 5400 rpm hdd.
Last edited by SuburbanThug on Thu Apr 25, 2013 5:25 pm, edited 1 time in total.

Psychoactive_Music
Posts: 104
Joined: Thu May 17, 2012 9:36 am
Contact:

Re: CPU Issues

Post by Psychoactive_Music » Wed Apr 24, 2013 8:55 am

I have CPU issues with live 9 too.

Never had a problem with 8.

but 9 , although wonderful, also quite frustrating

alvarostudio
Posts: 1
Joined: Thu Apr 18, 2013 5:15 pm

Re: CPU Issues

Post by alvarostudio » Wed Apr 24, 2013 10:55 am

I'm in the same boat.

Recently I bought ableton live 9 intro,never tried live 8, and I'm experiencing a lot of cpu issues. It's kind of crazy since my cpu is quite powerful,and I installed it in a ssd hard drive... even with some sounds, I just play a chord and it starts glitching o_0. I think this live 9 needs a lot of love from the developers.

Evengy
Posts: 451
Joined: Wed Jan 13, 2010 8:31 am

Re: CPU Issues

Post by Evengy » Wed Apr 24, 2013 11:06 am

i have also cpu issues. while im at 50% i have crackles when im creating new audio or midi tracks. live peformance isn´t possible with problems like that. another problem is that im using 100% cpu in live (4 audio tracks, 4 midi tracks) but only 15% on my i7-860 :( there is a lot of improvement required!

RaidenOffKey
Posts: 17
Joined: Tue Dec 02, 2008 5:04 am
Location: Bristol UK
Contact:

Re: CPU Issues

Post by RaidenOffKey » Wed Apr 24, 2013 6:24 pm

Same here, jumps from 20% to 100% on playback. Never had this issue with 8. I like live 9 but the development does feel rushed with some serious issues not being addressed.

gunkadoodah
Posts: 1
Joined: Thu Apr 25, 2013 5:11 am

Re: CPU Issues

Post by gunkadoodah » Thu Apr 25, 2013 5:19 am

Yeah I'm experiencing CPU issues too. Current gen MBP Retina 15". My issue seems to be that after working on a set for awhile, the CPU meter idles at about 15-20% even when doing nothing. I was hoping it was just a visual fluke, but apparently Ableton is really using that 20% for who knows what, because after launching 3 midi clips my CPU hits 55% and sound starts crackling :(

Hellllllppppp!

Coupe70
Posts: 1097
Joined: Fri Jul 23, 2004 7:25 am
Location: Mainz / Germany
Contact:

Re: CPU Issues

Post by Coupe70 » Thu Apr 25, 2013 10:28 am

You should post a link to this thread in the beta forum if you haven't yet.
Phongemeinschaft (Live-ElectroJazz / NuJazz)
Homepage - youtube - Like! :-)
Live 9 (32Bit), HP DV7, i5 2,53GHz, 8 GB RAM, Win7 (64Bit)

Post Reply