I don't see Live 9.0.3 in my account

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
filter_7
Posts: 370
Joined: Sun Feb 05, 2012 10:05 am

I don't see Live 9.0.3 in my account

Post by filter_7 » Fri Apr 19, 2013 2:38 pm

Anybody else with that issue?
I still have Live 9.0.2 and Max 6.1 downloads...

re:dream
Posts: 4545
Joined: Fri Dec 28, 2007 9:42 am
Location: Hoerikwaggo's sunset side...
Contact:

Re: I don't see Live 9.0.3 in my account

Post by re:dream » Fri Apr 19, 2013 2:42 pm

On the Ableton website, there are as yet no release notes for 9.0.3.
So my assumption is that it isn't out yet.

stashe
Posts: 4
Joined: Thu May 03, 2012 1:38 pm

Re: I don't see Live 9.0.3 in my account

Post by stashe » Fri Apr 19, 2013 2:53 pm

was posted on facebook 9 mins ago
We've temporarily removed Live 9.0.3 while we work out one final issue – we expect to have it available again next week. Thanks for your patience.
what happens for the people who already updated, does this mean the update installed from today is buggy? reinstall? or there be a auto fix?

silversurfer60
Posts: 194
Joined: Sat Mar 16, 2013 3:23 pm

Re: I don't see Live 9.0.3 in my account

Post by silversurfer60 » Fri Apr 19, 2013 2:58 pm

They must have canceled it. Yesterday, I made the update and read the release notes. The reason is the bug with the plugins off, this is my assumption.


BUT NOBODY FROM ABLETON SAYS ANYTHING, THIS IS A POORLY COMMUNICATION, SHAME ON YOU!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!



Here are the release notes from another forum.

Release Notes Live 9.0.3

Improvements and feature changes:

Added a new skin: "Disco".
Added a new option to the "Record/Warp/Launch" preferences pane: "Start Transport with Record". If activated, the transport will start immediately when clicking on the Session- or Arrangement-Record buttons. If deactivated, it prepares for recording as in Live 8, so you have to launch a clip in Session View or click the 'Play' button. You can hold down the Shift modifier key when clicking on the record buttons to invert the behavior temporarily.
When recording automation on top of an existing automation envelope, and quickly clicking on different positions in parameters like sliders, X/Y pads, etc., Live now records a latching automation envelope instead of jumping back to the previous value.
The Compressor device does not clip input signals at +20 dB anymore.
Added control surface support for Novation Launchkey series.
Added control surface support for M-Audio Axiom Air Mini 32.
Added a user satisfaction survey. After several hours of usage, Live will ask you to rate the software.
Updated manual, lessons and translations.

Bugfixes:

The Trial version of Live 9.0.2 could hang on startup.
Live would not work as a ReWire slave on Windows.
The performance of the Ableton Index process has been improved, especially on OS X.
The Ableton Index process would sometimes not scan all folders after adding them to the sidebar.
The Ableton Index process could block the GUI during saving and exporting of Live sets, presets or clips.
Scanning folders containing a huge amount of files could take longer than necessary.
The Browser would not update its content pane after a change in the file system if the selection was somewhere outside of the Browser.
Expanding the Audio Unit folder in the browser's "Plug-ins" label could be slow for users which have a lot of library content installed.
Live would not save a clip self-contained after dragging it to the Browser and confirming the name of the new clip by clicking anywhere outside of the Browser.
The Session Record button would not turn off if the recording was aborted, e.g. by stopping or deleting the currently recording clip, disarming a track, etc.
Under certain conditions, MIDI notes would not get recorded into a clip slot after deleting a previous clip.
Overdubbing into MIDI clips could unnecessarily bloat the undo history file.
Fixed a graphical glitch which could occur in the representation of the filter curve in EQ Eight's Frequency Display.
Several MIDI control surfaces would not correctly shut down after quitting Live, e.g. motorfaders on the Mackie Control would not return to zero, Axiom Pro devices would not exit Hypercontrol mode, etc.
The "Project Mix IO" control surface would not work.
The channel strip buttons on the Mackie Control XT would not work.
Fixed a bug where the key navigation in track headers would not work properly when certain control surfaces are selected.
When using control surface scripts, the blue hand would sometimes not map to any device, e.g. after creating a device and then deleting it by using undo.
Live could sometimes crash on quit in case a faulty MIDI remote script throws an exception in the Python console.
Fixed a crash which could occur in Live Intro when right-clicking on a drum rack chain.

Changes for Push:

Using the touch strip to change banks in drum racks now requires to pick up the current value, to avoid changing banks accidentally while playing.
Fixed incorrect intervals in the Locrian scale.
The velocity curve setting would reset to the default value when opening a new Live set.
Changing the pad sensitivity settings could be slow if a drum rack was in focus.
Updating the LCD display could be slow when switching between Drum and Note mode.
The Push LCD could remain blank and no mode would be selected after holding the 'Browse' mode button.
Fixed a bug where 'Browse' mode would be exited after swapping a Max for Live instrument.
Tracks created by dragging an instrument would sometimes not be automatically armed if Push is connected.
The "Arm Exclusive" preference would not be respected when Push was connected.
Fixed a bug where recording wouldn't work properly if the default clip launch mode was set to 'Toggle' mode.
Fixed a crash which could occur when using the 'Quantize' function.
Fixed a crash which could occur when using Push to delete a device whilst recording automation for this device with the mouse.
Last edited by silversurfer60 on Fri Apr 19, 2013 3:28 pm, edited 1 time in total.

Ableton_David
Posts: 1769
Joined: Fri Aug 20, 2010 7:31 pm
Location: Ableton
Contact:

Re: I don't see Live 9.0.3 in my account

Post by Ableton_David » Fri Apr 19, 2013 3:08 pm

We've temporarily taken Live 9.0.3 down while we fix a final issue. It should be available again next week.

In the mean time, if you've already installed 9.0.3 and are experiencing issues with plug-ins, please see this article for how to fix things: https://www.ableton.com/en/articles/plugins-silent-903/

squelcht
Posts: 1896
Joined: Thu Feb 05, 2009 4:38 am
Location: QC, NC
Contact:

Re: I don't see Live 9.0.3 in my account

Post by squelcht » Fri Apr 19, 2013 4:35 pm

:x

filter_7
Posts: 370
Joined: Sun Feb 05, 2012 10:05 am

Re: I don't see Live 9.0.3 in my account

Post by filter_7 » Fri Apr 19, 2013 5:11 pm

Thanks David.

Coupe70
Posts: 1097
Joined: Fri Jul 23, 2004 7:25 am
Location: Mainz / Germany
Contact:

Re: I don't see Live 9.0.3 in my account

Post by Coupe70 » Fri Apr 19, 2013 5:21 pm

dilettantish.
Phongemeinschaft (Live-ElectroJazz / NuJazz)
Homepage - youtube - Like! :-)
Live 9 (32Bit), HP DV7, i5 2,53GHz, 8 GB RAM, Win7 (64Bit)

re:dream
Posts: 4545
Joined: Fri Dec 28, 2007 9:42 am
Location: Hoerikwaggo's sunset side...
Contact:

Re: I don't see Live 9.0.3 in my account

Post by re:dream » Fri Apr 19, 2013 5:47 pm

It's the Disco skin, I'm sure of it 8O

H20nly
Posts: 15834
Joined: Sat Oct 27, 2007 9:15 pm
Location: The Wild West

Re: I don't see Live 9.0.3 in my account

Post by H20nly » Fri Apr 19, 2013 10:58 pm

^ exactly. they forgot that disco skin is supposed to have a hairy chest with traces of blow in it and a medallion.

Mark Quest
Posts: 1
Joined: Tue Dec 11, 2012 2:56 pm
Location: Perth, Australia

Re: I don't see Live 9.0.3 in my account

Post by Mark Quest » Sat Apr 20, 2013 3:32 am

but if we're aren't experiencing problems is it safe to keep the update?

timothyallan
Posts: 5788
Joined: Wed Nov 24, 2004 11:05 pm
Location: Melbourne Australia
Contact:

Re: I don't see Live 9.0.3 in my account

Post by timothyallan » Sat Apr 20, 2013 3:49 am

I had mucho problems and emailed support... They told me to roll back. Apparently I wasn't the only one :S

eyeknow
Posts: 5822
Joined: Fri Jul 15, 2005 6:16 am

Re: I don't see Live 9.0.3 in my account

Post by eyeknow » Sat Apr 20, 2013 4:56 am

How infuriating. So far, I haven't run into anything. I even tried opening a couple of old projects and everything seems ok. I'm not rolling it back unless necessary.

BTW, is it at all possible to install 9.02 and have it just rewrite the old version back? Uninstalling and reinstalling is too drastic for me.

steko
Posts: 3347
Joined: Thu Jan 22, 2009 8:29 pm

Re: I don't see Live 9.0.3 in my account

Post by steko » Sat Apr 20, 2013 4:08 pm

9.0.3 runs fine here so far. Mac 10.6.8

What problems did you have, Timothy?

Indexing is mucho improved in 9.0.3.
Rahad Jackson wrote:My Awesome Mix Tape #6

re:dream
Posts: 4545
Joined: Fri Dec 28, 2007 9:42 am
Location: Hoerikwaggo's sunset side...
Contact:

Re: I don't see Live 9.0.3 in my account

Post by re:dream » Sat Apr 20, 2013 4:36 pm

So does this mean we should all uncheck the automatic update box in preferences?

Post Reply