Page 1 of 1

Undo Update clips and devices with changed media files

Posted: Tue Jun 25, 2013 1:55 pm
by floond
I have been noticing the topic line in my "Undo history" in the Edit menu lately. What does it mean/do? I've never seen it till recently, but I usually only check the edit menu, when for some reason Ctrl-Y / Redo isn't doing anything, so it could be more common than I think. In this particular instance I hit ctrl-z by accident which reset a freqeuncy setting on an EQ-8. Hit ctrl-y to move it back to its proper setting, only to learn that Live claimed there was nothing to redo, and the next step backwards in Undo history was the topic line. Just curious :)

Re: Undo Update clips and devices with changed media files

Posted: Sat Jun 29, 2013 12:14 pm
by floond
Ok, found out this is just the first undo step, and my problem really is the undo history bug. Even though I started the project in Live9, using a Live8 legacy preset (Maxwell bass) is enough to fuck up undo/redo history..

Re: Undo Update clips and devices with changed media files

Posted: Tue Aug 06, 2013 6:03 am
by Michael Hatsis
Just got this as well...No idea what could have caused it...Using Live 8.4. Kinda annoying because w this particular track i basically lost the ability to use "undo". Also, It's a big track so Live takes about a minute or so to save... :(

Mike

Re: Undo Update clips and devices with changed media files

Posted: Tue Aug 06, 2013 7:56 am
by florian_bl
Are you using any M4L devices? A lot of them write every action that they perform into the undo history, making undo practically useless. At least it happens on my computer. Mono Sequencer and the LFO are two M4L devices that I can remember doing this. Could this be the problem in your session?

Re: Undo Update clips and devices with changed media files

Posted: Tue Aug 06, 2013 9:13 am
by Michael Hatsis
florian_bl wrote:Are you using any M4L devices? A lot of them write every action that they perform into the undo history, making undo practically useless. At least it happens on my computer. Mono Sequencer and the LFO are two M4L devices that I can remember doing this. Could this be the problem in your session?
Thanks for the reply. I'm definitely not using any MFL devices as I know things generally get weird when using them. Im on Live 8.4 os x 10.8.4

Cheers,
Mike

Re: Undo Update clips and devices with changed media files

Posted: Thu Aug 29, 2013 12:53 pm
by fredbloss
Yo did you ever get anywhere with this?
I've just start a free trial on Live 9 and i think am having the same problem

Re: Undo Update clips and devices with changed media files

Posted: Mon Sep 02, 2013 2:24 pm
by floond
I never found a fix for the problem on that particular project. I was aware that M4L devices could render the undo history pretty much useless. But in this case I hadn't used any M4L devices, my crime was simply that I had loaded a preset from my Live 8 Library folder. I later read others experiencing the same problem when they loaded a L8 project into L9 or used L8 presets in L9. I think this issue is distinct from the M4L problem. But I just now tried to reproduce the problem unsuccessfully, so I think it may have been fixed the version I'm currently running (9.0.5 x64).

Re: Undo Update clips and devices with changed media files

Posted: Fri Sep 20, 2019 1:13 am
by lapieuvre
Got the same problem with Live 10.1 suite...

Undo becomes useless, it's frustrating. On my side I use M4L devices.

Any ideas since 2013?

OSX 10.14.6
16gigs Ram
MBP 2018 core i9