VSTs not working when I'm playing live.

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
beachheart
Posts: 3
Joined: Thu Jan 10, 2013 10:02 pm

VSTs not working when I'm playing live.

Post by beachheart » Mon Jan 13, 2014 1:48 am

For example, I'm getting ready for a live show, where I'll be controlling samples with my APC40 as well as singing live vocals.

I have a de-esser as well as some other vocal effect VSTs on the vocal track. The track is armed, I can hear my voice in the monitors, but none of the VST effects do anything.

They work fine with recorded audio. They just have no effect on live audio. Is that just how it is, or is there something I'm missing?

Thanks in advance.

Angstrom
Posts: 14726
Joined: Mon Oct 04, 2004 2:22 pm
Contact:

Re: VSTs not working when I'm playing live.

Post by Angstrom » Mon Jan 13, 2014 3:15 am

You should hear your VSTs applied to your live vocal channel, as you sing it should be processed. A long as monitor is on, or Auto.

The only way I can think that this would not happen is if you have an unusual routing, such as where your vocal is being pulled to a buss channel and you have selected "pre effects" as the sub source pulldown option. If the track is going straight to "master" then I have no idea. It should work.

beachheart
Posts: 3
Joined: Thu Jan 10, 2013 10:02 pm

Re: VSTs not working when I'm playing live.

Post by beachheart » Mon Jan 13, 2014 3:36 am

Thanks, I forgot I did have the vocal track being sent to a bus pre effects. Once I got it fixed though, the latency on my POS laptop was horrendous with all the VSTs I needed running.

I think I'm just going to end up running my vocals through Waves GTR Solo for effects instead of putting the extra strain on Ableton. That will allow me to set presets on a song by song basis and not have to worry about tweaking the VSTs in between songs.

Angstrom
Posts: 14726
Joined: Mon Oct 04, 2004 2:22 pm
Contact:

Re: VSTs not working when I'm playing live.

Post by Angstrom » Mon Jan 13, 2014 2:13 pm

Although many effects are latency monsters you can fix this issue to some degree. In a late version of Live 8 Ableton added the menu option to change how PlayThrough latency compensation works.

Play through latency offseting will put your armed track in sync with all of the other latency riddled tracks in your set. So if you had a beat repeater on your armed track and some giant latency monster on hour drumtrack you would need all the tracks in sync, to put the rhythmic vocal effect in sync with the drums, etc.

However, if your vocal channel (armed/monitored) is not being effected rhythmically you can turn play through optimisation (or whatever it is called) OFF. Doing this means that the armed channel will only calculate and offset its own latency, and not try to match up with every other track. Which means it will have much less latency, as it ignores its fat friends and can sprint ahead,

Oh, and take all the look aheads off your compressors on your vocal track. You cant look ahead in real time.

Tl;dr - try turning off play through optimisation and compression look ahead

Post Reply