endless clicking/crackling problems with Live 9?

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
33tetragammon
Posts: 903
Joined: Fri Dec 26, 2008 8:34 pm
Location: The Universe
Contact:

Re: endless clicking/crackling problems with Live 9?

Post by 33tetragammon » Mon Feb 03, 2014 8:31 am

I tested the same stuff in :

-Studio One Version 2.6.2.
-Five12's Numerology 4 (build 128).

Both didn't have ANY problems like i have in Live.
Still have to test this in Logic x 10.0.6 and Maschine 2.06.

nemoy
Posts: 380
Joined: Thu Jun 04, 2009 1:45 pm
Contact:

Re: endless clicking/crackling problems with Live 9?

Post by nemoy » Mon Feb 03, 2014 3:39 pm

Macbook pro (late 2010)
RME Fireface
8 giga ram
SSD Drive

every possible stopbutton removed,
Dashboard deactivated
wlan deactivated,
no other programs running

264(!!!) samples Buffersize

->> still crackling as soon as CPU hits around 40%

btw. i had to go back to 9.0 because 9.1.1 didn't open my sets anymore...

Maybe live just isn't made for live preformances. (whut!?)

Michael Hatsis
Posts: 1807
Joined: Tue Nov 16, 2004 6:27 pm
Location: Here and There
Contact:

Re: endless clicking/crackling problems with Live 9?

Post by Michael Hatsis » Tue Feb 04, 2014 3:32 pm

I dont have the exact same problem as you. I will say that Live 9 starts falling apart way quicker than Live 8 ( cpu spikes, pops, crackles ) also, i pretty much always have to use a 512 buffer size when I start adding a few 3rd party plugs. Live 8 I'd usually have it on 128, then once the project got to a substantial size like 25 or so tracks, i would have to up the buffer.
Honestly, it feels like i cant do anything without audio dropouts and crackling( basically the sounds u get when the buffer is too small ) in Live 9...live 8 works way better on the same machine.

Mike

studiojohnny
Posts: 67
Joined: Thu Mar 22, 2012 10:58 pm
Location: Brooklyn, NY

Re: endless clicking/crackling problems with Live 9?

Post by studiojohnny » Tue Feb 04, 2014 5:41 pm

This is a long shot but try switching your system sound (in System Preferences) to use something else besides your sound card, so that the *only* thing using your soundcard is Live. For whatever reason this eliminates a lot of the random crackles I get in Live. It's annoying to switch all the time but it works.

I'm using Live 9.1.1, OS X 10.9.1, and an MBox Pro 1.3.0 (for now).

33tetragammon
Posts: 903
Joined: Fri Dec 26, 2008 8:34 pm
Location: The Universe
Contact:

Re: endless clicking/crackling problems with Live 9?

Post by 33tetragammon » Wed Feb 05, 2014 12:10 am

studiojohnny wrote:This is a long shot but try switching your system sound (in System Preferences) to use something else besides your sound card, so that the *only* thing using your soundcard is Live. For whatever reason this eliminates a lot of the random crackles I get in Live. It's annoying to switch all the time but it works.

I'm using Live 9.1.1, OS X 10.9.1, and an MBox Pro 1.3.0 (for now).
I already had it set up like that but the crackling still happens. Ableton needs to fix this.
I just received an email that a new beta is available (Live 9.1.2b1). I'll check that out and report back.

Update: Live 9.1.2b1 has the same crackles. I have posted this on the Beta forum.
Last edited by 33tetragammon on Wed Feb 05, 2014 8:56 am, edited 1 time in total.

eyeknow
Posts: 5822
Joined: Fri Jul 15, 2005 6:16 am

Re: endless clicking/crackling problems with Live 9?

Post by eyeknow » Wed Feb 05, 2014 4:30 am

Angstrom wrote:win 7 64 bit, 16 gb memory, quadcore i7 3.4gHz
Live 9.1 64 bit,
RME fireface 400.

One method I can make Live crackle repeatably on my system
  1. create a new set,
  2. load a sample into a clip clot,
  3. selecting Complex Pro on that clip
  4. use the warp markers to stretch the sample to be 4x it's normal length.
Outcome : Live 9 will now crackle, with just one audio clip loaded and no VSTs or effects
See my specs below. I can run virtually anything and I don't get that. Not to be a turd by saying it, just that I have two computers (both i7's) that run live 9 w/o this being an issue.

I get though that people are having issues with live. I have no clue why it runs for hours a day, with tons of virtual instruments and processor heavy tracks (like amp sims) w/o the issue.

eyeknow
Posts: 5822
Joined: Fri Jul 15, 2005 6:16 am

Re: endless clicking/crackling problems with Live 9?

Post by eyeknow » Wed Feb 05, 2014 4:34 am

Oh, and I run with internet on, I've done no mods or hacks to my system. And I have MSE running.

The only thing I do that is not considered good by some is I KILL the UAC first thing after installing windows. I kill it cold, I kill it dead. So, over 4 years of using win7x64 and other than sonar, very good luck as my main computer.

Angstrom
Posts: 14664
Joined: Mon Oct 04, 2004 2:22 pm
Contact:

Re: endless clicking/crackling problems with Live 9?

Post by Angstrom » Wed Feb 05, 2014 2:10 pm

But why does Live 8 still run perfectly on the exact same machine, if it is the setup?

Obviously something about my setup triggers the issue, but why only in Live 9 and never at all in Live 8.
Something in Live 9 hates my setup, something that was not in Live 8 which loves my setup.

Live 8 never crackles unless I'm at 80%cpu

Live 9 will start crackling at any time, under any load.

If the problem is my computer, then why does Live 8 work?

su
Posts: 194
Joined: Tue Dec 15, 2009 6:09 am

Re: endless clicking/crackling problems with Live 9?

Post by su » Wed Feb 05, 2014 2:18 pm

Experiencing regular crackling here and it seems to be a *recent* thing. Admittedly I haven't carefully tracked when it all began. I've been assuming possible culprits are: 1) iconnectmidi audio driver conflicting with my main soundcard driver, 2) more regular use of Fxpansion Tremor which is a huge cpu hog. Someone also mentioned complex pro warp mode and that's about the only mode I use. I'll be watching this thread. I've been putting samples into RAM mode and that seems to help. I haven't tested it systematically, but using 1 window instead of 2 also seems to help.

Spex:

Windows 7 64 bit
AMD Athlon 64 X2 4400, 2.3 GHz
4 GB RAM
Delta 66 PCI soundcard
iconnectmidi2
Last edited by su on Thu Feb 06, 2014 3:36 pm, edited 2 times in total.

keamo
Posts: 17
Joined: Tue Dec 10, 2013 5:15 am
Location: Dallas
Contact:

Re: endless clicking/crackling problems with Live 9?

Post by keamo » Wed Feb 05, 2014 3:42 pm

There could be a list of things that could cause this but I'd like to better understand the issue:

Could you tell me more about the complexity of your production? I've built synths out and engineered automations up to 20+ with at least 10 FX/thirdpartyFX, and up to 30.... and have seen what will happen when you say have 60 tracks all with their own amount of CPU usage, laptop over heating, ableton crashing, clicks, pops, etc...

Are you familiar with freezing and flattening your tracks? I think this could help you out if you're having issues with Ableton 9, which is much more stable with CPU usage than Ableton 8 ever was... Which leads me to believe it maybe something else...

I know this may seem a bit weird but I had my background on my MBP changing every 5 seconds, this actually caused a TON of issues in Ableton... this literally took me ages to figure out but I figured it's good to make sure that's sorted before anything else.

Also understanding what year your MBP will help too. I hear newer models are better with over heating issues, etc...

I'm sure we can figure this out, I've had years of figuring these things out under my belt.

But end of the day: 50% CPU usage in ableton is problematic. But I can't help you unless I know more about what you're doing in Ableton.


KEAMO
http://www.soundcloud.com/keamo
AbletonW/PUSH
Macbookproi7-8gig
MotuUltraliteMk3Hybrid
MoogLittlePhatty
KorgMS2000
KorgMicro
TriggerFinger
JazzmutantLemur
OxygenM-Audio49

Angstrom
Posts: 14664
Joined: Mon Oct 04, 2004 2:22 pm
Contact:

Re: endless clicking/crackling problems with Live 9?

Post by Angstrom » Wed Feb 05, 2014 5:52 pm

Angstrom wrote:win 7 64 bit, 16 gb memory, quadcore i7 3.4gHz
Live 9.1 64 bit,
RME fireface 400.

One method I can make Live crackle repeatably on my system
  1. create a new set,
  2. load a sample into a clip clot,
  3. selecting Complex Pro on that clip
  4. use the warp markers to stretch the sample to be 4x it's normal length.
Outcome : Live 9 will now crackle, with just one audio clip loaded and no VSTs or effects

marcoskohler
Posts: 333
Joined: Fri Aug 04, 2006 3:13 am

Re: endless clicking/crackling problems with Live 9?

Post by marcoskohler » Wed Feb 05, 2014 6:06 pm

I have similar issues. Even if I freeze tracks, live is choppy and crackles sometimes. I have a 512 buffer, and a fully loaded iMac with 16 gigs of RAM :(. I haven't tried to troubleshoot yet. I'm going to wait for BitWig and see how my performance is there and then compare/analyze.

eyeknow
Posts: 5822
Joined: Fri Jul 15, 2005 6:16 am

Re: endless clicking/crackling problems with Live 9?

Post by eyeknow » Wed Feb 05, 2014 6:14 pm

that is still 7 weeks away IF they get it out on time.

8 and 9 ran on the old computer with virtually identical results. The only thing that was a problem at first with 9 was indexing was a mess originally. On this computer this is just a clean install of 9.1, packs, M4L, and now push.

marcoskohler
Posts: 333
Joined: Fri Aug 04, 2006 3:13 am

Re: endless clicking/crackling problems with Live 9?

Post by marcoskohler » Wed Feb 05, 2014 9:24 pm

eyeknow wrote:that is still 7 weeks away IF they get it out on time.

8 and 9 ran on the old computer with virtually identical results. The only thing that was a problem at first with 9 was indexing was a mess originally. On this computer this is just a clean install of 9.1, packs, M4L, and now push.
So you're saying you have no issues? Or constant issues? It just seems weird to have a fully loaded system, running an insane amount of RAM and still have problems loading 10-15 tracks. Perhaps it's expected when using CPU intensive plugins like Satin and Monark, etc.

tone61
Posts: 376
Joined: Fri Dec 21, 2007 5:09 am

Re: endless clicking/crackling problems with Live 9?

Post by tone61 » Wed Feb 05, 2014 9:50 pm

Angstrom wrote:
Angstrom wrote:win 7 64 bit, 16 gb memory, quadcore i7 3.4gHz
Live 9.1 64 bit,
RME fireface 400.

One method I can make Live crackle repeatably on my system
  1. create a new set,
  2. load a sample into a clip clot,
  3. selecting Complex Pro on that clip
  4. use the warp markers to stretch the sample to be 4x it's normal length.
Outcome : Live 9 will now crackle, with just one audio clip loaded and no VSTs or effects
Using that test I stretched a 1bar sample to 4bar length.
I hear one crackle in the end of this stretched looping sample.

Post Reply