Live Performance Latency Issues

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
floridagizzi
Posts: 13
Joined: Fri Jul 13, 2012 9:19 pm

Live Performance Latency Issues

Post by floridagizzi » Fri May 23, 2014 6:28 pm

Ok, I really try not to post, and I consider myself a fairly capable Ableton user, but I absolutely cannot get a usable latency going.

PC Specs:
HP Envy 15t
Core i7-4700MQ (Quad Core @ 2.40GHz)
12GB Ram
240GB SSD Samples, 1TB 5600RPM HDD for other non-music things

Musical Setup:
1 Mic on input 1
1 Guitar/Bass on input 2
No DSP Effects processing
No Ableton/VST audio effects processing

Audio Interface and Drivers (@ 48000)
MOTU Microbook II
Asio4All- 1.33 Input Latency, 1.33 Output, 2.67 Overall, 64 Samples
MOTU Driver- 2.67 In, 7.33 Out, 10.0 overall, 128 Samples)
MOTU Ultralite MK3
Asio4All- 1.33 In, 1.33 Out, 2.67 Overall, 64 Samples
MOTU- 2.52 In, 3.04 Out, 5.56 Overall, 64 Samples

Theoretically, those latencies are great, but with headphone monitoring there is a significant 'slapback' kind of effect from the latency (clearly not sub 10ms), and without headphone monitoring there is probably a half second between plucking a string and hearing it through the system. Direct monitoring signal works great with no noticeable latency. It's only the signal after being processed through Ableton and sent out.

My goal is to use Looper and do a live looping thing, but it's damn near impossible with this significant slapback/latency going on.

What the heck is the problem? HELP! (and thank you!)
HP Envy 15t i7-4700MQ 12GB RAM 240GB SSD 1TB HDD
MOTU Microbook II & Ultralite MKIII

eyeknow
Posts: 5822
Joined: Fri Jul 15, 2005 6:16 am

Re: Live Performance Latency Issues

Post by eyeknow » Fri May 23, 2014 9:24 pm

This is getting disturbing.

I'm running 9.1.1 and I wonder if you guys with the latency issues are running 9.1.2?

This is the third of forth of these I've seen and it's not logical at all unless there is a bug in live.

That latency you are getting is ridiculously low, there is no way you should be getting a noticeable (at all) delay.

Now, I turn off any monitoring from the soundcard. I do all my monitoring inside of live, but still, that is weird.

floridagizzi
Posts: 13
Joined: Fri Jul 13, 2012 9:19 pm

Re: Live Performance Latency Issues

Post by floridagizzi » Fri May 23, 2014 9:48 pm

yup. running 9.1.2. I guess I'll drop down to 9.1.1 and see if that helps? Seems odd though...
HP Envy 15t i7-4700MQ 12GB RAM 240GB SSD 1TB HDD
MOTU Microbook II & Ultralite MKIII

eyeknow
Posts: 5822
Joined: Fri Jul 15, 2005 6:16 am

Re: Live Performance Latency Issues

Post by eyeknow » Fri May 23, 2014 9:51 pm

I don't know what else to think. I'm not saying that is going to fix it, but there has to be a reason. If there are no limiters or anything along those lines and it's every project.

Have you tried the 9.1.3 beta? I have not yet but that might be something to look into because I don't think you can play/save projects you opened in 9.1.2 back down to 9.1.1.

floridagizzi
Posts: 13
Joined: Fri Jul 13, 2012 9:19 pm

Re: Live Performance Latency Issues

Post by floridagizzi » Fri May 23, 2014 9:56 pm

I'll try the Beta. Does anyone know where I can grab the 9.1.1 installer? Ableton.com only offers me 9.1.2 and 8.4.2
?

*EDIT* and just to be clear, I do have my own purchased, unique serial number. are the torrent installers safe to use with a legit serial?
HP Envy 15t i7-4700MQ 12GB RAM 240GB SSD 1TB HDD
MOTU Microbook II & Ultralite MKIII

clydesdale
Posts: 350
Joined: Mon Sep 09, 2013 3:28 am

Re: Live Performance Latency Issues

Post by clydesdale » Fri May 23, 2014 10:34 pm

I'm on 9.1.2 and haven't noticed anything I would call out of the ordinary. I may not be the best test case.
LIVE 9.1.7 x64, PUSH w/PXT, APC40, KEYSTATION PRO88, Radium61
Win8.1 Pro, 4820k(4.5GHz)/32GB/840ProSSD/RME Babyface

eyeknow
Posts: 5822
Joined: Fri Jul 15, 2005 6:16 am

Re: Live Performance Latency Issues

Post by eyeknow » Fri May 23, 2014 10:51 pm

floridagizzi wrote:I'll try the Beta. Does anyone know where I can grab the 9.1.1 installer? Ableton.com only offers me 9.1.2 and 8.4.2
?

*EDIT* and just to be clear, I do have my own purchased, unique serial number. are the torrent installers safe to use with a legit serial?
I wouldn't try it, ymmv.

floridagizzi
Posts: 13
Joined: Fri Jul 13, 2012 9:19 pm

Re: Live Performance Latency Issues

Post by floridagizzi » Sat May 24, 2014 3:02 am

*bump* anyone else have any thoughts?
HP Envy 15t i7-4700MQ 12GB RAM 240GB SSD 1TB HDD
MOTU Microbook II & Ultralite MKIII

fishmonkey
Posts: 4134
Joined: Wed Oct 24, 2007 4:50 am

Re: Live Performance Latency Issues

Post by fishmonkey » Sat May 24, 2014 8:38 am

what processing are you doing with the signal in Live before it heads back out to your headphones?

and did you do the driver error compensation thing for each of your interfaces at the sample rates that you are working at?
badbrainz wrote: I'm a drummer, so I'm already at an intellectual disadvantage here

floridagizzi
Posts: 13
Joined: Fri Jul 13, 2012 9:19 pm

Re: Live Performance Latency Issues

Post by floridagizzi » Sat May 24, 2014 2:52 pm

fishmonkey wrote:what processing are you doing with the signal in Live before it heads back out to your headphones?

and did you do the driver error compensation thing for each of your interfaces at the sample rates that you are working at?
Just a bit of reverb for both guitar and vocals. I dropped auto tune vst on the vocals with plugin powered off.

I messed with the error compensation but, from what I understand (and experienced) it doesn't help overcome such a significant latency.
HP Envy 15t i7-4700MQ 12GB RAM 240GB SSD 1TB HDD
MOTU Microbook II & Ultralite MKIII

fishmonkey
Posts: 4134
Joined: Wed Oct 24, 2007 4:50 am

Re: Live Performance Latency Issues

Post by fishmonkey » Sun May 25, 2014 1:28 am

floridagizzi wrote: Just a bit of reverb for both guitar and vocals. I dropped auto tune vst on the vocals with plugin powered off.

I messed with the error compensation but, from what I understand (and experienced) it doesn't help overcome such a significant latency.
measuring the error in the driver latency is important because if the value is wrong, then Live cannot correctly compensate for latency through your audio interface. use the lesson in the Live sidebar help to measure the actual latency, and hence the correct value to enter in the compensation box.

once you have that set up right, try recording with no effects on the incoming signals, as that will give you a proper idea about how much latency is being introduced by the audio going through your system. for tracking and overdubbing a signal while monitoring it through Live, you want to avoid any effects that create extra latency in the signal chain (your auto tune plugin probably causes some, for example).
badbrainz wrote: I'm a drummer, so I'm already at an intellectual disadvantage here

floridagizzi
Posts: 13
Joined: Fri Jul 13, 2012 9:19 pm

Re: Live Performance Latency Issues

Post by floridagizzi » Sun May 25, 2014 1:33 am

you want to avoid any effects that create extra latency in the signal chain (your auto tune plugin probably causes some, for example).
Will a heavy hitter midi vst (omnisphere in my case) affect latency even if it doesn't process live audio?
HP Envy 15t i7-4700MQ 12GB RAM 240GB SSD 1TB HDD
MOTU Microbook II & Ultralite MKIII

fishmonkey
Posts: 4134
Joined: Wed Oct 24, 2007 4:50 am

Re: Live Performance Latency Issues

Post by fishmonkey » Sun May 25, 2014 2:15 am

i forgot to mention the "Reduced Latency While Monitoring" option, which is in the Options menu of Live. look it up in the user manual.

the effect of other latency creating devices will depend on the routing in your Live set. the crucial thing to realise is that keeping things in sync always involves adding extra latency to the tracks that have less latency...
badbrainz wrote: I'm a drummer, so I'm already at an intellectual disadvantage here

floridagizzi
Posts: 13
Joined: Fri Jul 13, 2012 9:19 pm

Re: Live Performance Latency Issues

Post by floridagizzi » Sun May 25, 2014 2:36 am

fishmonkey wrote:i forgot to mention the "Reduced Latency While Monitoring" option, which is in the Options menu of Live. look it up in the user manual.

the effect of other latency creating devices will depend on the routing in your Live set. the crucial thing to realise is that keeping things in sync always involves adding extra latency to the tracks that have less latency...
just finished. 4ms latency using the Microbook driver, 0ms latency using Asio4All (64 samples). I'll check the Ultralite tomorrow when I go in to work.
HP Envy 15t i7-4700MQ 12GB RAM 240GB SSD 1TB HDD
MOTU Microbook II & Ultralite MKIII

fishmonkey
Posts: 4134
Joined: Wed Oct 24, 2007 4:50 am

Re: Live Performance Latency Issues

Post by fishmonkey » Sun May 25, 2014 2:52 am

which latency are you talking about? 0 ms roundtrip latency is impossible to achieve. or are those the compensation values?
badbrainz wrote: I'm a drummer, so I'm already at an intellectual disadvantage here

Post Reply