MPC with Ableton, sync issue, need help

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
AKROC
Posts: 22
Joined: Fri Apr 22, 2011 4:40 pm

MPC with Ableton, sync issue, need help

Post by AKROC » Mon Dec 22, 2014 4:13 am

Having an issue with syncing my MPC 2000 to ableton. I have everything all synced properly using the midi clock out of the MPC into ableton, thats all good, my issue is after I have done that midi notes played from the mpc into ableton play all short and cut off (almost like staccato mode) does anybody know how to fix this?
thanks

be tonal
Posts: 56
Joined: Tue May 17, 2011 8:15 am

Re: MPC with Ableton, sync issue, need help

Post by be tonal » Mon Dec 22, 2014 4:52 pm

Sounds like you created a midi feedback loop, check your thru settings in the mpc and live´s tracks.

Edit: If it´s not that, maybe your interface struggles with receiving notes and clock at the same time, mine did (for output) so i had to seperate them, one interface does notes, one clock only.

AKROC
Posts: 22
Joined: Fri Apr 22, 2011 4:40 pm

Re: MPC with Ableton, sync issue, need help

Post by AKROC » Tue Dec 23, 2014 5:00 am

Edit: If it´s not that, maybe your interface struggles with receiving notes and clock at the same time, mine did (for output) so i had to seperate them, one interface does notes, one clock only.[/quote]

yeah maybe its that, good thinking. Im using a presonus firestudio, fairly decent interface. It's weird because this problem only happens when the playback on the MPC is stopped. When I play/start on the MPC and then hit the pads, the midi notes play back as they should (not cutting off). I don't know if that gives you any clues. How did you end up fixing it? do you have two interfaces now, or one with multiple midi ins, and if so which one?
Thanks man

be tonal
Posts: 56
Joined: Tue May 17, 2011 8:15 am

Re: MPC with Ableton, sync issue, need help

Post by be tonal » Tue Dec 23, 2014 11:14 am

I gave up on syncing Live to a clock,i run it as master (that´s on windows, maybe it works better with macs).Using a cheap ESI 2in2out interface, 1 for the clock, one for the notes. Incoming notes i receive on a Terrasoniq MIDI One as the esi didn´t like too many notes at the "same" time.

You might not have full blown midi feedback, just some doubling of notes. Try recording without the sync.
On second reading, do you record your notes in the mpc?
You need to figure out what gets sent where, check the recorded data on the mpc, check what´s arriving at the pc with midiox or similar. Switch off the thru settings in the mpc, make sure ableton is not sending anything back to the mpc.

Good luck!

Post Reply