Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
Posts: 1
Joined: Sun Dec 21, 2014 3:47 pm


Post by sammbutton » Tue Dec 23, 2014 4:18 pm

Hi,my name is Samm, i am rather new to max but slowly getting into it.
I am having problems with some controllers to be exact with the cc numbers.When i map a knob on the nanokontrol 2 it displays cc 16 as mapping but the apc40 has the same cc number to it so turning the knob on the nanokontrol automaticly turns the first knob on the apc40 device control, thus making it unable to control other devices. i hope i got this right. My question is how can i assign a different cc number to the nanokontrol so it doesn’t interfere with the apc40.

Posts: 353
Joined: Fri Mar 07, 2014 7:42 pm


Post by JoshG567 » Tue Dec 23, 2014 6:23 pm

If they're configured to send the signal on the same channel (1-16) you should re-config so they don't share and conflict. I keep a damn spreadsheet to keep track of my controller configs.

If you can't reconfig you may have success using each as a track input, rather than remote, and making a M4L device that's unique to each device and routing them into discrete tracks. That way only the individual tracks are listening for MIDI from the controllers and not Live as a whole.

Posts: 6591
Joined: Sat Oct 03, 2009 3:02 am
Location: Menasha, Wisconsin


Post by yur2die4 » Tue Dec 23, 2014 8:20 pm

Do you map things on the APC also? If you do not actually do mapping (blue screen), then you can turn 'Remote' off for the APC in midi preferences.

Posts: 337
Joined: Fri Mar 22, 2013 5:52 am


Post by Asymmetricalmusic » Wed Dec 24, 2014 6:56 am

The Apc40 mk1(not sure about mk2) uses MIDI Channels 1-9 so use MIDI channel 10 cc16 and that should fix your problem also........ if you dont want to have to specify each MIDI track to a specific controller.

Hope this helps......

Post Reply