Help! Pack won't fully install...

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
mereridhaf
Posts: 2
Joined: Tue Jun 02, 2015 3:09 pm

Help! Pack won't fully install...

Post by mereridhaf » Tue Jun 02, 2015 3:16 pm

Hi, have tried searching for an answer to this everywhere with no luck - can anyone help?

I'm trying to install Partner Instruments Compilation pack onto Live 9 Intro but it won't fully install due to being unable to change the filename of one file, which then cancels the whole process. I have full admin permissions on my PC and am installing all packs into a central C: directory (not My Documents)

This is the pack I want to install: https://www.ableton.com/en/packs/partne ... _type=free particularly as it has acoustic piano - so if there's any other alternatives I'm open to suggestions.

Thanks in advance!

mereridhaf
Posts: 2
Joined: Tue Jun 02, 2015 3:09 pm

Re: Help! Pack won't fully install...

Post by mereridhaf » Tue Jun 02, 2015 6:02 pm

Update: this is the error message I get https://www.dropbox.com/s/6prgp1qptd6uv ... d.jpg?dl=0 :x

MaggieL
Posts: 2
Joined: Sat Jun 13, 2015 3:44 pm

Re: Help! Pack won't fully install...

Post by MaggieL » Sat Jun 13, 2015 3:45 pm

Same problem here: Windows 8.1 and Live 9 intro

MaggieL
Posts: 2
Joined: Sat Jun 13, 2015 3:44 pm

Re: Help! Pack won't fully install...

Post by MaggieL » Sat Jun 13, 2015 4:05 pm

Looks like it's hitting a filename length limit.

LooFoX
Posts: 1
Joined: Wed Jun 17, 2015 2:54 pm

Re: Help! Pack won't fully install...

Post by LooFoX » Wed Jun 17, 2015 2:56 pm

I have exactly the same problem on Live 9 Standard and Windows 7.

Does anyone have a solution for this?

DukeOfPrunes
Posts: 44
Joined: Fri Jun 05, 2015 11:15 am

Re: Help! Pack won't fully install...

Post by DukeOfPrunes » Fri Nov 06, 2015 10:08 pm

Same problem here! Sucks 'cuz it seems to be a good pack. I wonder if other peeps are encountering the same issue?

Still recovering from the shock of seeing Push 2 emerging only 3 months I bought Push...Man, I got me some serious GAS now! Not sure how I will stop the shakes.

H20nly
Posts: 15838
Joined: Sat Oct 27, 2007 9:15 pm
Location: The Wild West

Re: Help! Pack won't fully install...

Post by H20nly » Fri Nov 06, 2015 11:24 pm

MaggieL wrote:Looks like it's hitting a filename length limit.
yep.

you might be able to get around it by making a fake library at C:\

call it something short like "AL" - C:\AL
hopefully this will shorten the path enough to allow the install.

...then point your live library to that location in Preferences. install the pack, then manually move it over to your actual library and change Preferences back in Live.

before you move the file to your real library, maybe remove the word "compilation" from all the folder names. this will help make sure that the path isn't too long for other purposes like backups and such.

unfortunately, you will probably have to wait for the browser to re-index after doing this.

hth

DukeOfPrunes
Posts: 44
Joined: Fri Jun 05, 2015 11:15 am

Re: Help! Pack won't fully install...

Post by DukeOfPrunes » Sat Nov 07, 2015 1:41 am

H20nly wrote:
MaggieL wrote:Looks like it's hitting a filename length limit.
yep.

you might be able to get around it by making a fake library at C:\

call it something short like "AL" - C:\AL
hopefully this will shorten the path enough to allow the install.

...then point your live library to that location in Preferences. install the pack, then manually move it over to your actual library and change Preferences back in Live.

before you move the file to your real library, maybe remove the word "compilation" from all the folder names. this will help make sure that the path isn't too long for other purposes like backups and such.

unfortunately, you will probably have to wait for the browser to re-index after doing this.

hth
Well well, aren't you the clever one! Brilliant idea. I'm so wrapped-up in the box that I can't see the forest from the trees!

Thanks for the good tip!

Jean.

UnderwaterSunlight
Posts: 103
Joined: Mon Jun 18, 2007 7:59 am
Location: House atop a Tree

Re: Help! Pack won't fully install...

Post by UnderwaterSunlight » Sat Nov 07, 2015 11:40 am

Yep, same situation here.
See my signature.
Mac Pro 6,1 (Late 2013), 64 GB RAM, 256 GB PCIE SSD, 1TB data/projects SSD, MacOS 10.14 Mojave, Ableton 10 Standard, Komplete 7, Waves Silver, Steinberg UR22 mkII

H20nly
Posts: 15838
Joined: Sat Oct 27, 2007 9:15 pm
Location: The Wild West

Re: Help! Pack won't fully install...

Post by H20nly » Mon Nov 09, 2015 10:31 pm

DukeOfPrunes wrote:
H20nly wrote:
MaggieL wrote:Looks like it's hitting a filename length limit.
yep.

you might be able to get around it by making a fake library at C:\

call it something short like "AL" - C:\AL
hopefully this will shorten the path enough to allow the install.

...then point your live library to that location in Preferences. install the pack, then manually move it over to your actual library and change Preferences back in Live.

before you move the file to your real library, maybe remove the word "compilation" from all the folder names. this will help make sure that the path isn't too long for other purposes like backups and such.

unfortunately, you will probably have to wait for the browser to re-index after doing this.

hth
Well well, aren't you the clever one! Brilliant idea. I'm so wrapped-up in the box that I can't see the forest from the trees!

Thanks for the good tip!

Jean.
did it work??

DukeOfPrunes
Posts: 44
Joined: Fri Jun 05, 2015 11:15 am

Re: Help! Pack won't fully install...

Post by DukeOfPrunes » Mon Nov 09, 2015 11:47 pm

Yes Sir. Quite clever, you are! Thanks again!

fishmonkey
Posts: 4099
Joined: Wed Oct 24, 2007 4:50 am

Re: Help! Pack won't fully install...

Post by fishmonkey » Tue Nov 10, 2015 3:15 am

the stoopid filename limit is one of the most annoying legacy Windows limitations...
badbrainz wrote: I'm a drummer, so I'm already at an intellectual disadvantage here

H20nly
Posts: 15838
Joined: Sat Oct 27, 2007 9:15 pm
Location: The Wild West

Re: Help! Pack won't fully install...

Post by H20nly » Tue Nov 10, 2015 5:59 am

fishmonkey wrote:the stoopid filename limit is one of the most annoying legacy Windows limitations...
It really is, but in all fairness... the one from the pack was ridiculously looooooong. fixing it means it won't get lost in a backup. nothing worse than trying to restore a backup only to find that the file name was truncated and the file no longer can be found/reassembled.

fishmonkey
Posts: 4099
Joined: Wed Oct 24, 2007 4:50 am

Re: Help! Pack won't fully install...

Post by fishmonkey » Tue Nov 10, 2015 6:14 am

it is uncommonly long, however i run into this problem regularly working between OS X and Windows...
badbrainz wrote: I'm a drummer, so I'm already at an intellectual disadvantage here

Richie Witch
Posts: 881
Joined: Mon Feb 10, 2014 10:10 pm
Location: Space Coast, Central Florida

Re: Help! Pack won't fully install...

Post by Richie Witch » Fri Nov 27, 2015 7:11 pm

H20nly wrote:you might be able to get around it by making a fake library at C:\

call it something short like "AL" - C:\AL
hopefully this will shorten the path enough to allow the install.

...then point your live library to that location in Preferences. install the pack, then manually move it over to your actual library and change Preferences back in Live.

before you move the file to your real library, maybe remove the word "compilation" from all the folder names. this will help make sure that the path isn't too long for other purposes like backups and such.

unfortunately, you will probably have to wait for the browser to re-index after doing this.

hth
Just tried this and it works perfectly! Thanks for this tip!! True enough, re-indexing takes a *very* long time (about 20 minutes for my library, even with high-speed SATA drives.
Win7/Intel i7 rig | Live 9.7.5 | Yamaha, Korg, and Novation synths, and 12U of Eurorack | Mackie Onyx 1620i mixer/interface | various outboard gear | Dune 2, Circle2, Enzyme, Kontakt |
current studio pic -> https://photos.app.goo.gl/svVvXwLuCSjVJG8c2

Post Reply