This VST Plug-in is not compatible with Live - 9.2 error

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
biestyboy
Posts: 125
Joined: Tue Jan 10, 2006 11:28 am
Location: Troon, Scotland

This VST Plug-in is not compatible with Live - 9.2 error

Post by biestyboy » Mon Jun 29, 2015 7:54 pm

Just upgraded Live to 9.2 64 bit (from 9.1.7) and Max 7 but when I try to open my project I was working on yesterday I'm getting this error:

VST "Replika". This VST Plug-in is not compatible with Live.

It was perfectly bloody compatible yesterday so a bit of a pain to say the least. Anyone else use NI Replika and having issues since upgrade?
Live 10 Suite (64 bit)
Windows 10 (64 bit)
Plugins galore
Push

ark
Posts: 1349
Joined: Thu Feb 26, 2009 4:25 pm
Location: New Jersey, USA
Contact:

Re: This VST Plug-in is not compatible with Live - 9.2 error

Post by ark » Tue Jun 30, 2015 3:08 am

Yup. When I have Replika among my VSTs, Live 9.2 crashes on startup. When I remove Replika, Live starts up.

I don't know whether the bug is in Live or in Replika. I have reported the problem to Ableton; presumably they'll fix it in the fullness of time.

bakku
Posts: 35
Joined: Wed Sep 23, 2009 4:11 am

Re: This VST Plug-in is not compatible with Live - 9.2 error

Post by bakku » Tue Jun 30, 2015 7:09 am

I got a reply from Ableton
"As Live version 9.2 does make some improvements to the handling of VST plugins, certain plugins which are not up to date may not be compatible…"

liquidsonics, Exponential audio…plugins are critical for me, stop working after upgrade to 9.2 :evil:

I rolled back to previous version.

do_om
Posts: 48
Joined: Fri Sep 15, 2006 3:43 am

Re: This VST Plug-in is not compatible with Live - 9.2 error

Post by do_om » Tue Jun 30, 2015 9:33 am

Yeah, I'm a victim of the same improvements...None of my Kush plugs work. I informed them about it in beta
but yeah, not a priority I guess. I think Live's spec should be updated to 3rd part VST's may or may not work,
use at own risk. I have been a user since V2 and the constant issues w/ crashes and projects that all of a sudden
won't load...All 3rd party plug issues.

bluyckx
Posts: 4
Joined: Tue Jun 30, 2015 9:58 am

Re: This VST Plug-in is not compatible with Live - 9.2 error

Post by bluyckx » Tue Jun 30, 2015 10:10 am

same here

all plugins work (as far as I know), except for Replika

I have the impression it's up to NI to fix the plugin, but it's up to ableton to do a better job of catching these exceptions:
only the first instance of the plugin is blocked with the message that it is incompatible.
When you try to load a set with two instances, or when you try to load another with only one instance or the same set again, ableton crashes.

I was able to load any set with only one instance of the plugin after restarting live each time.
Removed the empty effect rack that live left on my send and replace it with a couple of effects to mimic replika then saved.

No luck with sets that contain more than one instance of the plugin.

Not so happy with the way either NI or Ableton has handled this, since it was an obvious problem throughout beta testing apparently.
Should have been in a list with known problems in the release notes.

biestyboy
Posts: 125
Joined: Tue Jan 10, 2006 11:28 am
Location: Troon, Scotland

Re: This VST Plug-in is not compatible with Live - 9.2 error

Post by biestyboy » Tue Jun 30, 2015 10:16 am

bakku wrote:I got a reply from Ableton
"As Live version 9.2 does make some improvements to the handling of VST plugins, certain plugins which are not up to date may not be compatible…"

liquidsonics, Exponential audio…plugins are critical for me, stop working after upgrade to 9.2 :evil:

I rolled back to previous version.
Not sure about the other plugins mentioned but Replika was only released 6 months ago so it's certainly up to date. Ableton should release a statement stating which plugins are affected rather than letting people find out the hard way.
Live 10 Suite (64 bit)
Windows 10 (64 bit)
Plugins galore
Push

bluyckx
Posts: 4
Joined: Tue Jun 30, 2015 9:58 am

Re: This VST Plug-in is not compatible with Live - 9.2 -- SOLVED

Post by bluyckx » Tue Jun 30, 2015 3:22 pm

What I did:

uninstall Replika

restart for good measure

Go to the NI website, log in and find the updates and do a search for Replika
While on the website copy the serial number down
If you kept the original download, find it and install Replika 1.2.0

open Live, check if it was detected, drop it on a track, activate and Bob 's your uncle.

I haven't tried to update to 1.2.1 or 1.2.2 yet
Anyone brave enough to let us know how that went? 8)


Update: while my problem is solved with replika, it seems there is still the question of random crashes with every third or fourth set I load. :cry:
Last edited by bluyckx on Tue Jun 30, 2015 3:39 pm, edited 1 time in total.

[rry]
Posts: 17
Joined: Wed Jan 09, 2013 5:09 pm
Location: Ableton HQ

Re: This VST Plug-in is not compatible with Live - 9.2 -- SOLVED

Post by [rry] » Tue Jun 30, 2015 3:31 pm

bluyckx wrote: I haven't tried to update to 1.2.1 or 1.2.2 yet
Anyone brave enough to let us know how that went? 8)
As far as I know Replica 1.2.1 works fine, just 1.2.3 doesn't. I imagine that NI used an older compiler accidentally, and that a fix is not too difficult / far away.
The Kush Audio problem is known and we are already investigating this with Kush.

For all other plugins, please see this article.
https://www.ableton.com/en/help/article ... ements-92/

Best,
Rory

regretfullySaid
Posts: 8913
Joined: Thu Apr 22, 2010 5:50 pm

Re: This VST Plug-in is not compatible with Live - 9.2 error

Post by regretfullySaid » Tue Jun 30, 2015 3:33 pm

n/m I had v 1.2.0
Last edited by regretfullySaid on Tue Jun 30, 2015 4:14 pm, edited 2 times in total.
ImageImage

[tow]
Posts: 257
Joined: Wed Jun 13, 2007 10:50 am
Location: Ableton Headquarters

Re: This VST Plug-in is not compatible with Live - 9.2 error

Post by [tow] » Tue Jun 30, 2015 3:41 pm

Hello everybody,

these are two different things:

1. The NI Replika plug-in, version 1.2.2, doesn't work with Live 9.2.
The previous version 1.2.1 works fine with Live 9.2 and is still available for download on NI's website, which would be the temporary workaround for this problem. We were in contact with NI already and they are looking into the problem.
For further details, please contact Native Instruments directly.

2. For other older or legacy plug-ins that are causing trouble with Live 9.2, please refer to
our article about the changes of plug-in handling with Live 9.2.

Best,

Torsten

ark
Posts: 1349
Joined: Thu Feb 26, 2009 4:25 pm
Location: New Jersey, USA
Contact:

Re: This VST Plug-in is not compatible with Live - 9.2 error

Post by ark » Tue Jun 30, 2015 7:40 pm

Ableton says Native Instruments will fix the problem in the next release of Replica, coming soon.

lvehon
Posts: 143
Joined: Mon Dec 03, 2007 5:28 pm

Re: This VST Plug-in is not compatible with Live - 9.2 error

Post by lvehon » Wed Jul 01, 2015 7:52 pm

Rolling back, having plugin issues here as well.

sKulptureOfficial
Posts: 9
Joined: Wed Jul 01, 2015 8:35 am

Re: This VST Plug-in is not compatible with Live - 9.2 error

Post by sKulptureOfficial » Wed Jul 01, 2015 10:28 pm

Has anybody else here got the mfc120u.dll error?

It just happened to me last night!!

wow what a piss off!

Half way into making a beat and had to take my pooch for a walk! came back tried starting ableton! Got this error!!

It is easily fixed though!

biestyboy
Posts: 125
Joined: Tue Jan 10, 2006 11:28 am
Location: Troon, Scotland

Re: This VST Plug-in is not compatible with Live - 9.2 error

Post by biestyboy » Thu Jul 02, 2015 9:41 am

[tow] wrote:Hello everybody,

these are two different things:

1. The NI Replika plug-in, version 1.2.2, doesn't work with Live 9.2.
The previous version 1.2.1 works fine with Live 9.2 and is still available for download on NI's website, which would be the temporary workaround for this problem. We were in contact with NI already and they are looking into the problem.
For further details, please contact Native Instruments directly.

2. For other older or legacy plug-ins that are causing trouble with Live 9.2, please refer to
our article about the changes of plug-in handling with Live 9.2.

Best,

Torsten
Yup, rolling back to 1.2.1 works fine. Thanks for the advice.
Live 10 Suite (64 bit)
Windows 10 (64 bit)
Plugins galore
Push

[jur]
Site Admin
Posts: 2288
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: This VST Plug-in is not compatible with Live - 9.2 error

Post by [jur] » Thu Jul 02, 2015 10:15 am

sKulptureOfficial wrote:Has anybody else here got the mfc120u.dll error?

It just happened to me last night!!

wow what a piss off!

Half way into making a beat and had to take my pooch for a walk! came back tried starting ableton! Got this error!!

It is easily fixed though!

Have a look here for the fix
Ableton Forum Moderator

Post Reply