Problem with 9.2 and APC40mkII Device Control, Pan, Sends

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
TYLRbass
Posts: 277
Joined: Tue Aug 30, 2011 8:51 pm

Problem with 9.2 and APC40mkII Device Control, Pan, Sends

Post by TYLRbass » Thu Jul 02, 2015 8:12 pm

Is anyone experiencing funky knob reaction when using the APC40mkII in Live 9.2?

I'm running OS X 10.10.2, I've been in touch with Ableton support and they have been very helpful.

Basically, anything controlled by device control, pan, send will react in a strange way: with a smooth twist from 0-127 on any hard-mapped control you will get a smooth reaction in the software, with any pan, device control, or send level knob you will get a jumpy reaction and it takes about 1.5x as much of a twist to go from 0-127 or 127-0. I have then hard-mapped these same controls and they work fine, so it seems to be linked to any controls that are using the APC40mkII control surface script and not when re-mapped. This is only happening on the APC40mkII and I have tried other USB ports, cables, etc .. switching USB ports worked and it also worked when I switched back but after a restart and loading a set the problem is back and persisting.

But Ableton support said they haven't made any changes to the script in the newest release, but it worked fine on my 9.1.7 install so I am lost.

If you are having the same issue please let me know, it'd be nice to know I'm not the only one

Post Reply