How to get LED Feedback in custom MIDI Remote Script?

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
towers of silence
Posts: 70
Joined: Tue Jan 06, 2009 11:32 pm
Location: Portsmouth, NH

How to get LED Feedback in custom MIDI Remote Script?

Post by towers of silence » Sun Oct 04, 2015 3:22 pm

I'm modifying Myr's NanoKontrol MIDI Remote script for use with my trusty old NanoKontrol V1 and I'd like to try and get some basic LED feedback for the lower buttons when used as clip launchers. i don't want anything fancy, just to have the LED on when a clip is playing and off when it's not. I cannot for the life of me figure out how to do this...I've check ed out some decompiled scripts but they don't really help me out in this specific instance, anyone have any idea how to do this?

EDIT- here's the script in question that I'm working with
http://archive.monome.org/community/discussion/5510/x

S4racen
Posts: 5234
Joined: Fri Aug 24, 2007 4:08 pm
Location: Dunstable
Contact:

Re: How to get LED Feedback in custom MIDI Remote Script?

Post by S4racen » Sun Oct 04, 2015 6:00 pm

I believe the mk1 nano kontrol doesn't support led feedback...

Cheers
D

towers of silence
Posts: 70
Joined: Tue Jan 06, 2009 11:32 pm
Location: Portsmouth, NH

Re: How to get LED Feedback in custom MIDI Remote Script?

Post by towers of silence » Mon Oct 05, 2015 2:23 am

Thanks for your answer- I have a feeling you are correct. After messing around with the Python code for a few hours this afternoon it seems like LED feedback is simply dependent on whether or not the button is toggle or momentary, it has nothing to do with anything that is happening in the live set so it looks like it's a dead end for me.

Now if I can only figure out how to alter the code to only use certain buttons to launch clips, not a whole bank of them...

Post Reply