Live 9.5

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
solovox
Posts: 253
Joined: Sat Jan 04, 2003 6:41 am
Location: Portland
Contact:

Re: Live 9.5

Post by solovox » Thu Nov 05, 2015 10:22 pm

For those of you that agree Ableton needs to give users the option of having clip colors automatically all be the same as a track, please VOTE here:

viewtopic.php?f=1&t=218233&start=0
Live Show Rig: quad-core i7, 16 gig RAM, SSD, MOTU Ultralite, Windows 7.

Desktop Rig: 8 core Xeon, 20 gig RAM, RAID 0 drives, Echo Layla PCI, Windows 10

re:dream
Posts: 4554
Joined: Fri Dec 28, 2007 9:42 am
Location: Hoerikwaggo's sunset side...
Contact:

Re: Live 9.5

Post by re:dream » Fri Nov 06, 2015 4:57 am

Anyone getting crashes?

I am, with the new M4L synths...

Tarekith
Posts: 17364
Joined: Fri Jan 07, 2005 11:46 pm
Location: Ableton Forum Administrator
Contact:

Re: Live 9.5

Post by Tarekith » Fri Nov 06, 2015 7:12 am

Are you using the latest version of Max? Do you have java installed?

oddstep
Posts: 1732
Joined: Tue Feb 12, 2008 9:47 pm
Location: Plymouth the great

Re: Live 9.5

Post by oddstep » Fri Nov 06, 2015 9:22 am

solovox wrote:For those of you that agree Ableton needs to give users the option of having clip colors automatically all be the same as a track, please VOTE here:

viewtopic.php?f=1&t=218233&start=0
i'd rather they focussed developer time on making sampler as good as simpler and opening up the audio clip to simpler conversion api call to non-push users.

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Live 9.5

Post by Stromkraft » Fri Nov 06, 2015 9:27 am

oddstep wrote:
solovox wrote:For those of you that agree Ableton needs to give users the option of having clip colors automatically all be the same as a track, please VOTE here:

viewtopic.php?f=1&t=218233&start=0
i'd rather they focussed developer time on making sampler as good as simpler and opening up the audio clip to simpler conversion api call to non-push users.
yeah, but the priority is in the hands of Ableton staff and totally unnecessary for us to speculate in. Software is not a command economy. I'd think it's safe to say Sampler development is already under way. Make Sampler as good as Simpler is way too low to aim.
Make some music!

oddstep
Posts: 1732
Joined: Tue Feb 12, 2008 9:47 pm
Location: Plymouth the great

Re: Live 9.5

Post by oddstep » Fri Nov 06, 2015 9:42 am

agreed

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Live 9.5

Post by Stromkraft » Fri Nov 06, 2015 11:27 am

oddstep wrote:agreed
That said, suggesting to Ableton ideas you have I think is welcomed, especially if you have well thought out ideas that brings value and that you can explain well.
Make some music!

pskept
Posts: 86
Joined: Thu Nov 12, 2009 3:58 pm
Location: here now

Re: Live 9.5

Post by pskept » Fri Nov 06, 2015 3:38 pm

Tarekith wrote:Are you using the latest version of Max? Do you have java installed?
hey could you elaborate or why you are asking about java or point me in a direction to do my own reading? thanks.

tldr max 6 + new synth = crash, max 7 + new synth = no crash

i just got 9.5 installed last night so I've not taken it for enough of a drive to give a solid report but I can say that I have been avoiding max 7 because it makes my audio sound like farts and glitches and if I switch back to using max 6 it is fart free. However, last night when I popped in one of the new synths from the new max essentials packed live crashed immediately. I checked the max path and it was pointing at 6. I switched it to max 7 and the synth worked. Couldn't play long enough to see if it was fart sound free or not because my SSD started to fail :(

Tarekith
Posts: 17364
Joined: Fri Jan 07, 2005 11:46 pm
Location: Ableton Forum Administrator
Contact:

Re: Live 9.5

Post by Tarekith » Fri Nov 06, 2015 3:52 pm

Max needs Java to work, and the new M4L plug ins need Max 7, that's why I asked.

beats me
Posts: 23319
Joined: Fri Mar 30, 2007 6:39 pm

Re: Live 9.5

Post by beats me » Fri Nov 06, 2015 3:56 pm

I’m assuming this is a great time to upgrade to 9, possibly with a holiday discount soon. Not so much for the new features as much as they probably aren’t going to drop 10 in the near future and then the inevitable “I just bought 9 and now they want me to pay more for 10!!!!” whining.

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Live 9.5

Post by Stromkraft » Fri Nov 06, 2015 7:18 pm

Tarekith wrote:Max needs Java to work
While that is true in practice, Java is not needed for Max itself to work. The dependency exists because some devices could peruse Java byte code and Cycling74 at some point decided to handle that possible dependency on a Java Virtual Machine this way.

I have already pointed out to Cycling74, around when Max 7 was released, that not listing Java as a requirement is very odd. I received an informative answer, but it will probably be a while before this Java business changes.

Meanwhile the Java Virtual Machine is very common in server environments, also for other programming languages and frameworks.

It won't go away any time soon there, but Cycling74 need to at some point make Java optional only to use for those devices that actually need it. Fluid music or whatever it's called needs it for example.
Last edited by Stromkraft on Fri Nov 13, 2015 4:22 pm, edited 2 times in total.
Make some music!

stringtapper
Posts: 6272
Joined: Sat Aug 28, 2004 6:21 pm

Re: Live 9.5

Post by stringtapper » Fri Nov 06, 2015 7:53 pm

Stromkraft wrote:
Tarekith wrote:Max needs Java to work
While that is true in practice, Java is not needed for Max itself to work. The dependency exists because some devices could peruse Java byte code and Cycling74 at some point decided to handle that possible dependency on a Java Virtual Machine this way.

I have already pointed out to Cycling74, around when Max 7 was released, that not listing Java as a requirement is very odd. I received a an informative answer, but in the end it will be a while before this Java business will change.

Meanwhile the Java Virtual Machine is very common in server environments, also for other programming languages and frameworks.

It won't go away any time soon there, but Cycling74 need to at some point make Java optional only to use for those devices that actually need it. Fluid music or whatever it's called needs it for example.
It's not just about M4L devices that use it. It's the fact that the [mxj] and [mxj~] objects are and have been a part of Max's object set for some time now. If they were externals that someone had to install themselves then it would make sense to not require Java, but they're not. They're part of the regular Max distribution. [mxj] and [mxj~] would have to become deprecated for this to go away, so I would modify your "won't go away any time soon" to "probably never."
Unsound Designer

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Live 9.5

Post by Stromkraft » Sat Nov 07, 2015 7:52 pm

stringtapper wrote: It's not just about M4L devices that use it. It's the fact that the [mxj] and [mxj~] objects are and have been a part of Max's object set for some time now. If they were externals that someone had to install themselves then it would make sense to not require Java, but they're not. They're part of the regular Max distribution. [mxj] and [mxj~] would have to become deprecated for this to go away, so I would modify your "won't go away any time soon" to "probably never."
That sounds credible and makes it even stranger to not list Java as a requirement. I also suggested to Cycling74 to consider optionally supplying their own JVM inside the app, which makes much sense on the Mac platform. This is not an uncommon solution.
Make some music!

kitekrazy
Posts: 731
Joined: Sat Jan 16, 2010 7:16 pm

Re: Live 9.5

Post by kitekrazy » Sat Nov 07, 2015 7:57 pm

Stromkraft wrote:
oddstep wrote:
solovox wrote:For those of you that agree Ableton needs to give users the option of having clip colors automatically all be the same as a track, please VOTE here:

viewtopic.php?f=1&t=218233&start=0
i'd rather they focussed developer time on making sampler as good as simpler and opening up the audio clip to simpler conversion api call to non-push users.
yeah, but the priority is in the hands of Ableton staff and totally unnecessary for us to speculate in. Software is not a command economy. I'd think it's safe to say Sampler development is already under way. Make Sampler as good as Simpler is way too low to aim.
Sampler is quite tedious to use compared to Kontakt. Simpler is simpler. I would think the average user prefers Simpler. Sampler requires Live Suite or separate purchase.

pskept
Posts: 86
Joined: Thu Nov 12, 2009 3:58 pm
Location: here now

Re: Live 9.5

Post by pskept » Sat Nov 07, 2015 8:32 pm

Tarekith wrote:Max needs Java to work, and the new M4L plug ins need Max 7, that's why I asked.
thanks. i'm going to go install it now and see if it resolves the one remaining issue i'm having.

Post Reply