Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live

Bring Back Auto-Assign Colors to pre-9.5 functionality please!

YES: Having every clip the exact same color in a track makes it very difficult to tell different musical ideas apart, especially on-stage. Give users the OPTION of turning this on or off please.
86
83%
NO: Keep this new functionality in 9.5 and do not give users a choice in changing it
18
17%
 
Total votes: 104

skymakai
Posts: 9
Joined: Tue Aug 24, 2010 10:15 pm

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Post by skymakai » Thu Nov 12, 2015 8:55 pm

I've found that previous clip colors saved with the .asd files won't work anymore.

Here's the email I just sent:

Dear Ableton development team,

Thank you, from the bottom of my heart, for what you do.
I’ve been using Ableton Live as my primary production tool and DJ tool, for the greater part of the last decade. It’s brought me further in both endeavors than any other tool has done. I’ve been thankful for the new features added in each version, and the continuous focus on improving the experience.

However, I’m currently faced with a very frustrating experience, with a change… or rather, a feature which was removed from Live, in the 9.5 update. Clip color options no longer allow clips to retain their previous color setting, even when manually saved in the .asd file; When importing a song or audio file which I’ve already warped and saved settings for, the clip color is automatically changed to either the Track color (Automatic), or the clip color determined in Settings (Manual). The removal of this feature greatly impacts my workflow, as I’ve spent countless hours saving clip colors to help make sense of my clips in live use.

Please bring this feature back, as it seems like such a simple thing to re-impliment. Of course, also keep the option to color clips based on track color. That was a wonderful improvement to add.

Clip colors have, for years, been an overlooked feature in Live. I look forward to more improvements to clip color options, in the future.

solovox
Posts: 253
Joined: Sat Jan 04, 2003 6:41 am
Location: Portland
Contact:

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Post by solovox » Thu Nov 12, 2015 9:13 pm

skymakai wrote:I've found that previous clip colors saved with the .asd files won't work anymore.

Here's the email I just sent:

Dear Ableton development team,

Thank you, from the bottom of my heart, for what you do.
I’ve been using Ableton Live as my primary production tool and DJ tool, for the greater part of the last decade. It’s brought me further in both endeavors than any other tool has done. I’ve been thankful for the new features added in each version, and the continuous focus on improving the experience.

However, I’m currently faced with a very frustrating experience, with a change… or rather, a feature which was removed from Live, in the 9.5 update. Clip color options no longer allow clips to retain their previous color setting, even when manually saved in the .asd file; When importing a song or audio file which I’ve already warped and saved settings for, the clip color is automatically changed to either the Track color (Automatic), or the clip color determined in Settings (Manual). The removal of this feature greatly impacts my workflow, as I’ve spent countless hours saving clip colors to help make sense of my clips in live use.

Please bring this feature back, as it seems like such a simple thing to re-impliment. Of course, also keep the option to color clips based on track color. That was a wonderful improvement to add.

Clip colors have, for years, been an overlooked feature in Live. I look forward to more improvements to clip color options, in the future.
Yikes! I didn't even realize this was happening as well. Fixing this is sounding more important than ever. I hope they are having a meeting about this right now. One can hope!
Live Show Rig: quad-core i7, 16 gig RAM, SSD, MOTU Ultralite, Windows 7.

Desktop Rig: 8 core Xeon, 20 gig RAM, RAID 0 drives, Echo Layla PCI, Windows 10

oblique strategies
Posts: 3580
Joined: Thu Nov 02, 2006 9:57 pm
Location: Another Green World

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Post by oblique strategies » Thu Nov 12, 2015 9:25 pm

skymakai wrote:I've found that previous clip colors saved with the .asd files won't work anymore.
This is the same bug I mentioned earlier. You'll be glad to know that Ableton are aware of it & are/will be working on it.

Here's the response I received from Ableton Support:
"The behaviour you describe is indeed a bug: any clip which is already saved with a color should of course keep this colour even when imported to a track of a different colour. We have filed this as a story for our developers and hope this can be fixed quickly."

skymakai
Posts: 9
Joined: Tue Aug 24, 2010 10:15 pm

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Post by skymakai » Fri Nov 13, 2015 4:19 am

Thanks, eO.

I saw that it's been reported as a bug. I look forward to a fix. In the meanwhile, I'm seriously considering changing away from Live as my primary DJ software. Unfortunately, I'm seeing more and more... that Ableton is not focused on maintaining and focusing on features for the Live DJ.

staxxx
Posts: 2
Joined: Fri Nov 13, 2015 9:52 pm

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Post by staxxx » Fri Nov 13, 2015 9:59 pm

Oh man!

I'm with everyone on this. I totally see the usefulness of the two new options for color assignment in 9.5, BUT BUT BUT! Losing random color assignment has really messed with my work flow.

I created a custom template with specific colors to kick start any new session. That template is null and void, my carefully chosen color scheme is gone. The specific problem is that there are only two alternatives and neither is acceptable for my needs.

Alternative 1) Live set new random colors - not helpful, since they are different every time I launch!!
Alternative 2) Use a pre-determined color for all new tracks. Also not helpful because, not only are all tracks the same color now, in both cases, all clips are assigned the same color as the track. I can't quickly differentiate between takes, variations, edits, or clips I've composed on one track and am mirroring on another track.

The whole thing has slowed me down. We should have a "legacy color" option, which sets everything back to the classic color assignment. I'm really surprised Ableton bungled on this feature!

skymakai
Posts: 9
Joined: Tue Aug 24, 2010 10:15 pm

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Post by skymakai » Sat Nov 14, 2015 4:57 pm

I got word back from Ableton Support...

They said that the issue is a bug, and should be fixed in the next incremental update. And... if you save clips to your User Library, they should retain their color settings.

solovox
Posts: 253
Joined: Sat Jan 04, 2003 6:41 am
Location: Portland
Contact:

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Post by solovox » Thu Nov 26, 2015 9:28 am

Okay Ableton--it's been a few weeks. How's this coming along? An Options.txt would be a perfectly acceptable solution for us if that works for you. :-)
Live Show Rig: quad-core i7, 16 gig RAM, SSD, MOTU Ultralite, Windows 7.

Desktop Rig: 8 core Xeon, 20 gig RAM, RAID 0 drives, Echo Layla PCI, Windows 10

[art]
Posts: 368
Joined: Mon Sep 04, 2006 3:29 am
Contact:

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Post by [art] » Tue Dec 01, 2015 9:55 am

Looks like this was just re-implemented in the latest beta.

Really love how quick Abes are moving on things at the mo

Tarekith
Posts: 17537
Joined: Fri Jan 07, 2005 11:46 pm
Location: Ableton Forum Administrator
Contact:

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Post by Tarekith » Tue Dec 01, 2015 10:24 am

Yes there's now an option for random clip colors again in the new beta, people in this thread can breath a sigh of relief now. :)

zeepster
Posts: 312
Joined: Thu Sep 27, 2007 2:03 pm

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Post by zeepster » Tue Dec 01, 2015 2:26 pm

How about the "No Color" option??

foxymethoxy
Posts: 97
Joined: Wed Jan 16, 2008 5:43 am

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Post by foxymethoxy » Tue Dec 01, 2015 6:12 pm

zeepster wrote:How about the "No Color" option??
Yeah, I really want No Color option back!

LFO8
Posts: 333
Joined: Fri May 01, 2009 7:12 pm

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Post by LFO8 » Tue Dec 01, 2015 6:37 pm

I would like it if clips also changed their color if I change the track color.

tintala
Posts: 465
Joined: Mon Nov 29, 2010 5:37 pm

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Post by tintala » Tue Dec 01, 2015 7:29 pm

So ABes is saying they don't want to clutter the UI. adding an option to change the colors is not clutter! I have been assigning colors to different tracks since I started. I carefully choose colors schemes based on the "type" of track... it's simple. Now its gone.

I vote yes.

zeepster
Posts: 312
Joined: Thu Sep 27, 2007 2:03 pm

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Post by zeepster » Wed Dec 02, 2015 12:22 pm

tintala wrote:I have been assigning colors to different tracks since I started. I carefully choose colors schemes based on the "type" of track... it's simple. Now its gone.
This has been how i work since forever too. And as long as a track is sketch it has "No Color", then when i'm happy with it i color the track.

oblique strategies
Posts: 3580
Joined: Thu Nov 02, 2006 9:57 pm
Location: Another Green World

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Post by oblique strategies » Thu Dec 03, 2015 12:48 am

While the latest beta fixes the bug that was giving me grief:
'Audio files would not retain the color saved in the respective .asd file when dropped into a track.'

My workflow is still compromised by a feature that was removed in Live 9.5:
The Preference to assign clips a Default color.

I prefer to have all clips that I haven't personally assigned a specific color based on my color-coding scheme to have a predetermined color so I know immediately that it needs to be color-coded. Having clips assume the color of tracks is just confusing when I'm using specific color-coding for my tracks that is independent from the color-coding I'm using for my clips.

Next beta?

I have also sent this to Tech Support.

Post Reply