Page 4 of 5

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Posted: Thu Nov 12, 2015 8:55 pm
by skymakai
I've found that previous clip colors saved with the .asd files won't work anymore.

Here's the email I just sent:

Dear Ableton development team,

Thank you, from the bottom of my heart, for what you do.
I’ve been using Ableton Live as my primary production tool and DJ tool, for the greater part of the last decade. It’s brought me further in both endeavors than any other tool has done. I’ve been thankful for the new features added in each version, and the continuous focus on improving the experience.

However, I’m currently faced with a very frustrating experience, with a change… or rather, a feature which was removed from Live, in the 9.5 update. Clip color options no longer allow clips to retain their previous color setting, even when manually saved in the .asd file; When importing a song or audio file which I’ve already warped and saved settings for, the clip color is automatically changed to either the Track color (Automatic), or the clip color determined in Settings (Manual). The removal of this feature greatly impacts my workflow, as I’ve spent countless hours saving clip colors to help make sense of my clips in live use.

Please bring this feature back, as it seems like such a simple thing to re-impliment. Of course, also keep the option to color clips based on track color. That was a wonderful improvement to add.

Clip colors have, for years, been an overlooked feature in Live. I look forward to more improvements to clip color options, in the future.

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Posted: Thu Nov 12, 2015 9:13 pm
by solovox
skymakai wrote:I've found that previous clip colors saved with the .asd files won't work anymore.

Here's the email I just sent:

Dear Ableton development team,

Thank you, from the bottom of my heart, for what you do.
I’ve been using Ableton Live as my primary production tool and DJ tool, for the greater part of the last decade. It’s brought me further in both endeavors than any other tool has done. I’ve been thankful for the new features added in each version, and the continuous focus on improving the experience.

However, I’m currently faced with a very frustrating experience, with a change… or rather, a feature which was removed from Live, in the 9.5 update. Clip color options no longer allow clips to retain their previous color setting, even when manually saved in the .asd file; When importing a song or audio file which I’ve already warped and saved settings for, the clip color is automatically changed to either the Track color (Automatic), or the clip color determined in Settings (Manual). The removal of this feature greatly impacts my workflow, as I’ve spent countless hours saving clip colors to help make sense of my clips in live use.

Please bring this feature back, as it seems like such a simple thing to re-impliment. Of course, also keep the option to color clips based on track color. That was a wonderful improvement to add.

Clip colors have, for years, been an overlooked feature in Live. I look forward to more improvements to clip color options, in the future.
Yikes! I didn't even realize this was happening as well. Fixing this is sounding more important than ever. I hope they are having a meeting about this right now. One can hope!

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Posted: Thu Nov 12, 2015 9:25 pm
by oblique strategies
skymakai wrote:I've found that previous clip colors saved with the .asd files won't work anymore.
This is the same bug I mentioned earlier. You'll be glad to know that Ableton are aware of it & are/will be working on it.

Here's the response I received from Ableton Support:
"The behaviour you describe is indeed a bug: any clip which is already saved with a color should of course keep this colour even when imported to a track of a different colour. We have filed this as a story for our developers and hope this can be fixed quickly."

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Posted: Fri Nov 13, 2015 4:19 am
by skymakai
Thanks, eO.

I saw that it's been reported as a bug. I look forward to a fix. In the meanwhile, I'm seriously considering changing away from Live as my primary DJ software. Unfortunately, I'm seeing more and more... that Ableton is not focused on maintaining and focusing on features for the Live DJ.

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Posted: Fri Nov 13, 2015 9:59 pm
by staxxx
Oh man!

I'm with everyone on this. I totally see the usefulness of the two new options for color assignment in 9.5, BUT BUT BUT! Losing random color assignment has really messed with my work flow.

I created a custom template with specific colors to kick start any new session. That template is null and void, my carefully chosen color scheme is gone. The specific problem is that there are only two alternatives and neither is acceptable for my needs.

Alternative 1) Live set new random colors - not helpful, since they are different every time I launch!!
Alternative 2) Use a pre-determined color for all new tracks. Also not helpful because, not only are all tracks the same color now, in both cases, all clips are assigned the same color as the track. I can't quickly differentiate between takes, variations, edits, or clips I've composed on one track and am mirroring on another track.

The whole thing has slowed me down. We should have a "legacy color" option, which sets everything back to the classic color assignment. I'm really surprised Ableton bungled on this feature!

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Posted: Sat Nov 14, 2015 4:57 pm
by skymakai
I got word back from Ableton Support...

They said that the issue is a bug, and should be fixed in the next incremental update. And... if you save clips to your User Library, they should retain their color settings.

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Posted: Thu Nov 26, 2015 9:28 am
by solovox
Okay Ableton--it's been a few weeks. How's this coming along? An Options.txt would be a perfectly acceptable solution for us if that works for you. :-)

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Posted: Tue Dec 01, 2015 9:55 am
by [art]
Looks like this was just re-implemented in the latest beta.

Really love how quick Abes are moving on things at the mo

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Posted: Tue Dec 01, 2015 10:24 am
by Tarekith
Yes there's now an option for random clip colors again in the new beta, people in this thread can breath a sigh of relief now. :)

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Posted: Tue Dec 01, 2015 2:26 pm
by zeepster
How about the "No Color" option??

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Posted: Tue Dec 01, 2015 6:12 pm
by foxymethoxy
zeepster wrote:How about the "No Color" option??
Yeah, I really want No Color option back!

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Posted: Tue Dec 01, 2015 6:37 pm
by LFO8
I would like it if clips also changed their color if I change the track color.

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Posted: Tue Dec 01, 2015 7:29 pm
by tintala
So ABes is saying they don't want to clutter the UI. adding an option to change the colors is not clutter! I have been assigning colors to different tracks since I started. I carefully choose colors schemes based on the "type" of track... it's simple. Now its gone.

I vote yes.

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Posted: Wed Dec 02, 2015 12:22 pm
by zeepster
tintala wrote:I have been assigning colors to different tracks since I started. I carefully choose colors schemes based on the "type" of track... it's simple. Now its gone.
This has been how i work since forever too. And as long as a track is sketch it has "No Color", then when i'm happy with it i color the track.

Re: Poll: Bring back Auto-Assign Colors to pre-9.5 functionality

Posted: Thu Dec 03, 2015 12:48 am
by oblique strategies
While the latest beta fixes the bug that was giving me grief:
'Audio files would not retain the color saved in the respective .asd file when dropped into a track.'

My workflow is still compromised by a feature that was removed in Live 9.5:
The Preference to assign clips a Default color.

I prefer to have all clips that I haven't personally assigned a specific color based on my color-coding scheme to have a predetermined color so I know immediately that it needs to be color-coded. Having clips assume the color of tracks is just confusing when I'm using specific color-coding for my tracks that is independent from the color-coding I'm using for my clips.

Next beta?

I have also sent this to Tech Support.