9.5: Automating the Filter Freq on all devices - broken

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
garyboozy
Posts: 2622
Joined: Mon Jul 16, 2007 12:27 pm
Location: UK
Contact:

9.5: Automating the Filter Freq on all devices - broken

Post by garyboozy » Mon Nov 09, 2015 1:01 pm

my Operator is broken! drawing in any semi-fast attack automation for Operator's filter in 9.5 (Operator instance is in pre-'upgrade' state) sounds wildly different to 9.2.3. and not in a good way.

can anyone with both 9.2.3 and 9.5 check this? track one is the automated filter instance. the other 2 tracks were me testing if the sloppiness was present on other automated params but it looks like it's just Operator's filter. again, this is pre-upgrade mode so should sound exactly the same. i've already sent to support last week but no response as yet.

here's a test project: download

cheers
osx 10.9.5
Last edited by garyboozy on Sat Feb 13, 2016 8:42 am, edited 2 times in total.

garyboozy
Posts: 2622
Joined: Mon Jul 16, 2007 12:27 pm
Location: UK
Contact:

Re: 9.5: Automating Operator's filter - something's broken

Post by garyboozy » Mon Nov 09, 2015 2:57 pm

ok, it's not just Operator – it's a problem with Freq when automated on all devices that have the new Cytomic filters – Simpler, Sampler, Operator, Auto Filter – BUT the filters are not 'upgraded' to the Cytomic ones on any of the devices here so they should behave exactly as pre-9.5 ...?

Same in 9.5.1b1

9.2.3 can be downloaded with these links:
mac – http://cdn2-downloads.ableton.com/chann ... 2.3_64.dmg
pc – http://cdn2-downloads.ableton.com/chann ... 2.3_64.zip

garyboozy
Posts: 2622
Joined: Mon Jul 16, 2007 12:27 pm
Location: UK
Contact:

Re: 9.5: Automating Filter Freq on updated devices - broken

Post by garyboozy » Tue Nov 10, 2015 11:59 am

here's an audio comparison.
exact same project file, opened in 9.2.3 first, then in 9.5:

https://dl.dropboxusercontent.com/u/782 ... erprob.wav

andy_cytomic
Posts: 40
Joined: Fri Oct 01, 2010 10:06 am

Re: 9.5: Automating Filter Freq on updated devices - broken

Post by andy_cytomic » Sat Feb 13, 2016 2:06 am

garyboozy wrote:here's an audio comparison.
exact same project file, opened in 9.2.3 first, then in 9.5:

https://dl.dropboxusercontent.com/u/782 ... erprob.wav
I did point this out to the guys at Ableton that they needed to "pad" the input signal levels to the new filters more (i.e. lower the input volume and increase the output volume). Please try this manually and you'll get what you want. Right now the resonance is getting drowned out from excessive input signal volume.
The Glue, The Drop, The Scream - https://www.cytomic.com

garyboozy
Posts: 2622
Joined: Mon Jul 16, 2007 12:27 pm
Location: UK
Contact:

Re: 9.5: Automating Filter Freq on updated devices - broken

Post by garyboozy » Sat Feb 13, 2016 8:38 am

Hi Andy, thanks for the reply!

The problem i was posting about here is not specific to your filters though (i'll change this thread's misleading subject title shortly). The issue here is that Ableton added a smoothing behaviour to the filter when automated, no matter which filters are being used - the old ones or your new ones. When the filter is mapped using MfL modulators there's no problem. Ableton acknowlegded the issue on the beta forums but no news since (9.6.1b1 still broken).

Did you hear back from Ableton about a fix for Operator to work correctly with your new filters? Where the resonance rings out unaffected by the filter or vol envs. Or is that what you mean by padding the input?
Cheers

andy_cytomic
Posts: 40
Joined: Fri Oct 01, 2010 10:06 am

Re: 9.5: Automating Filter Freq on updated devices - broken

Post by andy_cytomic » Fri May 27, 2016 4:40 am

garyboozy wrote:Hi Andy, thanks for the reply!

The problem i was posting about here is not specific to your filters though (i'll change this thread's misleading subject title shortly). The issue here is that Ableton added a smoothing behaviour to the filter when automated, no matter which filters are being used - the old ones or your new ones. When the filter is mapped using MfL modulators there's no problem. Ableton acknowlegded the issue on the beta forums but no news since (9.6.1b1 still broken).

Did you hear back from Ableton about a fix for Operator to work correctly with your new filters? Where the resonance rings out unaffected by the filter or vol envs. Or is that what you mean by padding the input?
Cheers
Operator has no post filter amp or envelopes, but that is another issue entirely. If you have self oscillation then it will be suddenly cut when the longest oscillator pre filter envelope finishes. Padding the input just means that resonance will be stronger in the filters as they aren't being drowned out by the input signal. This is standard usage of analog filters.

I'm not really full bottle on how smoothing is done in Live and what changes have been made. Are you still having issues with smoothing of automation with the filter cutoffs on different devices? This smoothing is applied outside of the filter itself by Live, the filters themselves are capable of audio rate modulation and can step to a new cutoff and resonance on a per sample basis, so there is no limitation there at all, it will be how they are used in Live that may need fine tuning.
The Glue, The Drop, The Scream - https://www.cytomic.com

garyboozy
Posts: 2622
Joined: Mon Jul 16, 2007 12:27 pm
Location: UK
Contact:

Re: 9.5: Automating Filter Freq on updated devices - broken

Post by garyboozy » Fri May 27, 2016 8:29 am

andy_cytomic wrote:Operator has no post filter amp or envelopes, but that is another issue entirely.
Yep, was just asking if you'd heard anything about a fix while you were here! anyway...
andy_cytomic wrote:Are you still having issues with smoothing of automation with the filter cutoffs on different devices?
Yep! It's still screwed, although i'm surprised i've not seen anyone else mention it.
It's entirely down to Ableton's decision to add automation and realtime tweak smoothing to the filters in 9.5, not to do with your filters at all.

You can see this in action yourself by looking at the demo set attached here:
dowload project

Clip 1: a held Operator note has its filter automated at 1/16th pulses
Sounds like crap - the automation is smoothed to death, barely moving the filter cutoff.

Clip 2: the same held Operator note has its filter modulated by Operator's filter env (in 1/16th loop mode)
Sounds fine, as expected.

Cheers

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: 9.5: Automating the Filter Freq on all devices - broken

Post by Stromkraft » Fri May 27, 2016 9:09 am

Gary, did you try just lowering the Oscillator levels and if so did that improve this somewhat?
Make some music!

Post Reply