Waves Central

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
sowhoso
Posts: 836
Joined: Thu Dec 27, 2007 1:14 am

Waves Central

Post by sowhoso » Sat Nov 28, 2015 11:04 pm

getting TrueVerb seriously fucked up Waves plugins in Live here. it required Waves Central and after lots of BSing some Waves plugins are loading but others getting error

I really like waves but this changing shit is always fucked up

fuck me...

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Waves Central

Post by Stromkraft » Sun Nov 29, 2015 5:36 am

sowhoso wrote:getting TrueVerb seriously fucked up Waves plugins in Live here. it required Waves Central and after lots of BSing some Waves plugins are loading but others getting error

I really like waves but this changing shit is always fucked up.
The interface isn't optimal, but you should understand that when you use Waves Central for the first time you need to reinstall all your Waves plug-ins. What I feel has always been irritating is that you can't avoid installing AU versions or that AU validation tool. As AU isn't "supported" in Live that would be convenient for Live users.
Make some music!

sowhoso
Posts: 836
Joined: Thu Dec 27, 2007 1:14 am

Re: Waves Central

Post by sowhoso » Sun Nov 29, 2015 6:27 am

Stromkraft wrote:...you should understand that when you use Waves Central for the first time you need to reinstall all your Waves plug-ins.
i did reinstall. it's a mess

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Waves Central

Post by Stromkraft » Sun Nov 29, 2015 7:20 am

sowhoso wrote:
Stromkraft wrote:...you should understand that when you use Waves Central for the first time you need to reinstall all your Waves plug-ins.
i did reinstall. it's a mess
I had no issues when I started with Central. Just redo them all at once as that is the simplest way.

Also remember to turn off the VST folder in Preferences and back on again. It's not enough to rescan.
Make some music!

G-force
Posts: 77
Joined: Fri May 01, 2009 4:59 am

Re: Waves Central

Post by G-force » Sun Nov 29, 2015 7:35 am

Ancient Chinese proverb--" Be careful for what you wish for" :lol: This Truverb may be free, but you'll have to work for it ! I spent like an hour getting to finally show up in Live. You have to point the VST plugin folder as it won't scan the correct location. good luck! :wink:

sowhoso
Posts: 836
Joined: Thu Dec 27, 2007 1:14 am

Re: Waves Central

Post by sowhoso » Sun Nov 29, 2015 7:44 am

Stromkraft wrote:Just redo them all at once as that is the simplest way.

Also remember to turn off the VST folder in Preferences and back on again. It's not enough to rescan.
yeah, i did all that after uninstalling. some open others not

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Waves Central

Post by Stromkraft » Sun Nov 29, 2015 9:59 am

G-force wrote:Ancient Chinese proverb--" Be careful for what you wish for" :lol: This Truverb may be free, but you'll have to work for it ! I spent like an hour getting to finally show up in Live. You have to point the VST plugin folder as it won't scan the correct location. good luck! :wink:
No, as I suggested "Remember to turn off the VST folder in Preferences and back on again. It's not enough to rescan". That's unfortunate, but that works reliably.
Make some music!

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Waves Central

Post by Stromkraft » Sun Nov 29, 2015 9:59 am

sowhoso wrote:
Stromkraft wrote:Just redo them all at once as that is the simplest way.

Also remember to turn off the VST folder in Preferences and back on again. It's not enough to rescan.
yeah, i did all that after uninstalling. some open others not
So, do it again. Are you on Windows or OS X?
Make some music!

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Waves Central

Post by Stromkraft » Sun Nov 29, 2015 10:47 am

Stromkraft wrote:
sowhoso wrote:
Stromkraft wrote:Just redo them all at once as that is the simplest way.

Also remember to turn off the VST folder in Preferences and back on again. It's not enough to rescan.
yeah, i did all that after uninstalling. some open others not
So, do it again. Are you on Windows or OS X?
If you happen to be on OS X, open up Disk Utilities (in Applications/Utilities) and select your disk and run "Repair Permissions". That's a good habit to have after any installation, even if permission errors aren't as usual as they used to be.
Make some music!

sowhoso
Posts: 836
Joined: Thu Dec 27, 2007 1:14 am

Re: Waves Central

Post by sowhoso » Sun Nov 29, 2015 11:09 am

I'm on windows 7

i have tried 4 times, did a complete uninstall with no luck

i don't really need TrueVerb but wanted to check it out. i wish i hadn't heard about this freebie!

this install crap fuckin sux!

i just want the rest of my Wave plugins back

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Waves Central

Post by Stromkraft » Sun Nov 29, 2015 11:36 am

sowhoso wrote:I'm on windows 7

i have tried 4 times, did a complete uninstall with no luck

i don't really need TrueVerb but wanted to check it out. i wish i hadn't heard about this freebie!

this install crap fuckin sux!

i just want the rest of my Wave plugins back
OK, so it's quite common with permissions issues on the VST folder in Windows as well. I'd venture to say something like that is at play here.
Is every plug-in visible under Waveshell?
Last edited by Stromkraft on Mon Nov 30, 2015 6:16 pm, edited 1 time in total.
Make some music!

sowhoso
Posts: 836
Joined: Thu Dec 27, 2007 1:14 am

Re: Waves Central

Post by sowhoso » Sun Nov 29, 2015 3:01 pm

every plugin is visible. some don't open at all, others will open but then Live crashes

i never had a problem with Waves plugins until Waves Central was installed

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Waves Central

Post by Stromkraft » Sun Nov 29, 2015 3:55 pm

sowhoso wrote:every plugin is visible. some don't open at all, others will open but then Live crashes

i never had a problem with Waves plugins until Waves Central was installed
OK. Waves Central itself shouldn't affect Live in this way. I received really good help from Waves when I had installation issues last autumn and called them (via Skype as I'm overseas from them). Emailing them works too but may take a day or so.
Make some music!

sowhoso
Posts: 836
Joined: Thu Dec 27, 2007 1:14 am

Re: Waves Central

Post by sowhoso » Sun Nov 29, 2015 4:30 pm

I used the "Waves_Complete_V9r30" installer to reinstall all my Waves plugins (backed that shit up). i need an installer that lets you choose where to place WaveShell-VST dll

all good now. yay!

screw Waves Central :evil:

Richie Witch
Posts: 885
Joined: Mon Feb 10, 2014 10:10 pm
Location: Space Coast, Central Florida

Re: Waves Central

Post by Richie Witch » Mon Nov 30, 2015 2:21 am

So I tried this trick--turned off the custom VST folder and turned it back on. Yes, that got all my Waves plugins to display in the new 9.6 shell. However, Renaissance Bass now crashes Live. And any project that contains that plugin crashes Live before the project can open. Yeah--my most-used Waves plugin.... :twisted:
Win10/Intel i7 rig | Live 10 | DSI, Yamaha, Korg, and Novation synths, and 12U of Eurorack | various outboard gear | Dune 2, Circle2, Enzyme, Kontakt |

Post Reply