Ableton serously?! Library erased after launch of 9.6 !

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Guillermo Barrancos
Posts: 289
Joined: Tue Mar 05, 2013 8:05 am

Ableton serously?! Library erased after launch of 9.6 !

Post by Guillermo Barrancos » Mon Feb 15, 2016 7:34 pm

Today I fired up Live 9.6 again after a week break and to my horror it has deleted all custom folders in my User Library! It's completely empty and back to default like a new installation.

You got to be kidding me?? :evil:

I am seriously starting to lose my patience with Ableton.

Luckily most (but not all) of my Project files are still on my Mac, but this should never ever happen! So I have lost some of my recent projects now! :evil:

First, the crashing Mayhem With Live 9.5 + Push 2, then after upgrading to Live 9.6, almost all my Packs got deleted and had to be re-imported from scratch! Then we got the velocity sensitivity issues and stability issues with Push 2......... and now this?!

I'm really wondering what the heck is going on at Ableton HQ? Have they lost all their senior programmers lately or something? As the increasing instability, issues and bugs is starting to get me worried.

Completely speechless and frustrated right now. Can't believe such a bug made it into a live release.

Angstrom
Posts: 14722
Joined: Mon Oct 04, 2004 2:22 pm
Contact:

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by Angstrom » Mon Feb 15, 2016 8:18 pm

I'm confused by "deleted all folders in your custom user library"
Do you mean - the folders aren't in "places" or the folders have been deleted?

It shouldn't delete files ... Unless you were saving or moving things in the Live library. That stuff will always get overwritten.
the browser isn't built for users to manage their content. My guess is they only considered factory packs and Push when they made this attrocity.

aschneider
Posts: 36
Joined: Thu Nov 03, 2011 4:36 am

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by aschneider » Mon Feb 15, 2016 8:27 pm

Well it can certainly be a bummer but you should write to support instead. I mean, I get that you're frustrated, but still. The support people are helpful enough to assest this kind of situation and as you're not providing much info I don't see how can we help.

jbone1313
Posts: 463
Joined: Wed Dec 12, 2007 2:44 am

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by jbone1313 » Mon Feb 15, 2016 9:04 pm

Sometimes when I quit Live, it does not actually terminate Live's process in Win 10. When I restart Live, two Live processes are running. When that happens, my library is blank. Terminating all the Live processes and restarting Live resolves the issue.

Hope this helps.

Guillermo Barrancos
Posts: 289
Joined: Tue Mar 05, 2013 8:05 am

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by Guillermo Barrancos » Mon Feb 15, 2016 9:13 pm

Angstrom wrote:I'm confused by "deleted all folders in your custom user library"
Do you mean - the folders aren't in "places" or the folders have been deleted?

It shouldn't delete files ... Unless you were saving or moving things in the Live library. That stuff will always get overwritten.
the browser isn't built for users to manage their content. My guess is they only considered factory packs and Push when they made this attrocity.
I use the User Library to save my Projects and always have.

I created a custom folder called Music Productions and save my Projects there in individual sub folders.

Today I launched Ableton Live 9.6 again and wanted to open one of my Projects by selecting File > Recent Projects and all my recent Projects showed, but greyed out.
So I went to the User Library and to my horror it was completely empty! Only folder left is the sub folder called Ableton Project Info, which is also empty!

Last week everything was there, but due to work and other stuff I haven't touched my PC for a week. It has just been off and no one else uses it at home, only me.

So today I wanted to get back into it, fired up my PC and launched Live again and everything was just gone! I never touch the User Library, other than copy it to my Mac now and then if I want to work on my Laptop and I haven't done that for almost a month.

Ableton is installed on a seperate disk, including my Library. So no OS update could have done this! I have no other explanation then that Ableton somehow, for whatever "buggy" reason emptied my User LIbrary on startup this evening. :(
Last edited by Guillermo Barrancos on Mon Feb 15, 2016 9:22 pm, edited 1 time in total.

Guillermo Barrancos
Posts: 289
Joined: Tue Mar 05, 2013 8:05 am

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by Guillermo Barrancos » Mon Feb 15, 2016 9:16 pm

jbone1313 wrote:Sometimes when I quit Live, it does not actually terminate Live's process in Win 10. When I restart Live, two Live processes are running. When that happens, my library is blank. Terminating all the Live processes and restarting Live resolves the issue.

Hope this helps.
Well that is scary, as I indeed restarted Live a couple times last week before the break, due to Push 2 hanging up / crashing Live.

When I was done, I saved changes to the last Project I worked on, quit live and shut down my PC.

So, then it might have actually deleted all content in my Library last week, when I shut down the PC. :evil:

Today I only started Live once, so there are not multiple processes of Live running now.

Just downright scary and really pissed off about this!

When I open Windows Explorer, my Music Productions sub folder still shows on under Quick Access, but ofcourse gives an error when I click on it, as it no longer exists.
Further proof it isn't Windows that deleted this folder, otherwise it wouldn't show anymore under Quick Access. Windows still thinks this folder exists, but it doesn't. :(

Guillermo Barrancos
Posts: 289
Joined: Tue Mar 05, 2013 8:05 am

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by Guillermo Barrancos » Mon Feb 15, 2016 9:29 pm

Angstrom wrote:I'm confused by "deleted all folders in your custom user library"
Do you mean - the folders aren't in "places" or the folders have been deleted?

It shouldn't delete files ... Unless you were saving or moving things in the Live library. That stuff will always get overwritten.
the browser isn't built for users to manage their content. My guess is they only considered factory packs and Push when they made this attrocity.
The User Library is the default location where Your Projects are saved, unless you manually change to a different folder every time you save a New Project.

So no! Content in the User Library should never be erased or overwritten!

I have been using this folder since Live 6. As long as I can remember at least.

[jur]
Site Admin
Posts: 2218
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by [jur] » Mon Feb 15, 2016 10:09 pm

You can't those files from within Live. But are they still on your disk?
Ableton Forum Moderator

[jur]
Site Admin
Posts: 2218
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by [jur] » Mon Feb 15, 2016 10:12 pm

Guillermo Barrancos wrote: Ableton is installed on a seperate disk, including my Library.
You shouldn't do that. You'd better install it on the disk that runs the system.
Ableton Forum Moderator

Angstrom
Posts: 14722
Joined: Mon Oct 04, 2004 2:22 pm
Contact:

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by Angstrom » Mon Feb 15, 2016 10:16 pm

Aha, I never save my projects there. Mine are in folders such as f:/live 9 songs/ , f:/live 8 songs , far away from the Live user library.

I don't ever remember changing that, it just uses the most recent location as far as I know. I do save my presets under the user library location, but I have no idea why as it doesnt gain me anything. I could just as well save them in z:/far away/my presets , as the Live browser doesnt do anything special to things in the user library folder.

I think the lesson we have learned is to avoid that folder, it adds nothing and may take everything away.
Live 9s browser remains utterly shit.

Angstrom
Posts: 14722
Joined: Mon Oct 04, 2004 2:22 pm
Contact:

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by Angstrom » Mon Feb 15, 2016 10:27 pm

[jur] wrote:
Guillermo Barrancos wrote: Ableton is installed on a seperate disk, including my Library.
You shouldn't do that. You'd better install it on the disk that runs the system.
Uh, really? :?:
Because I have always had Live installed on a different disk than my system. for the last 10 years !
  • My system Disk is C: an SSD drive, 128gb
  • Ableton Live is installed on Disk E: a platter drive 500Gb
  • My Library is on Drive F: a different platter drive 1Tb
  • My music is on a different drive again.
I've never heard that Live needs to be on the System drive.

[jur]
Site Admin
Posts: 2218
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by [jur] » Mon Feb 15, 2016 10:33 pm

I didn't say it needs to, just that it is better. It's recommended here
Ableton Forum Moderator

jestermgee
Posts: 3888
Joined: Mon Apr 26, 2010 6:38 am
Contact:

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by jestermgee » Mon Feb 15, 2016 11:37 pm

When you installed your new Live did you "Upgrade or replace" when asked?

You may find it simply did not carry over your library from the previous installed version.

Not sure on MAC but on Windows in \ProgramData\USER\AppData\Roaming\Ableton\[Ableton version]

You have a folder for each Live version with library files etc in there. You could just copy the files from the previous version to the new one?

I have to do this every time because I use a custom MIDI script for the Launchpad due to being colourblind and that never copies over when I install a new version of Live.

zeropoint
Posts: 626
Joined: Tue Sep 17, 2002 9:06 pm
Location: London, UK

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by zeropoint » Tue Feb 16, 2016 1:20 am

I've been installing several betas recently which caused no problems with my custom folders i.e those added to "Places" or to my Plug in locations. Despite the release beta causing no issues, Live 9.6 wiped the whole lot clean. Next beta 9.6.1b1 installed fine with everything where it should be.....
MacBook Pro 17" 2.93Ghz 8G Ram, Live 9.6, OSX 10.11.3,Faderfoxes, Monome........

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by Stromkraft » Tue Feb 16, 2016 1:54 am

Guillermo Barrancos wrote:Today I fired up Live 9.6 again after a week break and to my horror it has deleted all custom folders in my User Library! It's completely empty and back to default like a new installation.

You got to be kidding me?? :evil:
I don't think this is Live's doing at all. Not on Mac. Yes, it's strictly possible, but also highly unlikely. I've made enough installations to say this is extremely rare and not common place as you seem to suggest it is. It could be a bug of course, but it doesn't seem to affect everyone. The question is why this happened.
You mean to say you don't keep a backup of one of the most important Ableton Live folders that contains your work product?

I think the trend of blaming Ableton for when you mess up yourself is quite tiresome. I can understand if someone is saying the design of Live makes them make decisions that comes back and bite them. The user folder might be one of those. Yes, there are bugs in Live, sometimes rare and doesn't affect everyone, but that doesn't mean when something goes wrong it must be Live. The OS and different pieces of software interact and sometimes bad things can happen.

The way users sometimes present problems, when it's clear for experienced users that something vital is missing from the story, as some kind of conspirational theory then that's not an useful attitude. I think you're bordering on this here, which might be understandable as having issues is indeed frustrating.

The question here is whether you want to learn from happened so you can avoid it in the future. You need to be pragmatic when using computers. Maybe one doesn't need learn every technical detail, but one needs to learn what is relevant for the tasks one wants to be able to do successfully. It's no different from operating any semi-advanced equipment. You're the operator so know your tools.

I decided some years back to take control of my music production folders, so I'd always know where to find them instead of allowing software to place files where its developers wanted. This has really paid off. Even if a a dumb update procedure of an otherwise lovely piece of software — I'm looking at you Native Instruments — think their placement is wise and overwrite my stuff I'm covered even if the three times a day backup failed as my paths are not the standard ones in most cases.

Take control over your machines so they work for you is my suggestion. That's one thing being a music producer entails these days.
Make some music!

Post Reply