Ableton serously?! Library erased after launch of 9.6 !

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Pasha
Posts: 3248
Joined: Tue Dec 27, 2005 12:45 pm
Location: Lost Island
Contact:

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by Pasha » Wed Feb 17, 2016 3:44 pm

As auto update was on I got 9.6, 32bit on OS X delivered. No accident on user library (I had only a few presets of mine there)

Just to report.
Pasha
Apple iMac 2013 / Macbook Late 2012
Live 10 Suite,Zebra ,Guitar, Bass, VG99, JV1010 and some controllers
______________________________________
Music : http://alonetone.com/pasha

H20nly
Posts: 15844
Joined: Sat Oct 27, 2007 9:15 pm
Location: The Wild West

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by H20nly » Wed Feb 17, 2016 6:33 pm

Stromkraft wrote:some kind of conspirational theory then that's not an useful attitude.
that's not a useful word. you could at least have the decency of using real words when you're going the long winded route of being condescending.


@ Guillermo, do you have indexing turned on in Windows? if so, maybe you could do a search for .alp and .als files and see if anything comes up in any unexpected locations.

Guillermo Barrancos
Posts: 290
Joined: Tue Mar 05, 2013 8:05 am

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by Guillermo Barrancos » Wed Feb 17, 2016 7:36 pm

H20nly wrote:
Stromkraft wrote:some kind of conspirational theory then that's not an useful attitude.
that's not a useful word. you could at least have the decency of using real words when you're going the long winded route of being condescending.


@ Guillermo, do you have indexing turned on in Windows? if so, maybe you could do a search for .alp and .als files and see if anything comes up in any unexpected locations.
Nope. Never turn that on.

Angstrom
Posts: 14741
Joined: Mon Oct 04, 2004 2:22 pm
Contact:

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by Angstrom » Wed Feb 17, 2016 8:04 pm

How about System Restore?

did we cover that already?

Windows will usually make a restore point on all drives at any installation, unless you have specifically told it not to.

Guillermo Barrancos
Posts: 290
Joined: Tue Mar 05, 2013 8:05 am

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by Guillermo Barrancos » Wed Feb 17, 2016 8:15 pm

Angstrom wrote:How about System Restore?

did we cover that already?

Windows will usually make a restore point on all drives at any installation, unless you have specifically told it not to.
No it doesn't do it for all drives as default, just for the OS disk and default folders.

Angstrom
Posts: 14741
Joined: Mon Oct 04, 2004 2:22 pm
Contact:

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by Angstrom » Wed Feb 17, 2016 9:04 pm

Oh yeah, that's right. You have Ableton installed elsewhere. I forgot.

muthafunka
Posts: 2241
Joined: Fri Jan 10, 2003 5:28 pm
Location: Tokyo

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by muthafunka » Thu Feb 18, 2016 2:09 am

Guillermo Barrancos wrote:
muthafunka wrote:No backups/clones?
The last two weeks no. I had been struggling so much with all the crashing and hanging issues with Ableton Live 9.5, Push 2 and the Focusrite, that I was happy when I actually got things running for a bit to actually do something. So I forgot. :(

When upgrading to Live 9.6 last week and having the Steinberg UR44, I was so happy everything was more or less stable again (except Push 2 causing some hang ups now and then), that I forgot to copy an updated User Library to my Mac last week. :(

You just don't expect Ableton to just suddenly erase everything in the User Library! /Facepalm
That sucks, really. Not expecting is exactly the reason we should all have back ups as part of our computer use life, esp. checking as soon as things start to get flaky and crashy. Off-site too as far as poss. - shit happens > houses get robbed, burn down, earthquakes, flood. It can all happen. Losing all my kid's pics etc, my work, music...can't imagine it and not ready to let it happen.

Guillermo Barrancos
Posts: 290
Joined: Tue Mar 05, 2013 8:05 am

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by Guillermo Barrancos » Thu Feb 18, 2016 7:41 am

muthafunka wrote:
Guillermo Barrancos wrote:
muthafunka wrote:No backups/clones?
The last two weeks no. I had been struggling so much with all the crashing and hanging issues with Ableton Live 9.5, Push 2 and the Focusrite, that I was happy when I actually got things running for a bit to actually do something. So I forgot. :(

When upgrading to Live 9.6 last week and having the Steinberg UR44, I was so happy everything was more or less stable again (except Push 2 causing some hang ups now and then), that I forgot to copy an updated User Library to my Mac last week. :(

You just don't expect Ableton to just suddenly erase everything in the User Library! /Facepalm
That sucks, really. Not expecting is exactly the reason we should all have back ups as part of our computer use life, esp. checking as soon as things start to get flaky and crashy. Off-site too as far as poss. - shit happens > houses get robbed, burn down, earthquakes, flood. It can all happen. Losing all my kid's pics etc, my work, music...can't imagine it and not ready to let it happen.
I am taking frequent backups of important files, but not "that" frequent and as I had so much trouble With Live 9.5 the last 2 months, I lost track a little With backups due to the sheer frustration working with Live the last 2 months with all the crashes and hangups!
I was just happy when it finally worked and could do something. :(

H20nly
Posts: 15844
Joined: Sat Oct 27, 2007 9:15 pm
Location: The Wild West

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by H20nly » Thu Feb 18, 2016 11:04 am

Guillermo Barrancos wrote:
H20nly wrote:Guillermo, do you have indexing turned on in Windows? if so, maybe you could do a search for .alp and .als files and see if anything comes up in any unexpected locations.
Nope. Never turn that on.
it's on by default, so you would have to turn it off.

it can be turned on at any time and still work. it would just need a while to build - i.e. overnight

tintala
Posts: 467
Joined: Mon Nov 29, 2010 5:37 pm

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by tintala » Thu Feb 18, 2016 3:10 pm

I am on Pc- and about 6 months ago after starting Live 9.2/4 my libraries were blank I think I even posted the issue here , however after restarting Live again, letting it rescan all of my external hds the libraries came back! so I have seen of this though I can't remember what caused it ,sry. I think it's probable Live needs to rescan it or your hd were "sleep" more, etc... 2 cnt.

mholloway
Posts: 1577
Joined: Sat Nov 29, 2008 7:24 pm
Location: Portland, Oregon, USA
Contact:

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by mholloway » Thu Feb 18, 2016 4:14 pm

tintala wrote:I am on Pc- and about 6 months ago after starting Live 9.2/4 my libraries were blank I think I even posted the issue here , however after restarting Live again, letting it rescan all of my external hds the libraries came back! so I have seen of this though I can't remember what caused it ,sry. I think it's probable Live needs to rescan it or your hd were "sleep" more, etc... 2 cnt.
Yes, but the OP isn't saying the files simply aren't showing up in Live's Browser -- which is what you are saying -- he's saying they are confirmed as gone from the actual HD, and cannot be found via his system, not just via live's browser.

In your case, a quick check of the system HD will show the files are still there, and just need to be re-scanned by Live's browser.

I'm still unsure if it's possible that the 9.6 update actually deleted the OP's files; I've never had a case of Live overwriting anything in the User Library during an update, but that doesn't mean it isn't possible.

-M
my industrial music made with Ableton Live (as DEAD WHEN I FOUND HER): https://deadwhenifoundher.bandcamp.com/
my dark jazz / noir music made with Ableton Live: https://michaelarthurholloway.bandcamp. ... guilt-noir

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by Stromkraft » Fri Feb 19, 2016 8:16 am

H20nly wrote:
Stromkraft wrote:some kind of conspirational theory then that's not an useful attitude.
that's not a useful word. you could at least have the decency of using real words when you're going the long winded route of being condescending.
I'm not. That's all in your head. I just feel that many of us users, myself included, are quick to blame Ableton for everything including stuff they can't control like how the OS operates. It's certainly not as useful to pass blame as it is to really analyse the issue you experience. I've been upset at a certain plug-in maker until I realized I had caused the problem with something I did.

To always claim with a knee-jerk motion it must be a bug isn't useful either, even when it appears so. It's more useful to retrace your steps, if you really want to find the cause.

There are current issues with Live, with elusive features, that are very irritating and that are hard to recreate even for the person experiencing them. We don't stand much of a chance getting these fixed just by saying "it's Ableton's fault". Maybe it is, if so we'll find out hopefully.

Whatever is behind this problem of Guillermo's, that would appear to be Windows-related, there is likely a specific reason. Do the update app in Windows create a log? What's in the log?

Sidebar: Useful word or not, you need a word app. You know, like Webster's. If you had one, you'd know that's a real word, the adverb form of conspiration.
Make some music!

Tarekith
Posts: 17670
Joined: Fri Jan 07, 2005 11:46 pm
Location: Ableton Forum Administrator
Contact:

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by Tarekith » Fri Feb 19, 2016 8:42 am

I don't think we need to make this personal over people's word choice guys, let's keep this constructive please.
Tarekith
Ableton Forum Administrator
InnerPortalStudio.com - Professional Audio Mastering

Guillermo Barrancos
Posts: 290
Joined: Tue Mar 05, 2013 8:05 am

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by Guillermo Barrancos » Fri Feb 19, 2016 8:43 am

Stromkraft wrote:
H20nly wrote:
Stromkraft wrote:some kind of conspirational theory then that's not an useful attitude.
that's not a useful word. you could at least have the decency of using real words when you're going the long winded route of being condescending.
I'm not. That's all in your head. I just feel that many of us users, myself included, are quick to blame Ableton for everything including stuff they can't control like how the OS operates. It's certainly not as useful to pass blame as it is to really analyse the issue you experience. I've been upset at a certain plug-in maker until I realized I had caused the problem with something I did.

To always claim with a knee-jerk motion it must be a bug isn't useful either, even when it appears so. It's more useful to retrace your steps, if you really want to find the cause.

There are current issues with Live, with elusive features, that are very irritating and that are hard to recreate even for the person experiencing them. We don't stand much of a chance getting these fixed just by saying "it's Ableton's fault". Maybe it is, if so we'll find out hopefully.

Whatever is behind this problem of Guillermo's, that would appear to be Windows-related, there is likely a specific reason. Do the update app in Windows create a log? What's in the log?

Sidebar: Useful word or not, you need a word app. You know, like Webster's. If you had one, you'd know that's a real word, the adverb form of conspiration.
In my case it's not a Windows OS related problem. As my entire Ableton installation, plugins, Library, etc are on a seperate dedicated disk.

In Windows Explorer the short cuts and folder info to my Music Productions sub-folder still exist, so Windows OS still thinks the folder exist, but it doesn't. It's gone.
If I had been stupid drunk and accidently manually deleted all my Project files, then all these shortcuts would have been cleaned up and gone too.
I have scanned all my harddrives. Nothing! All gone.

In Ableton, in Recent Opened Projects, there is still a Reference to all my recent Projects, just that they are greyed out, as again... everything is gone.

My gut feeling tells me that something is messed up with update / replace process of Ableton Live and because of the hangup's I experienced last week, that it might have been in limbo trying to move away my User Library or something for whatever reason, with files being in memory during move and when I shut down the PC all got lost! (as I did not know at that time Ableton Live doesn't Close it's processes after these hangup's after I force exit through task manager. Another user brought that up 2 pages back)

I have no other explanation. I have seen some messed up Things with OS updates, but they were always related to the OS related folders on OS disk, never personal files on other disks.
I also had weird stuff with Virus scanners deleting false positive files in the past, but I do not use a Third party virus scanner anymore, just Windows Defender and I have all my Music related folders excluded from scanning.

Coupe70
Posts: 1097
Joined: Fri Jul 23, 2004 7:25 am
Location: Mainz / Germany
Contact:

Re: Ableton serously?! Library erased after launch of 9.6 !

Post by Coupe70 » Fri Feb 19, 2016 11:22 am

If the files were really deleted you should stop working on that
HD and try a recovery tool like Recuva to get the deleted files
back that should still be there if you didn't write (much)
on the affected HD...
Doesn't find the cause for what you describe, doesn't cure the
bug if there is one, but it might bring back your files.
And you can get prove that something really deleted the files
and they didn't disappear for some other strange reason - can't
remember if Recuva maybe can provide a "time of deletion" for
the files it finds so you can link it to the time of the Live update.
Phongemeinschaft (Live-ElectroJazz / NuJazz)
Homepage - youtube - Like! :-)
Live 9 (32Bit), HP DV7, i5 2,53GHz, 8 GB RAM, Win7 (64Bit)

Post Reply