When Ableton Live 9 is open, kills all other computer sound

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
mutator
Posts: 48
Joined: Mon Mar 14, 2011 5:02 am

When Ableton Live 9 is open, kills all other computer sound

Post by mutator » Wed Feb 24, 2016 5:39 pm

I'm having an issue I can't quite figure out in regards to my computer sound when ableton live 9 I is open. When I have Ableton Live 9 open and I attempt to use any other sound source on my computer it doesn't work. If I have a web browser open and I tried to play any music with YouTube, SoundCloud, or anything else no sound will come out. Also if I have any other audio application open like Winamp or any other music player it also won't make any sound. I can't get any of it to work again until completely shutting down Ableton. I didn't used to have this issue, and I'm not quite sure when it really started. But I love watching tutorials wilel I have Ableton open so I can follow along. I also like listening to music with Winamp while working on a project so I can get ideas for things. Or just in general use my computer while Ableton is still running and being able to hear audio in whatever I'm doing on my computer.

My audio device is a Tascam US144MKII connected to USB.

sana48
Posts: 417
Joined: Sun Mar 01, 2015 12:16 am

Re: When Ableton Live 9 is open, kills all other computer sound

Post by sana48 » Wed Feb 24, 2016 8:23 pm

Can you use a different driver/sound system for your computer, letting Ableton use the Tascam?

or are you only using one set of speakers, like your onboard comp speakers?

Tagor
Posts: 939
Joined: Thu Mar 12, 2009 3:18 am

Re: When Ableton Live 9 is open, kills all other computer sound

Post by Tagor » Wed Feb 24, 2016 8:26 pm

on win 7 you need to change something here
Image

your soundcard must be default and your onboard must have the phone-symbol

doghouse
Posts: 1413
Joined: Fri Aug 29, 2008 5:30 pm

Re: When Ableton Live 9 is open, kills all other computer sound

Post by doghouse » Wed Feb 24, 2016 8:29 pm

Check your settings in the Sound control panel. The Tascam should show up as well as whatever internal sound device is in your PC. Make sure the proper devices are enabled.

Also look at the Mixer...click on the speaker icon in the toolbar to see it...make sure nothing is muted.

mutator
Posts: 48
Joined: Mon Mar 14, 2011 5:02 am

Re: When Ableton Live 9 is open, kills all other computer sound

Post by mutator » Thu Feb 25, 2016 2:52 am

this was quite the interesting issue. My soundcard itself doesn't have many adjustments, it's something i need to upgrade in the future for sure (the Tascam that is).

I insured all mixer volumes for the computers sound setting where on and working. I messed with trying to make one thing the "default communication device" and another the "default device". No matter how I set it, for sound to come out of the one set of speakers i have it had to be only the Tascam. I was able to disable everything but the tascam, then all computer audio would come out of my main speakers (which area connected to the tascam). I could then play youtube, winamp, and ableton at the same time.... but then i ran into another issue. when ableton was running, all other audio played on the PC would play slower; not in half slower, but close. If i had winamp or youtube running with ableton closed, and then opened ableton... I could see and hear it slow the audio down right in front of my face.

I was using the ASIO driver in ableton. Ended up switching it to the MME/DirectX driver which seemed to fix the things playing slower issue. Not sure why I had to do it. Thought i always ran the ASIO driver in the past with ableton version 8. So for now, all audio selections in windows 7 have been disabled except for my tascam audio card and i'm now running the MME/DirectX driver in ableton. Not sure if I'm going about this the right way, but i tried so many damn combos of things tonight am sort of going mad..... happy it's working ATM. Not sure if the MME/DirectX driver is the best for me Ableton work though.

yur2die4
Posts: 6451
Joined: Sat Oct 03, 2009 3:02 am
Location: Menasha, Wisconsin
Contact:

Re: When Ableton Live 9 is open, kills all other computer sound

Post by yur2die4 » Thu Feb 25, 2016 4:13 am

It has to do with whether or not your interface is a 'multi-client' interface. If not, it'll put all its resources into whichever software has it selected as the asio device.

If you aren't doing any recording that requires latency, it shouldn't really hurt to use mme, I don't know if it colors the sound in any way (not sure if the audio runs through windows prefs, and sometimes win prefs are funky).

Asio is great for when you are playing keyboards and recording and want minimal latency. Basically when you want optimal performance inside Live specifically.

mutator
Posts: 48
Joined: Mon Mar 14, 2011 5:02 am

Re: When Ableton Live 9 is open, kills all other computer sound

Post by mutator » Thu Feb 25, 2016 5:51 am

yur2die4 wrote:It has to do with whether or not your interface is a 'multi-client' interface. If not, it'll put all its resources into whichever software has it selected as the asio device.

If you aren't doing any recording that requires latency, it shouldn't really hurt to use mme, I don't know if it colors the sound in any way (not sure if the audio runs through windows prefs, and sometimes win prefs are funky).

Asio is great for when you are playing keyboards and recording and want minimal latency. Basically when you want optimal performance inside Live specifically.
thanks for the info. I guess i'll use ASIO if i sense some latency. The audio interface hasn't been the best if you know what i mean. I got friends with ones around the same money that seem to do better than mine.... so a upgrade is definitely in order in the near future. The AI doesn't have many settings as well. Here a quick clip of all the possible settings it has. It does come with some latency settings; weather or not it will do much to counter act the MME setting i'm not sure yet. So far I got it on "normal" most the time.

Image

ejguzman94
Posts: 1
Joined: Tue Oct 31, 2017 11:00 pm

Re: When Ableton Live 9 is open, kills all other computer sound

Post by ejguzman94 » Tue Oct 31, 2017 11:10 pm

I have a Tascam US-144 and had the same exact problem as you. In order to fix it, I had to change my In/Out Sample Rate from 44100 to 48000. This setting can be accessed through preferences in the audio tab. Also, I'm still able to use ASIO and everything is working fine. I can play YouTube videos with Ableton open without the video being unable to start or the sound slowing down. You probably upgraded your equipment already since it's been over a year since you posted, but hopefully this can help someone else with the same issue lol. When I selected a sample rate above 48000 sounds sped up as opposed to slowing down when the rate was lower. Different set ups might need different settings, but 48000 worked for me.

Richie Witch
Posts: 885
Joined: Mon Feb 10, 2014 10:10 pm
Location: Space Coast, Central Florida

Re: When Ableton Live 9 is open, kills all other computer sound

Post by Richie Witch » Wed Nov 01, 2017 11:15 am

Sorry, zombie thread. :oops:
Win10/Intel i7 rig | Live 10 | DSI, Yamaha, Korg, and Novation synths, and 12U of Eurorack | various outboard gear | Dune 2, Circle2, Enzyme, Kontakt |

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: When Ableton Live 9 is open, kills all other computer sound

Post by Stromkraft » Wed Nov 01, 2017 11:35 am

ejguzman94 wrote:When I selected a sample rate above 48000 sounds sped up as opposed to slowing down when the rate was lower. Different set ups might need different settings, but 48000 worked for me.

I forgot now what it fixed but running at 48k has been a solution for other more serious issues in the past. To this day I default at 48kHz, though if I remember I export to 44.1 kHz.
Make some music!

theophilus
Posts: 520
Joined: Fri Mar 06, 2009 3:54 pm

Re: When Ableton Live 9 is open, kills all other computer sound

Post by theophilus » Wed Nov 01, 2017 2:36 pm

IIRC there is a setting in the audio panel for sample rate. obviously this needs to match what you are using in Ableton if you want them both to be able to use the soundcard at the same time - the soundcard can only send out one stream of audio after all. keep in mind the intention of ASIO is to get as close to the audio output as possible to reduce latency; a mixer (allowing ableton + other applications) isn't that much of a hit, but SRC would be.

the default in windows is 48K iirc normally; you can probably either change ableton to 48K, or change windows to 44.1. (i don't run windows anymore so this is mostly from memory, it may be wrong)...

chrk
Posts: 1728
Joined: Mon Dec 28, 2009 5:36 pm

Re: When Ableton Live 9 is open, kills all other computer sound

Post by chrk » Wed Nov 01, 2017 4:41 pm

theophilus wrote:it may be wrong
You needn't worry about your long therm memory, it seems to be quite functional.

If the sound driver is capable of multi client/multi asio the sample rates of ASIO clients and the windows audio must match, because asio clients try to lock the device's clock.
Richie Witch wrote:Sorry, zombie thread. :oops:
But it bears repeating.

rattenjunge
Posts: 2
Joined: Sun Sep 23, 2018 4:53 pm

Re: When Ableton Live 9 is open, kills all other computer sound

Post by rattenjunge » Sun Sep 23, 2018 5:03 pm

got the same problem here with live 10 and m-audio m-track interface. plus asio is currently the only driver which allows me to play sounds in ableton. if i use the other drivers there's just no sound at all. weird is that it worked before with mme driver but not anymore...aswell not after reseting the pc and updating everything.
is asio generally only capable of playing one sound source and inable of switching between devices/programms?

pottering
Posts: 797
Joined: Sat Dec 06, 2014 4:41 am

Re: When Ableton Live 9 is open, kills all other computer sound

Post by pottering » Sun Sep 23, 2018 6:46 pm

Most ASIO drivers work in exclusive mode and only work with one software at a time.

rattenjunge
Posts: 2
Joined: Sun Sep 23, 2018 4:53 pm

Re: When Ableton Live 9 is open, kills all other computer sound

Post by rattenjunge » Tue Sep 25, 2018 1:09 am

thanks for reply :)
ok, so that means with asio driver it's just not possible any way to switch around between different programms playing sound when they're opened the same time? so for example with asio4all vlc and youtube opened at the same time should cause simmilar problems?
and is there an alternative where u can to such things or do i just need a second computer separately in order to work on music while being able to acces the internet?

another thing is that in my presetings there's no way to change bufferzize, only samplerate. when i change from asio-driver of my soundcard to asio4all it changes buffer from 256 to 512.
shouldn't that be possible?
gratefull for help

Post Reply