Page 1 of 1

Video Issue: "..could not be read ..." HELP!!

Posted: Fri Jan 13, 2017 2:51 am
by LesMizzell
Running Live Suite 9 64 bit (latest version) on Win 10 64 bit.
I've been sent an .mp4 video file I need to score to.
I've converted the mp4 to .mov in Handbrake.

The video plays back perfectally on the computer where Live is installed using the Windows Media Player, so the file must be OK and the needed codec installed, right? Nope.
Video will not import into Live and gives the error message: "xxxx.mov could not be read, it may be corrupt or not licensed"

Went here for advice:
https://help.ableton.com/hc/en-us/artic ... n-of-Live-

I'm running Live as the Administrator
I've installed the codecs suggested by Ableton here: http://ffdshow-tryout.sourceforge.net/download.php
Note: CoreAVC 3.0.1 from CoreCodec also suggested appears no longer available and the link doesn't work.

To test that it's not the file, I've tried a few other .mov files, some from my wife's iPhone, some from my Mac, some from my PC, and they all play back fine in their associated media players on the same PC Live is installed on, but none of them will load into Live.

Nothing works. I've got a deadline approaching, and I've spent almost the entire day trying to get the video to play back in live.

Quick Suggestions? Slowly coming to my wits end here...

Only (crappy) solution I've got at the moment is to cue the video up on a 2nd computer, hit play on BOTH at the same time, and hope for the best. Not good ....

Re: Video Issue: "..could not be read ..." HELP!!

Posted: Fri Jan 13, 2017 4:12 am
by Stromkraft
LesMizzell wrote:
Only (crappy) solution I've got at the moment is to cue the video up on a 2nd computer, hit play on BOTH at the same time, and hope for the best. Not good ....
So use handbrake to re-encode it to MP4. Instead of asking from Ableton that they make Live support every little video format under the sun, take control over your source material.

Also. may I suggest you don't use Live as the source for the finished video. It's better to use the video you import as the reference, export the audio and then add video from the original together in a real video editing application. There's plenty of free and low priced editors if you need to do this yourself. If the budget allows you should probably pay someone else to do it.

Re: Video Issue: "..could not be read ..." HELP!!

Posted: Fri Jan 13, 2017 6:58 am
by LesMizzell
Well, the docs say Live needs .mov files. I started there.

I tried importing the MP4 as well - same result. That won't import either.
Doesn't matter what format I try, I get the same error and it won't import into the project.

... BUT, any of those same videos will play fine in the Windows media player, so I know the codec needed to play it is on the system.

I'm not doing the final mix on this myself - once I've completed the music files, everything goes back to the production house and they're running the final mix from there, but, I do have Premier, and have tried importing/exporting a number of formats of the file in order to get Live to import it. No joy.

So I'm stuck. No idea what to try next.

Re: Video Issue: "..could not be read ..." HELP!!

Posted: Fri Jan 13, 2017 1:21 pm
by LesMizzell
I also have Live installed on an older iMac. It's too underpowered for me to complete my project on, but as a test, I tried importing my ,mov file into a test project on the iMac. The file imports fine and plays back as expected.

Therefor, the problem is definitely video import on the PC.
I've contacted Ableton support as well as posting here at this point. I need a solution.

Re: Video Issue: "..could not be read ..." HELP!!

Posted: Fri Jan 13, 2017 2:17 pm
by LesMizzell
I uninstalled and then reinstalled fresh versions of the suggested codecs listed on Abletons' support page.
Now, I'm no longer getting the error message, but the video appears to start importing, then Live immediately crashes. Every time.

I've tried a number of additional .mov files that WILL import into Live on my Mac, but they all crash the PC version...

Re: Video Issue: "..could not be read ..." HELP!!

Posted: Sat Jan 14, 2017 1:13 pm
by LesMizzell
One additional note - I downloaded a trial of Digital Performer.
Everybody single video I've tried to use in Live imports and plays flawlessly in Performer.
The problem is definitely in Live. I just don't know if it's just the 64 bit version or not.

Silence from my Ableton support request as well.
If you're listening - I'm willing to test and send you anything information you need to help find a fix for this.

Re: Video Issue: "..could not be read ..." HELP!!

Posted: Tue Jan 17, 2017 4:38 pm
by LesMizzell
I had to give up and move this particular scoring session to Performer, as there seems nothing I can do in order to get video to play in Ableton.
The style of music I'm doing for this project would have been a better fit for Ableton though.

I'm guessing there's a problem with 64 bit Windows 10, but I've heard nothing from support yet.

So, Ableton over, except the video issue, is very stable for me on Windows. As long as I'm not using video, it's working great.
Performer however, will play video, but is extremely unstable on Windows and is taking a lot of extra time recovering from crashes.

Neither of these is a good situation. I'm hoping I can get support from both companies to get with me to help resolve these problems. I'm will to test/run anything, send any files wanted ... whatever.

Re: Video Issue: "..could not be read ..." HELP!!

Posted: Tue Jan 17, 2017 6:51 pm
by ChangoM
LesMizzell wrote:I had to give up and move this particular scoring session to Performer, as there seems nothing I can do in order to get video to play in Ableton.

I'm guessing there's a problem with 64 bit Windows 10, but I've heard nothing from support yet.
FWIW, I use video heavily with Ableton Live Suite in Windows 10 64-bit with MOV, MP4, M2T and just about every other video format/wrapper thrown at me using:

https://www.codecguide.com/download_kl.htm

Re: Video Issue: "..could not be read ..." HELP!!

Posted: Wed Jan 18, 2017 3:16 pm
by LesMizzell
FWIW, I use video heavily with Ableton Live Suite in Windows 10 64-bit with MOV, MP4, M2T and just about every other video format/wrapper thrown at me using: https://www.codecguide.com/download_kl.htm
I will give that a try. Thank you very much.

Re: Video Issue: "..could not be read ..." HELP!!

Posted: Wed Oct 03, 2018 11:30 am
by dankostieglitz
i had the same problem with windows 10 64 bit and live 9 and i installed the k lite basic codec pack and now it works perfectly! thanks!

Re: Video Issue: "..could not be read ..." HELP!!

Posted: Sun Feb 03, 2019 9:39 pm
by carrieres
ChangoM wrote:FWIW, I use video heavily with Ableton Live Suite in Windows 10 64-bit with MOV, MP4, M2T and just about every other video format/wrapper thrown at me using:

https://www.codecguide.com/download_kl.htm
Are you using live 10 ?
it does not work for me :cry:

Re: Video Issue: "..could not be read ..." HELP!!

Posted: Fri Feb 15, 2019 7:57 am
by carrieres
I found a solution thanks to Pottering from KVR, i must use the integrated graphics for Ableton Live10 exe
pottering wrote: For example, my system has a AMD Radeon GPU, it has a "AMD settings" software installed with the drivers. I found Live's EXE in it and set it to "Power Saving", which keeps it from using the discrete GPU.

https://www.amd.com/en/support/kb/faq/dh-017

With NVIDIA it apparently it works like this (not sure though):

https://nvidia.custhelp.com/app/answers ... ettings%3F
This tip should be added in the faq :
https://help.ableton.com/hc/en-us/artic ... -Live-Win-

Re: Video Issue: "..could not be read ..." HELP!!

Posted: Sat Feb 16, 2019 12:30 am
by chris vine
Video in Live 10 has been a massive pain in the a** for me: (Win 7 64 bit with Nvidia card).
So much so, that I have sometimes been forced back to Live 9 32 bit just to be able to view a video in Live.

Make sure you have Quicktime installed on your PC, because without it, you'll have hassles with video in Live.
Even then, just dragging an MP4 clip into the arrange window takes a while, as though Live is deciding whether to import or not.
Mixing MAC software with Windows is always iffy anyway but there's not much choice here AFAICS.
Quicktime and iTunes are complete rubbish on PC.

Come on Abes, PLEASE sort this shit out. It's about time PC users had some real support on this issue and not some workaround based on coding made on Macs.

Re: Video Issue: "..could not be read ..." HELP!!

Posted: Wed Jun 12, 2019 11:59 pm
by chris vine
Bump.

Had to use video for the first time in a while. Windows 7 (for my sins). Arrgh! NO DICE :x

So my workaround: downloaded a trial version of Reaper and tried Rewire to Live 10.1.
Ran the video (MP4) into reaper. Hey presto!
WTF Reaper is only 20mb.
IS this a mad idea?

Re: Video Issue: "..could not be read ..." HELP!!

Posted: Thu Jan 09, 2020 2:57 am
by DjPseudonymous
chris vine wrote:
Wed Jun 12, 2019 11:59 pm
Bump.

Had to use video for the first time in a while. Windows 7 (for my sins). Arrgh! NO DICE :x

So my workaround: downloaded a trial version of Reaper and tried Rewire to Live 10.1.
Ran the video (MP4) into reaper. Hey presto!
WTF Reaper is only 20mb.
IS this a mad idea?
No, it's a great idea as long as it works!

It's painful to read the above posts. I can't understand why this was never tested and fixed in 64 bit versions of Live. I still literally have to run 32 and 64 bit versions of Live 9.7.7 on my Win 10 system in order to run old VSTs that never got ported to 64 bit.

The CCCP solution worked for a while for me to get video working on 9.7.7 64 bit, but now it's unstable and at the point the 64 bit version of Live will not even launch. On the last run I observed the tray icon of ASIO4ALL blinking alternately green and red indicating possible incompatibility between ASIO4ALL and CCCP? Well, time to start the next 10 hour debugging to see which of all the pieces don't work.