re-enable automation button turns on when i launch 3/4 scene

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
NoSonic822
Posts: 700
Joined: Sat Jun 01, 2013 8:38 am

re-enable automation button turns on when i launch 3/4 scene

Post by NoSonic822 » Fri Jul 21, 2017 9:13 am

I have 3 scenes, one is
114bpm;4/4
104bpm;3/4
84bpm;4/4

For some reason when i trigger the scene, the orange "re-enable automation" button turns on, like I overrode some automation, so it plays one scene in 3/4, but then re enable turns on, and if i press the re-enable, it switches the global sig to 4/4, so the metronome starts counting the 3/4 clip wrong

the clip in the 3/4 scene is 3/4, my global quant is 1 bar.

i start switching between scenes, and the metronome is not hitting the "1", it keep going out of time. i have all 3 clips set to 4 bar quant, so I dont get why this is happening....

why is the re enable thing going on?

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: re-enable automation button turns on when i launch 3/4 scene

Post by Stromkraft » Fri Jul 21, 2017 10:06 am

NoSonic822 wrote: why is the re enable thing going on?
Do you have any Max For Live devices in your set? Some older devices with deprecated objects can cause this.
Make some music!

Angstrom
Posts: 14662
Joined: Mon Oct 04, 2004 2:22 pm
Contact:

Re: re-enable automation button turns on when i launch 3/4 scene

Post by Angstrom » Fri Jul 21, 2017 11:58 am

Surely this is because a scene with a time signature change is altering the song's time-sig away from what is set in the arrangement. Hence the "back to arrangement" illumination. If the arrangement is 4/4 and you use the scene to flip to 3/4, it's a kind of automation change. It's certainly a difference between the session and arrangement.

I've not investigated this fully though. Just my thoughts.

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: re-enable automation button turns on when i launch 3/4 scene

Post by Stromkraft » Fri Jul 21, 2017 2:10 pm

Angstrom wrote:Surely this is because a scene with a time signature change is altering the song's time-sig away from what is set in the arrangement. Hence the "back to arrangement" illumination.
I thought it was the "re-enable automation" button in transport?
Make some music!

Angstrom
Posts: 14662
Joined: Mon Oct 04, 2004 2:22 pm
Contact:

Re: re-enable automation button turns on when i launch 3/4 scene

Post by Angstrom » Fri Jul 21, 2017 3:49 pm

ah sorry, that's what I meant. I referenced the wrong button. "re-enable automation" is effectively "BTA for automation"

when automating time-signature from Session (with a scene named "3/4") it is creating an automation deviation from what is set in the arrangement. Even if there are no time sig markers previously set in the arrangement Live assumes 4/4 as a basis. It's a bit weird, but it's how they chose to implement it.

Consequently, if you activate a named 3/4 scene, you'll see that in arrangement a temporary time signature marker is created "3/4". (Try it with two screens to see it in action). At that point if this signature automation is not written to the arrangement with arrangement record then the state of the automation remains at "4/4" temporarily modified to 3/4 by the temporary marker. Using the "re-enable automation" and the 3/4 marker is removed.

I'm writing contracts today. I ought to be more precise!

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: re-enable automation button turns on when i launch 3/4 scene

Post by Stromkraft » Fri Jul 21, 2017 9:37 pm

Angstrom wrote:ah sorry, that's what I meant. I referenced the wrong button. "re-enable automation" is effectively "BTA for automation"

when automating time-signature from Session (with a scene named "3/4") it is creating an automation deviation from what is set in the arrangement. Even if there are no time sig markers previously set in the arrangement Live assumes 4/4 as a basis. It's a bit weird, but it's how they chose to implement it.

Consequently, if you activate a named 3/4 scene, you'll see that in arrangement a temporary time signature marker is created "3/4". (Try it with two screens to see it in action). At that point if this signature automation is not written to the arrangement with arrangement record then the state of the automation remains at "4/4" temporarily modified to 3/4 by the temporary marker. Using the "re-enable automation" and the 3/4 marker is removed.
Yes, this makes sense.

Did this excellent item help you identify the culprit in your case, NoSonic822?
Make some music!

NoSonic822
Posts: 700
Joined: Sat Jun 01, 2013 8:38 am

Re: re-enable automation button turns on when i launch 3/4 scene

Post by NoSonic822 » Sat Jul 22, 2017 10:06 am

Angstrom wrote:Surely this is because a scene with a time signature change is altering the song's time-sig away from what is set in the arrangement. Hence the "back to arrangement" illumination. If the arrangement is 4/4 and you use the scene to flip to 3/4, it's a kind of automation change. It's certainly a difference between the session and arrangement.

I've not investigated this fully though. Just my thoughts.
yea, thanks thats it. as long as the metronome isnt on it's not a big deal. but it can screw you up if you arent noticing when you're playing beats in to the metronome.

Post Reply