Midi controllers not mapping

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
danny klim
Posts: 72
Joined: Wed May 24, 2017 1:34 pm

Midi controllers not mapping

Post by danny klim » Mon Oct 16, 2017 5:34 pm

Hi, i'm trying to use an Akai Midimix and a novation Launch Control to map some basic volume functions in ableton. Could you please help?


Both of them seem to be pre-mapped by ableton- they control volume and sends for different tracks in a way that makes sense.

However, I want to change the functions for many of them knobs to make them control different tracks or control different effects on tracks. I tried clicking the MIDI button on the top right (or hitting cmd M) to make everything purple, and then clicking on the parameter that i want to change in ableton, then turning the physical knob that i want to assign that parameter to. But that is not doing anything to map the controllers- they stay with the original pre-mapping.

I'm pretty sure i've manually mapped ableton without issue before (and the controllers map fine in logic), but dont understand why this is happening now. Could you please help me figure out what to do? Am i missing a step or something?


Thanks, Dan

S4racen
Posts: 5207
Joined: Fri Aug 24, 2007 4:08 pm
Location: Dunstable
Contact:

Re: Midi controllers not mapping

Post by S4racen » Mon Oct 16, 2017 7:27 pm

The controller needs to be listed as MIDI Control in the bottom half of the MIDI Set Up preferences you want remote set to on....

Cheers
D

Post Reply