Routing Audio to Soundflower/OBS

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
danny klim
Posts: 71
Joined: Wed May 24, 2017 1:34 pm

Routing Audio to Soundflower/OBS

Post by danny klim » Sun Oct 29, 2017 1:03 am

Hi, I’m trying to route audio from Ableton to OBS via soundflower, but OBS isn’t recieving the audio and i dont know what to do. Could you please help?

I am able to route audio from Logic to OBS via soundflower without problem, so the problem has to be somewhere in Ableton. I have created an aggregate interface with SoundFlower (2 channel version) as the outputs 23 and 24 (screenshot below)

https://www.dropbox.com/s/qmg1eml302n21 ... 0.png?dl=0


Then i created a track in Ableton called Output to SF 1+2 (screenshot link below). I set this to recieve audio from the master (post mixer) so that OBS would recieve all of the tracks that i play/mix/add effects to in ableton. (I created a seperate track for this in addition to the master, because i still want to monitor the sound in ableton and be able to control it independently from the sound going to OBS.)

I routed the audio of this track to an External out on channels 23 and 24.

I thought this would work, but i find that OBS is picking up no signal. With Logic, OBS shows the signal with a green line where it says “Desktop audio” to indicate that its receiving sound. But with ableton, there is no signal in OBS there, even though there is a signal on the track that i created ( (Output to SF 1+2) (you can see this below too)


Am i doing something wrong in the routing or have i missed a step/setting? What should i do to make it work?



https://www.dropbox.com/s/rrwac3g1m9oso ... 1.png?dl=0


Thanks, Dan

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Routing Audio to Soundflower/OBS

Post by Stromkraft » Sun Oct 29, 2017 6:49 am

You're not showing us the audio settings in Live nor the Logic settings.
Make some music!

danny klim
Posts: 71
Joined: Wed May 24, 2017 1:34 pm

Re: Routing Audio to Soundflower/OBS

Post by danny klim » Tue Oct 31, 2017 2:05 pm

Sorry about that, thanks for letting me know!

Here is the device settings in logic (and you can also see the routings in the mixer in the bottom)

https://www.dropbox.com/s/vx4lm9khgwv3d ... 4.png?dl=0

Here is the device preferences and the output config in Ableton

https://www.dropbox.com/s/t1fu8snz8ay8x ... 1.png?dl=0


Please let me know if there’s any other info that I should provide.

Thanks, Dan

danny klim
Posts: 71
Joined: Wed May 24, 2017 1:34 pm

Re: Routing Audio to Soundflower/OBS

Post by danny klim » Tue Oct 31, 2017 2:09 pm

Think i have just found the solution- i needed to select both the mono and stereo output as 23/24 in output config- the audio seems to be working now. Does this make sense, is it correct?

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Routing Audio to Soundflower/OBS

Post by Stromkraft » Tue Oct 31, 2017 8:31 pm

danny klim wrote:Think i have just found the solution- i needed to select both the mono and stereo output as 23/24 in output config- the audio seems to be working now. Does this make sense, is it correct?
I forgot now why this is necessary, but this stood out as I always do this in my audio settings for some reason.
Make some music!

Post Reply