Clicks on all tracks during tempo change

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
gtripi
Posts: 15
Joined: Fri Oct 14, 2011 7:11 pm

Clicks on all tracks during tempo change

Post by gtripi » Sun Jan 28, 2018 8:00 am

I use Live for film scoring work, and often have tempo changes. They are always direct changes, instead of linear ramps. So, the cue can be playing at 90bpm, and then change to 110bpm on a downbeat. Every time this happens, Live clicks. It gets recorded in an offline bounce also. I've eliminated all of my plugins, and don't have any audio with warp markers over the break, so I think it's the main audio engine making a click. Does anyone know how to fix this?

Thanks!

McAnix
Posts: 415
Joined: Mon Jan 14, 2013 7:42 pm

Re: Clicks on all tracks during tempo change

Post by McAnix » Sun Jan 28, 2018 9:51 am

Just incase, have you made sure the end of the first clip and beginning of the second clips are faded. Just the clip edges?

mikb
Posts: 373
Joined: Sat Jan 08, 2011 9:53 pm

Re: Clicks on all tracks during tempo change

Post by mikb » Mon Jan 29, 2018 12:15 pm

gtripi wrote:I've eliminated all of my plugins, and don't have any audio with warp markers over the break, so I think it's the main audio engine making a click. Does anyone know how to fix this?
Have you actually looked at the waveform? Usually clicks come from going from a non-zero amplitude to a value a long way from the end point, including zero. Short fades as McAnix suggested can help.

You should be able to eliminate track by track until you find likely candidates for the source of this issue. Sometimes it's interactions.

Also watch out for automation changes at the intersection and make them before, or if not possible make them contiguous like a fade.
Basic gear info: Macbook Pro with macOS 10.12, Ableton Live Suite version 9 (64bit) with Ozone, Push and APC20 as controllers.

gtripi
Posts: 15
Joined: Fri Oct 14, 2011 7:11 pm

Re: Clicks on all tracks during tempo change

Post by gtripi » Mon Jan 29, 2018 5:51 pm

I may not have explained this problem correctly. I'm not using any audio files, it's all MIDI. I don't have any automation break points over the tempo change, except of course the tempo line in the MASTER track. It's difficult to tell whether the click is coming from the tail of an instrument ringing over the tempo change, or if it's a global problem with Live. It's very easy to watch the playback, and hear the click as soon as Live encounters the tempo change. Not great for film music. We have lots of abrupt changes like this. I tried several different buffer settings also, and it still hasn't solved the problem.

mikb
Posts: 373
Joined: Sat Jan 08, 2011 9:53 pm

Re: Clicks on all tracks during tempo change

Post by mikb » Tue Jan 30, 2018 12:38 am

gtripi wrote:I may not have explained this problem correctly. I'm not using any audio files, it's all MIDI.
This doesn't matter as audio is audio. You can record the master with re-sampling to a new audio track and look at the waveform at those intersections for abrupt changes.

Also you can turn off track by track, device by device and loop the same intersection and listen back.

Then if necessary dive deeper and duplicate and freeze/flatten track by track and study the waveforms of these in the same way. Trough these methods you can learn what is the problem. It's likely not the "audio engine" in itself, but rather some kind of interaction.

Your symptoms indicate something like a waveform is aborted abruptly for some reason, which is likely causing the clicks. It's hard for me to say what is affected by the tempo change as I have no idea what's in your music. The alternative would be a click is somehow added on top of your music.

Even if your tempo changes are abrupt in their nature you can also zoom in on the master automation and make a slide to the new tempo during a 64th note or something, which may improve the issue.
Basic gear info: Macbook Pro with macOS 10.12, Ableton Live Suite version 9 (64bit) with Ozone, Push and APC20 as controllers.

yur2die4
Posts: 6451
Joined: Sat Oct 03, 2009 3:02 am
Location: Menasha, Wisconsin
Contact:

Re: Clicks on all tracks during tempo change

Post by yur2die4 » Tue Jan 30, 2018 12:45 am

Another thing that can cause clicks is a tempo synced digital delay effect. That and possibly synced automations, but usually anything that buffers and syncs, like delay or repeaters.

gtripi
Posts: 15
Joined: Fri Oct 14, 2011 7:11 pm

Re: Clicks on all tracks during tempo change

Post by gtripi » Sat Feb 03, 2018 5:09 am

After a lot of testing, I was able to narrow the problem down to one track. It’s not coming from any plugins, but there is an audio file that extends across my tempo change. It’s not warped, although I did try trying warping in and had the same clicking problem. It just seems to be coming from the fact that an audio file is laying across the tempo change. I tried changing the tempo shift to be a linear ramp, and it still didn’t help the problem. Maybe it will act differently in Live 10.

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Clicks on all tracks during tempo change

Post by Stromkraft » Sat Feb 03, 2018 2:26 pm

gtripi wrote:After a lot of testing, I was able to narrow the problem down to one track. It’s not coming from any plugins, but there is an audio file that extends across my tempo change. It’s not warped, although I did try trying warping in and had the same clicking problem. It just seems to be coming from the fact that an audio file is laying across the tempo change. I tried changing the tempo shift to be a linear ramp, and it still didn’t help the problem. Maybe it will act differently in Live 10.
If you can share a transition slice and the tempo change data more of us can also help in testing. I'm thinking there wouldn't be a click with a cut and superfast fades or if the change happen at a zero crossing. I need to test this.
Make some music!

Post Reply