Plugins don't work on Ableton Live 10 (Sausage Fattener)

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
heisdanne
Posts: 4
Joined: Thu Feb 08, 2018 5:06 am

Plugins don't work on Ableton Live 10 (Sausage Fattener)

Post by heisdanne » Thu Feb 08, 2018 5:11 am

Some plugins doesn't work on live 10, like Glitch 2 and Sausage Fattener. Anybody knows how to fix this?
Or what issues are involved in this possible crash?

They both work well on Ableton Live 9.

Da hand
Posts: 1622
Joined: Sat Jan 18, 2003 8:38 pm
Location: Montreal, Canada

Re: Plugins don't work on Ableton Live 10 (Sausage Fattener)

Post by Da hand » Thu Feb 08, 2018 6:23 am

Were you using Live 9 64bit or 32 bit?

daizok
Posts: 57
Joined: Fri Oct 27, 2017 9:05 am

Re: Plugins don't work on Ableton Live 10 (Sausage Fattener)

Post by daizok » Thu Feb 08, 2018 8:24 am

This issue was reported by several users on the beta forum, best to file a support request (now that it's released).

mothergarage
Posts: 454
Joined: Sun Sep 06, 2009 7:41 am
Contact:

Re: Plugins don't work on Ableton Live 10 (Sausage Fattener)

Post by mothergarage » Thu Feb 08, 2018 8:36 am

heisdanne wrote:Some plugins doesn't work on live 10, like Glitch 2 and Sausage Fattener.
Both working here.
home | sound | twitter | m4l
Windows 10 64bit - Live 10.0.1 - M4L 8 - RME Babyface/iConnectAUDIO4+

daizok
Posts: 57
Joined: Fri Oct 27, 2017 9:05 am

Re: Plugins don't work on Ableton Live 10 (Sausage Fattener)

Post by daizok » Thu Feb 08, 2018 8:39 am

Seems Mac related, i have not seen reports of Win users.

heisdanne
Posts: 4
Joined: Thu Feb 08, 2018 5:06 am

Re: Plugins don't work on Ableton Live 10 (Sausage Fattener)

Post by heisdanne » Thu Feb 08, 2018 5:57 pm

I'm using Ableton Live 10 64bits
And Ableton Live 9 64bits

Using MAC High Sierra 10.13.1

heisdanne
Posts: 4
Joined: Thu Feb 08, 2018 5:06 am

Re: Plugins don't work on Ableton Live 10 (Sausage Fattener)

Post by heisdanne » Thu Feb 08, 2018 5:58 pm

mothergarage wrote:
heisdanne wrote:Some plugins doesn't work on live 10, like Glitch 2 and Sausage Fattener.
Both working here.
Are you a mac user or win?

mothergarage
Posts: 454
Joined: Sun Sep 06, 2009 7:41 am
Contact:

Re: Plugins don't work on Ableton Live 10 (Sausage Fattener)

Post by mothergarage » Thu Feb 08, 2018 6:47 pm

heisdanne wrote: Are you a mac user or win?
see sig
home | sound | twitter | m4l
Windows 10 64bit - Live 10.0.1 - M4L 8 - RME Babyface/iConnectAUDIO4+

Da hand
Posts: 1622
Joined: Sat Jan 18, 2003 8:38 pm
Location: Montreal, Canada

Re: Plugins don't work on Ableton Live 10 (Sausage Fattener)

Post by Da hand » Thu Feb 08, 2018 7:00 pm

heisdanne wrote:I'm using Ableton Live 10 64bits
And Ableton Live 9 64bits

Using MAC High Sierra 10.13.1
Ah ok, thanks for clarifying :)

i_bonus
Posts: 2
Joined: Mon Apr 09, 2012 9:37 am

Re: Plugins don't work on Ableton Live 10 (Sausage Fattener)

Post by i_bonus » Fri Feb 09, 2018 12:55 pm

yep, same deal here. Sausage Fattener throws an error, does not load.

MacOS 10.12.6, works on ableton 9.7.5 x64, does not work on 10.0.1.

heisdanne
Posts: 4
Joined: Thu Feb 08, 2018 5:06 am

Re: Plugins don't work on Ableton Live 10 (Sausage Fattener)

Post by heisdanne » Fri Feb 09, 2018 8:37 pm

Glitch2 worked, I updated to 2.1 version.
But Sausage Fattener still don't load and now the vst aren't appearing in the vst section.

smith64fx
Posts: 3
Joined: Thu Feb 15, 2018 11:13 pm

Re: Plugins don't work on Ableton Live 10 (Sausage Fattener)

Post by smith64fx » Thu Feb 15, 2018 11:13 pm

Yeah

Pls @Ableton help us :)

lalakulo
Posts: 51
Joined: Sat Nov 07, 2009 12:30 am

Re: Plugins don't work on Ableton Live 10 (Sausage Fattener)

Post by lalakulo » Sat Feb 17, 2018 2:21 pm

Maybe you could recreate this with abletons effects. So your projects are not depending on this vst.

Freestylaa
Posts: 1
Joined: Sun Feb 18, 2018 12:26 am

Re: Plugins don't work on Ableton Live 10 (Sausage Fattener)

Post by Freestylaa » Sun Feb 18, 2018 12:29 am

Same issue here running Mac OSX El Capitan 10.11.6 on Mac Mini Quadcore 2.6ghz i7 16GB Ram 1TB SSD

My licensed Live 10 Suite simply stalls at startup screen while scanning Plugins. SausageFattener (which worked fine in Live9.7 64bit) is now having issues.

Also noticed various crashes on Startup of Ableton Live 10 Suite.

This needs a fix definitely... Pls @Ableton can you post a solution?

aklisiewicz
Posts: 362
Joined: Mon Mar 14, 2005 3:33 am

Re: Plugins don't work on Ableton Live 10 (Sausage Fattener)

Post by aklisiewicz » Sun Feb 18, 2018 1:04 am

I have KOMPLETE ULTIMATE 11 and had to remove already 5 plugins or Live10 would crash.
I also have had some plugins in Live9 converted using jBridge and they worked but they do not work in Live10 (9 and 10 64bit).
Running Win10/64
Not to happy, especially I made a mistake and removed Live9

What's wired is that when I start Live10/64 it seem to work, but the moment I start scanning VST folder it crashes.
"You are what you think you are"
Sadarahu

Post Reply