Clip colour in arrangement view

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
max million
Posts: 20
Joined: Fri Sep 26, 2008 12:27 am
Location: GR
Contact:

Clip colour in arrangement view

Post by max million » Mon Feb 19, 2018 12:14 pm

I just upgraded to Live version 10, seems there was a major change on clip colouring that is different from all previous versions, the clip now is totally coloured making it impossible to make edits right on the spot as i can not see the bars from the "canvas" behind the clip even by zooming in.
I see there is a small transparency still impossible to see the lines behind the coloured clip, is there an option to tweak the transparency of the clip?

I have emailed Ableton about this and received a failed support email from the Ableton team stating that i can see the background through the shortcut "a" and entering automation mode but still you can not cut the clip in automation mode.

Any one has the same issue?

Warmonger
Posts: 130
Joined: Wed Aug 01, 2007 7:02 pm
Location: Warsaw, Poland
Contact:

Re: Clip colour in arrangement view

Post by Warmonger » Mon Feb 19, 2018 6:33 pm

Everything works fine here. In arrangement view notes and automation are visible.

max million
Posts: 20
Joined: Fri Sep 26, 2008 12:27 am
Location: GR
Contact:

Re: Clip colour in arrangement view

Post by max million » Mon Feb 19, 2018 6:40 pm

Notes and automation are visible yes, but not the vertical "lines" in the canvas in ableton background. The clip now has colour istead of see-through like on all previous versions.

glenn303
Posts: 1056
Joined: Mon Sep 17, 2007 7:03 pm

Re: Clip colour in arrangement view

Post by glenn303 » Mon Feb 19, 2018 7:32 pm

You have to click the very top of the clip in order for the grid to show.

max million
Posts: 20
Joined: Fri Sep 26, 2008 12:27 am
Location: GR
Contact:

Re: Clip colour in arrangement view

Post by max million » Mon Feb 19, 2018 9:36 pm

Of course, you can also select the clip to see the lines... but still you can not see the lines behind the clip when the clip(s) are not selected which was one of the main advances of Live on quick audio cuts and edits. It simply does not make any sense

Nokatus
Posts: 1064
Joined: Fri Jul 01, 2005 7:06 am

Re: Clip colour in arrangement view

Post by Nokatus » Mon Feb 19, 2018 10:54 pm

You are in the new "uncluttered" default view mode that doesn't show track automation, and colors the clips as more opaque. Press A on your keyboard to enter the automation mode that, incidentally, resembles the classic Live view mode :), with the gridlines and automation visible etc.

Nokatus
Posts: 1064
Joined: Fri Jul 01, 2005 7:06 am

Re: Clip colour in arrangement view

Post by Nokatus » Mon Feb 19, 2018 11:03 pm

max million wrote:i can see the background through the shortcut "a" and entering automation mode but still you can not cut the clip in automation mode.
Sorry, just noticed this. Cutting the clips in that mode works fine over here :?

max million
Posts: 20
Joined: Fri Sep 26, 2008 12:27 am
Location: GR
Contact:

Re: Clip colour in arrangement view

Post by max million » Tue Feb 20, 2018 9:30 am

Nope, if you select a part of the clip and press delete for example it does not delete the part, still you can not edit.. only cut with Ctrl+E / Cmd+E

Nokatus
Posts: 1064
Joined: Fri Jul 01, 2005 7:06 am

Re: Clip colour in arrangement view

Post by Nokatus » Tue Feb 20, 2018 12:08 pm

max million wrote:i can see the background through the shortcut "a" and entering automation mode but still you can not cut the clip in automation mode.
max million wrote:still you can not edit.. only cut with Ctrl+E / Cmd+E
Ah, I see now. I thought ^ this was the cutting you were talking about. What other editing doesn't work, in addition to delete?

Nokatus
Posts: 1064
Joined: Fri Jul 01, 2005 7:06 am

Re: Clip colour in arrangement view

Post by Nokatus » Tue Feb 20, 2018 12:27 pm

Feature request here: viewtopic.php?f=3&t=229458

max million
Posts: 20
Joined: Fri Sep 26, 2008 12:27 am
Location: GR
Contact:

Re: Clip colour in arrangement view

Post by max million » Tue Feb 20, 2018 12:43 pm

Yes, exactly. This was one of live's advantages in clip edits , at least the way i work. Using Live this way since Ver.5 it is a big disappointment to see it can't be done on the new 10 Version.

Nokatus
Posts: 1064
Joined: Fri Jul 01, 2005 7:06 am

Re: Clip colour in arrangement view

Post by Nokatus » Tue Feb 20, 2018 12:52 pm

Yeah. Check my second post in the feature request thread; I see there's a reason for it working like it does, but it would be very nice to have an option for a more "traditional" editing experience in the A mode. Basically, an option for allowing these clip editing actions on the main clip container in A mode.

max million
Posts: 20
Joined: Fri Sep 26, 2008 12:27 am
Location: GR
Contact:

Re: Clip colour in arrangement view

Post by max million » Tue Feb 20, 2018 1:29 pm

Or at least make the clip color transparent so you do not need to enter "a" mode in the first place. What's the matter with the devs @ Ableton? :?

Nokatus
Posts: 1064
Joined: Fri Jul 01, 2005 7:06 am

Re: Clip colour in arrangement view

Post by Nokatus » Tue Feb 20, 2018 3:49 pm

Ironically, there's an AutomationLaneClipBodyAlpha keyword in the new theme format, and I just tested you can indeed adjust the clip transparency in A mode :D simply by changing the value in your preferred theme file, making the grid show more/less.

Don't seem to find any keyword for clip alpha when in the other view mode, though, hahh. Tried guessing some in case there's an unused easy match (ClipBodyAlpha? ArrangementClipBodyAlpha? ArrangementLaneClipBodyAlpha?) and finally checked if a list of theme keywords is stored in plaintext in the executable (it is), and yep, there doesn't seem to be anything other relevant to these than the above.

That would be one tweaking solution. Just add a similar keyword for clip alpha in the default viewmode, as there's an alpha value for that, too, already in use internally anyway.

max million
Posts: 20
Joined: Fri Sep 26, 2008 12:27 am
Location: GR
Contact:

Re: Clip colour in arrangement view

Post by max million » Tue Feb 20, 2018 4:23 pm

I have been advised a workaround, you need to move the mouse up to the header after you select something, then click delete, done.

Post Reply