Ableton 10 slow to load instruments, drums, rack etc...

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Muze
Posts: 168
Joined: Fri Jul 16, 2010 6:01 am

Re: Ableton 10 slow to load instruments, drums, rack etc...

Post by Muze » Sat Jun 09, 2018 8:16 pm

Super slow for me too (on Mac)

Stromkraft
Posts: 7055
Joined: Wed Jun 25, 2014 11:34 am

Re: Ableton 10 slow to load instruments, drums, rack etc...

Post by Stromkraft » Sat Jun 09, 2018 10:06 pm

If you guys could perhaps define "slow" in actual measured time units, then perhaps there could be some help for you?
And describe what you have installed, when it's slow and whether or not you've done the usual checks.

I did some tests previously, posted here, but this was well within the tolerable. It was, however, clearly slower in 10.0.2 compared 10.0.1. There may be reasons for that, but I can't say if those are acceptable until they are known.

Some suggestions for measurements, preferably the exact same thing in Live 10.0.1, 10.0.2 and 10.0.3b. are:
  • Loading of a set.
  • Loading a multiple samples
  • Exporting a song
Share your data to Ableton and include reports and sets if possible. or just complain about the speed.
Make some music!

[jur]
Site Admin
Posts: 1285
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: Ableton 10 slow to load instruments, drums, rack etc...

Post by [jur] » Sat Jun 09, 2018 10:12 pm

It is known that loading large drum racks are slower in L10.
It's fixed in the latest 10.0.3b1, though.
Ableton Forum Moderator

locojohn
Posts: 483
Joined: Mon Feb 19, 2007 8:42 am
Location: riga, latvia

Re: Ableton 10 slow to load instruments, drums, rack etc...

Post by locojohn » Wed Jul 04, 2018 11:36 am

[jur] wrote:L10 is slower to load samples. That's fixed in the latest beta though.
Well, it takes about a minute to load a small live set in Live 10.0.2. It does not even contain M4L devices. It does contain samples, though. Why does it take so long to load?

For the reference, my system is iMac 2017 27" 3.5Ghz 16GB RAM Fusion drive system. The OS is macOS 10.13.5.

Best regards,
Andrejs
/*
  • the basic tone of life remains the same,
    and in it there are some happy melodies
    and some sad melodies
    - sekito kisen
*/

mbenigni
Posts: 762
Joined: Mon Aug 07, 2006 3:43 pm

Re: Ableton 10 slow to load instruments, drums, rack etc...

Post by mbenigni » Wed Jul 04, 2018 11:49 am

Stromkraft wrote:If you guys could perhaps define "slow" in actual measured time units, then perhaps there could be some help for you?
And describe what you have installed, when it's slow and whether or not you've done the usual checks.

I did some tests previously, posted here, but this was well within the tolerable. It was, however, clearly slower in 10.0.2 compared 10.0.1. There may be reasons for that, but I can't say if those are acceptable until they are known.

Some suggestions for measurements, preferably the exact same thing in Live 10.0.1, 10.0.2 and 10.0.3b. are:
  • Loading of a set.
  • Loading a multiple samples
  • Exporting a song
Share your data to Ableton and include reports and sets if possible. or just complain about the speed.
Re: “just complain”, etc. - if you read the previous posts in full you’ll find that most of the questions are addressed which you imply are not.

But I don’t really have a horse in the race; I decided to stick with Live 8. I’m considering a jump to Cubase anyway.

Stromkraft
Posts: 7055
Joined: Wed Jun 25, 2014 11:34 am

Re: Ableton 10 slow to load instruments, drums, rack etc...

Post by Stromkraft » Wed Jul 04, 2018 2:20 pm

mbenigni wrote: Re: “just complain”, etc. - if you read the previous posts in full you’ll find that most of the questions are addressed which you imply are not.

But I don’t really have a horse in the race; I decided to stick with Live 8. I’m considering a jump to Cubase anyway.
What are you on about? I've been in this discussion since page 1. You missed reading previous posts in full perhaps? I was obviously directing my comment to new reporters since.

You have anything against people specifying what they feel is slow? Why? I think it's great if we can understand the different expectations different people may have. What's wrong with that?
Make some music!

mbenigni
Posts: 762
Joined: Mon Aug 07, 2006 3:43 pm

Re: Ableton 10 slow to load instruments, drums, rack etc...

Post by mbenigni » Wed Jul 04, 2018 3:10 pm

Stromkraft wrote:I was obviously directing my comment to new reporters since.
For a guy who puts a premium on accurate reporting, you sure are hanging a lot of weight on "you guys". :D

Seriously though, I agree it's beneficial for commenters to be as specific as possible, and submit data to Ableton where applicable. For my part, the differences in timing were on orders of magnitude, and thus not worth measuring with any accuracy. E.g. actions that took 1-2 seconds in v8 taking 20 seconds or more in v10, with "Application Not Responding" in the meantime. As stated earlier, this applies to everything from opening projects, inserting/ moving audio/MIDI channels, inserting VSTs, etc.

Stromkraft
Posts: 7055
Joined: Wed Jun 25, 2014 11:34 am

Re: Ableton 10 slow to load instruments, drums, rack etc...

Post by Stromkraft » Wed Jul 04, 2018 4:38 pm

mbenigni wrote:
Stromkraft wrote:I was obviously directing my comment to new reporters since.
For a guy who puts a premium on accurate reporting, you sure are hanging a lot of weight on "you guys". :D
Fair enough, but the time context is there.
mbenigni wrote: For my part, the differences in timing were on orders of magnitude, and thus not worth measuring with any accuracy. E.g. actions that took 1-2 seconds in v8 taking 20 seconds or more in v10, with "Application Not Responding" in the meantime
Yeah, but this is indeed very useful information you're adding to this now. There are execution times that under specific circumstances can be viewed as normal and not under others. I see you have a HDD. This of course reinforces any differences moving into the unacceptable.

I do think that if this "slowness" is behind the improvements in playback performance I've seen, then I think that's the right prioritisation. On the other hand I don't see why anything needs to go slow when not playing back.

Let's hope this is a technical development "debt" that Ableton will pay back in coming incremental updates.
Make some music!

mbenigni
Posts: 762
Joined: Mon Aug 07, 2006 3:43 pm

Re: Ableton 10 slow to load instruments, drums, rack etc...

Post by mbenigni » Wed Jul 04, 2018 5:23 pm

Stromkraft wrote:Yeah, but this is indeed very useful information you're adding to this now. There are execution times that under specific circumstances can be viewed as normal and not under others. I see you have a HDD.
The information in my last post was all covered when I initially chimed in on page 1 of this thread. Hence my comments earlier today. But I don't mean to beat a dead horse here. It's not really a huge deal. I'm sure the problem is specific to my configuration somehow; otherwise Live 10 never would have made it out of Beta. It's just that I was left with no reason to drop $280 on an "upgrade" that didn't appear to work for me. :) (I've since upgraded to an SSD, and it's likely Live 10 would work better now than it did before. But would it work better than Live 8 on the same SSD? With everything else beinq equal I'm inclined to doubt it, and I'm not really motivated to find the time to repeat the experiment.)

[jur]
Site Admin
Posts: 1285
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: Ableton 10 slow to load instruments, drums, rack etc...

Post by [jur] » Wed Jul 04, 2018 8:05 pm

As said earlier, the fix is coming soon with the 10.0.3 release.
Ableton Forum Moderator

prahja
Posts: 1
Joined: Wed Oct 24, 2018 5:24 am

Re: Ableton 10 slow to load instruments, drums, rack etc...

Post by prahja » Wed Oct 24, 2018 5:31 am

I have the same issue with iMac Pro. This is still valid and I have the issue with 10.0.4 version still.

For some reason it might be driven by GPU related problems instead of CPU.

8O
ahdsrbass wrote:Hey guys,

Have you experienced any issues with Live 10 taking a while to load instruments drum, pretty much anything from the browser on the left hand side? Just dragging in an instance of Simpler or Drum rack sometimes takes 5-10 seconds, where as Ableton 9 was pretty quick. I've also noticed much longer wait times to load even small projects.

Ableton runs on a Samsung SSD drive, and my library including the core files are on another 7200 RPM drive, could that be the issue? I've tried several things like making sure the library doesn't point to too many folders on my drive, as I've heard that can slow things down significantly due to Ableton indexing the samples.

I've got a good computer in terms of specs, more than what I need really.

Any thoughts?

Lucas

antic604
Posts: 572
Joined: Tue Jan 10, 2017 8:14 am
Location: Warsaw, Poland

Re: Ableton 10 slow to load instruments, drums, rack etc...

Post by antic604 » Wed Oct 24, 2018 8:52 am

Doing this actually solved the problem for me yesterday (Win10 though, so might be different for you):
https://help.ableton.com/hc/en-us/artic ... reset-Live

akela
Posts: 2
Joined: Tue Mar 06, 2018 4:54 am

Re: Ableton 10 slow to load instruments, drums, rack etc...

Post by akela » Sat Nov 03, 2018 7:59 pm

I just noticed this problem today. Instruments take ~10s to load but this wasn't an issue before. It's making me wonder if it's related to the most recent update to my current build number. I haven't really touched Live in the past couple of weeks, but the difference was immediately noticeable. Is it possible to roll back versions?

That said, I followed the Live 10 reset suggestion, and it made no difference whatsoever. Was super annoying though!

Happy to try anything, really.

Specs:

Ableton Live 10.0.5 (Build 2018-10-18_8aeadb1597)
Windows 10 Pro x64 (v1803 Build 17134.345)
Intel Cire i5 3770k
16GB DDR3
Steinberg UR44 interface
Live installed on SSD
Samples installed on HDD

tomf
Posts: 227
Joined: Tue Oct 21, 2008 2:02 pm

Re: Ableton 10 slow to load instruments, drums, rack etc...

Post by tomf » Mon Dec 03, 2018 9:38 pm

I am also finding Live 10.0.5 to be slow on my following machines -

Mac pro
Macbook pro

I have a lot of RAM, SSD drives in both, i just don't get it. When i try to flick thru presets on some plugins i get a noticeable lag. The audio is ok but everything on screen freezes for up to 10 seconds.

Also, when i load ableton up, i get the spinning wheel for about 15 seconds before i can do anything.

Very disappointed in this version of Live, it was a waste of time and money upgrading. Live 9 is fine.

mbenigni
Posts: 762
Joined: Mon Aug 07, 2006 3:43 pm

Re: Ableton 10 slow to load instruments, drums, rack etc...

Post by mbenigni » Tue Dec 04, 2018 4:59 pm

akela wrote:I just noticed this problem today. Instruments take ~10s to load but this wasn't an issue before. It's making me wonder if it's related to the most recent update to my current build number. I haven't really touched Live in the past couple of weeks, but the difference was immediately noticeable. Is it possible to roll back versions?

That said, I followed the Live 10 reset suggestion, and it made no difference whatsoever. Was super annoying though!

Happy to try anything, really.

Specs:

Ableton Live 10.0.5 (Build 2018-10-18_8aeadb1597)
Windows 10 Pro x64 (v1803 Build 17134.345)
Intel Cire i5 3770k
16GB DDR3
Steinberg UR44 interface
Live installed on SSD
Samples installed on HDD
Problem persisted for me after an update to Windows 10. (Live 8 is very quick on the same build.) The reset suggestion didn't work. I'm skeptical of the claim (above) that 10.0.3 resolved, since people are still having issues with 10.0.5. I've only tested the Live 10 demo version, and I don't know how far forward that has been patched.

Post Reply