Ableton 10 glitches and bugs

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
gkmachine
Posts: 6
Joined: Wed Mar 07, 2012 3:04 pm

Ableton 10 glitches and bugs

Post by gkmachine » Mon May 07, 2018 8:12 am

Hi,
I think we need a sticky for all the glitches and bugs with Live 10. I've contacted tech support but not had any response yet. For me, I have experienced the following:

Not saving edit history: I currently have a session on the go that the last edit that I can undo is when I opened it last week. This is a complete nightmare as I have a deadline to reach by this Thursday and need a track finished....but when I open it it doesn't sound like what we last saved. What this means is that, in my case, I can do 100 edits but when I go to File - Undo, the last thing is always "Undo change bpm" (I changed bpm almost a week ago)

Crackle and glitches: if a track is playing in arrangement view even if I move the cursor from one clip to another it crackles and pauses for a microsecond, sometimes it does it without having to do anything.

Re-enable automation is permanently coloured red: this implies that automation has been changed and to revert to the session's settings you need to click on it to over-ride any recent changed. However, when I do this it immediately jumps back to being red. This is impossible!!!

I have tried saving sessions as a new session but all these glitches cary over to amy new sessions too. I don't have time to convert all these channels to stems and open a completely fresh session with them! It's pretty infuriating.

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Ableton 10 glitches and bugs

Post by Stromkraft » Mon May 07, 2018 8:32 am

gkmachine wrote: Not saving edit history:…
….but when I open it it doesn't sound like what we last saved. What this means is that, in my case, I can do 100 edits but when I go to File - Undo, the last thing is always "Undo change bpm" (I changed bpm almost a week ago)
The emboldened statements seem unrelated to me. What does "doesn't sound like" even mean in this case?
gkmachine wrote: Crackle and glitches: if a track is playing in arrangement view even if I move the cursor from one clip to another it crackles and pauses for a microsecond, sometimes it does it without having to do anything.
What happens if you increase your audio buffer?
gkmachine wrote: Re-enable automation is permanently coloured red: this implies that automation has been changed and to revert to the session's settings you need to click on it to over-ride any recent changed. However, when I do this it immediately jumps back to being red. This is impossible!!!
Do you have any Melda plug-ins or Max For Live devices in the set?
gkmachine wrote: I have tried saving sessions as a new session but all these glitches cary over to amy new sessions too. I don't have time to convert all these channels to stems and open a completely fresh session with them! It's pretty infuriating.
This is to be expected. One way to look for culprits is to save as a new set and delete tracks until the issues disappears, undo and then delete devices. I've had to do that multiple times and have got rid of the involved devices/plug-ins.
Make some music!

gkmachine
Posts: 6
Joined: Wed Mar 07, 2012 3:04 pm

Re: Ableton 10 glitches and bugs

Post by gkmachine » Mon May 07, 2018 8:50 am

Hey, thanks for the response.

Right, forget about "doesn't sound like" (this could be subjective).... the main thing is the edit history......the last thing I can Undo is the change I made to bpm automation (slowing the track down at the end) I made this change during the 4th last time that I had the session open and have made many changes since.

Tried increasing audio buffer.....no improvement

Yes, M4L space echo. Are there known issues?

re:dream
Posts: 4586
Joined: Fri Dec 28, 2007 9:42 am
Location: Hoerikwaggo's sunset side...
Contact:

Re: Ableton 10 glitches and bugs

Post by re:dream » Mon May 07, 2018 6:43 pm

gkmachine wrote:
Yes, M4L space echo. Are there known issues?
viewtopic.php?f=1&t=230396

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Ableton 10 glitches and bugs

Post by Stromkraft » Tue May 08, 2018 5:22 am

gkmachine wrote:…the main thing is the edit history......the last thing I can Undo is the change I made to bpm automation (slowing the track down at the end) I made this change during the 4th last time that I had the session open and have made many changes since.
That's odd, yes. But is this only in this song or is it stuck at that in every song? Commonly Max For Live devices that spew data into the undo action list is behind the undo function breaking. Could you make a set without any MFL devices and see if that helps?
Make some music!

Alexander Dorodeiko
Posts: 1
Joined: Sun Feb 10, 2019 4:40 pm

Re: Ableton 10 glitches and bugs

Post by Alexander Dorodeiko » Sun Feb 10, 2019 4:45 pm

I have the same annoying issue with "undo change bpm". I actually can undo to a previous state, but need to click undo 20-30 times (all the times I see "undo change bpm".
Indeed, I use Max devices in the project, could be because of them.
Also, I have changing tempo in the project, but the undo bugs happen even when I am working on the parts with stable tempo.
Suuuuuuper annoying bug

nemoy
Posts: 380
Joined: Thu Jun 04, 2009 1:45 pm
Contact:

Re: Ableton 10 glitches and bugs

Post by nemoy » Fri Apr 05, 2019 1:04 pm

That same undo history spamming occurs also, when you map one Midi controller Knob to multiple parameters in live.
Turning that knob then results in loads and loads of tiny increments of the two or more mapped parameters being written into the undo history.
very, very super annoying.

Post Reply