This VST is not compatible with Live

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
leoparde
Posts: 1
Joined: Fri May 11, 2018 1:07 pm

This VST is not compatible with Live

Post by leoparde » Fri May 11, 2018 1:17 pm

I have some big issues with Waves plugins. They simply don't work anymore. All Waves "Support" does is reinstalling it endlessly in some vain hope it suddenly works? Now that IS good software engineering. I even let the guy remotely access my computer, and he did literally the same things I have done. They have zero idea as of now.

Which is sad because I spent a considerable time and money so I CAN USE THE PLUGINS I BOUGHT. Funny thing is that cracked plugins would probably work... Talk about irony.

So wondering if anyone had the same issue and how could I tell what "VST is not compatible mean"?

This is the message I get when I try to load any Waves plugin:

Image

Aka not much information at all.

I have to stress that this is NOT an Ableton issue: it doesn't work in Reaper either.

Everything on my system is 64bit. Everything is also legit bought software.

Is there a log, debug mode or whatever in any VST host which could tell me whats happening in there? Any help is appreciated, hell I'd probably PAY anyone who could figure this one out, as Waves are pretty much my go-to plugins when it comes to mixing.

If that helps these are my specs:
  • AMD Ryzen 7 1800x
    16GB Ram
    GigaByte AB350N Wifi motherboard
    NVidia Geoforce GTX 1050 Ti

    Windows 10 Home Edition
    Ableton 9.7.6
Waves Central is the newest. I have reinstalled it completely, deleted it completely etc. close to 10 times now. Maybe something in registry?

If you have any idea which goes beyond the "did you try to reinstall it" I'm happy to hear it. Even if it means meddling with registry or whatever. I'm pretty sure its a Waves licence issue or similar.

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: This VST is not compatible with Live

Post by Stromkraft » Fri May 11, 2018 3:05 pm

leoparde wrote:I have some big issues with Waves plugins. They simply don't work anymore. All Waves "Support" does is reinstalling it endlessly in some vain hope it suddenly works? Now that IS good software engineering. I even let the guy remotely access my computer, and he did literally the same things I have done. They have zero idea as of now.

Which is sad because I spent a considerable time and money so I CAN USE THE PLUGINS I BOUGHT. Funny thing is that cracked plugins would probably work... Talk about irony.

[Expletive deleted pee-emptively]. You need to use the VST versions only as I'm sure Waves support told you.

I have 30 Waves plug-ins. They all work and are solid. Actually, except for the occasional NI plug acting up there are no issues with any device or plug-in. If there is I toss it.

Imagining piracy will save you is ridiculous. Good luck with that attitude.
leoparde wrote: I'm pretty sure its a Waves licence issue or similar.
Nothing of what you have described indicates this.
Make some music!

Mark Williams
Posts: 233
Joined: Sun Aug 10, 2014 2:43 pm
Location: Deal, Kent

Re: This VST is not compatible with Live

Post by Mark Williams » Fri May 11, 2018 5:05 pm

Waves plugins do work within Ableton, and work well. I have zero issues with Waves ( and that speaks volumes, even for the Beta's I test)
Live 10,Push 2, Maschine MK3 & KK S61 MK2, Focusrite Scarlett 18i20, Softube Console 1 Mk2, Deepmind 12D, K-2,Roland MC-707, Komplete 12, Minitaur,TC Electronics M1XL,

H20nly
Posts: 15838
Joined: Sat Oct 27, 2007 9:15 pm
Location: The Wild West

Re: This VST is not compatible with Live

Post by H20nly » Fri May 11, 2018 6:15 pm

it might be a 32 bit vs. 64 bit issue.

if you're using Live in 64 bit, a 32 bit plugin will not work... and vice versa

unless you're Waves plug is about 4 or 5 years old and out of date, you should be able to get the 64 bit installer.
Ableton will have a 64 bit installer on your downloads page.

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: This VST is not compatible with Live

Post by Stromkraft » Sat May 12, 2018 12:22 am

H20nly wrote:it might be a 32 bit vs. 64 bit issue.
Leoparde actually said "Waves Central is the newest." and "Everything on my system is 64bit.".
Make some music!

H20nly
Posts: 15838
Joined: Sat Oct 27, 2007 9:15 pm
Location: The Wild West

Re: This VST is not compatible with Live

Post by H20nly » Tue May 15, 2018 9:45 pm

Stromkraft wrote:
H20nly wrote:it might be a 32 bit vs. 64 bit issue.
Leoparde actually said "Waves Central is the newest." and "Everything on my system is 64bit.".
right, so if the VSTs are 32 bit there will be an issue.

Phrases like "everything on my system", 'all the time', 'every time', 'everything', 'all of them'... people throw those in front of PC issues and probing questions about them all day long where I work. In my day to day job, more often than not, they are simply inaccurate qualifiers. I think people use them to create a sense of urgency and/or to keep from confirming the actual facts for reasons ranging from laziness to ineptitude.*

*I am not implying that is necessarily what was happening here... only that I take those qualifying phrases with a grain of salt on the first pass.




looks like it may be useful for posterity anyway. OP never came back.

Fizmarble
Posts: 320
Joined: Tue Sep 26, 2006 4:25 pm

Re: This VST is not compatible with Live

Post by Fizmarble » Wed May 16, 2018 5:29 pm

H20nly wrote:
Stromkraft wrote:
H20nly wrote:it might be a 32 bit vs. 64 bit issue.
Leoparde actually said "Waves Central is the newest." and "Everything on my system is 64bit.".
Phrases like "everything on my system", 'all the time', 'every time', 'everything', 'all of them'... people throw those in front of PC issues and probing questions about them all day long where I work. In my day to day job, more often than not, they are simply inaccurate qualifiers. I think people use them to create a sense of urgency and/or to keep from confirming the actual facts for reasons ranging from laziness to ineptitude.*

*I am not implying that is necessarily what was happening here... only that I take those qualifying phrases with a grain of salt on the first pass.
I "always" use these phrases to indicate that I've already reduced the possible solutions that people should suggest. :/
http://www.youtube.com/user/TOGtracks Free Jam Tracks for Guitarists, Bassists, and Drummers

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: This VST is not compatible with Live

Post by Stromkraft » Wed May 16, 2018 7:05 pm

Fizmarble wrote:
I "always" use these phrases to indicate that I've already reduced the possible solutions that people should suggest. :/
That'd be the possible solutions that you'd consider. We say what we think, not what you want.
Make some music!

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: This VST is not compatible with Live

Post by Stromkraft » Wed May 16, 2018 7:11 pm

H20nly wrote:
Stromkraft wrote:
H20nly wrote:it might be a 32 bit vs. 64 bit issue.
Leoparde actually said "Waves Central is the newest." and "Everything on my system is 64bit.".
right, so if the VSTs are 32 bit there will be an issue.
If Waves Central is indeed the newest — current is 1.3.7.8 — that would exclude 32bit plug-ins.
Make some music!

Fizmarble
Posts: 320
Joined: Tue Sep 26, 2006 4:25 pm

Re: This VST is not compatible with Live

Post by Fizmarble » Wed May 16, 2018 7:57 pm

Stromkraft wrote:
Fizmarble wrote:
I "always" use these phrases to indicate that I've already reduced the possible solutions that people should suggest. :/
That'd be the possible solutions that you'd consider. We say what we think, not what you want.
Fair enough, I just wouldn't waste time suggesting things that people said they had already ruled out. If someone is out to sabotage themselves by lying about what troubleshooting steps they had taken, I'm not sure they really want your help. :)
http://www.youtube.com/user/TOGtracks Free Jam Tracks for Guitarists, Bassists, and Drummers

H20nly
Posts: 15838
Joined: Sat Oct 27, 2007 9:15 pm
Location: The Wild West

Re: This VST is not compatible with Live

Post by H20nly » Wed May 16, 2018 10:50 pm

:roll:

Da hand
Posts: 1624
Joined: Sat Jan 18, 2003 8:38 pm
Location: Montreal, Canada

Re: This VST is not compatible with Live

Post by Da hand » Thu May 17, 2018 1:37 am

Lol, common guys - what's the point of this really :wink:

As far as I can tell, it's not a 64/32bit issue because the plugins wouldn't even show up in Live's browser. Therefore, you wouldn't get an error message.

Looking at the message for clues:
"this vst is not compatible with live"
..leads me to think that something in the version of the plugin and Live are not fully compatible with each other (other than 32/64 bit, lol).

Try running Live in compatibility mode for an earlier version of Windows - like Windows 8, 7, xp, etc. This can help sometimes in such situations.

Image

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: This VST is not compatible with Live

Post by Stromkraft » Thu May 17, 2018 5:44 am

Fizmarble wrote: Fair enough, I just wouldn't waste time suggesting things that people said they had already ruled out. If someone is out to sabotage themselves by lying about what troubleshooting steps they had taken, I'm not sure they really want your help. :)
True, but unless you have some parts of the post indicating the poster actually likely couldn't have done those claimed actions, starting out disbelieving the poster is somewhat odd.
Make some music!

Fizmarble
Posts: 320
Joined: Tue Sep 26, 2006 4:25 pm

Re: This VST is not compatible with Live

Post by Fizmarble » Thu May 17, 2018 3:45 pm

Stromkraft wrote:
Fizmarble wrote: Fair enough, I just wouldn't waste time suggesting things that people said they had already ruled out. If someone is out to sabotage themselves by lying about what troubleshooting steps they had taken, I'm not sure they really want your help. :)
True, but unless you have some parts of the post indicating the poster actually likely couldn't have done those claimed actions, starting out disbelieving the poster is somewhat odd.
Exactly. My original point was linked to the simple idea of trusting the poster when they make a statement about their setup. No hard feelings H20nly!
http://www.youtube.com/user/TOGtracks Free Jam Tracks for Guitarists, Bassists, and Drummers

H20nly
Posts: 15838
Joined: Sat Oct 27, 2007 9:15 pm
Location: The Wild West

Re: This VST is not compatible with Live

Post by H20nly » Fri May 18, 2018 6:12 pm

you guys are off in the weeds.

Da Hand is trying to re-rail
H20nly wrote:probing questions
i work as a Network Administrator and general I.T. digi-slave by day... sometimes asking things another way is helpful. however, i am so done with that here. the ends don't justify the means.


still no sign of the OP. so this is all just a bunch of wasted motion :arrow:

Post Reply