Clicking on Track Title sends MIDI messages...

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
arretx
Posts: 142
Joined: Thu Jul 02, 2015 5:29 am

Clicking on Track Title sends MIDI messages...

Post by arretx » Sat May 12, 2018 8:02 pm

Track 1: No MIDI Input. MIDI output set to Network Session 1 / Channel 15.
Track 2: No MIDI Input. MIDI output set to Network Session 1 / Channel 16.


Both tracks have a MIDI Effect Rack with empty chains. The purpose of this is to provide the clips with names notes based on the names of the chains rather than having to guess what C0 and D2 are, etc.

These two tracks send to a DMXIS lighting app on another Mac. The preset BANKS are controlled by the note values of clips in track 1 on channel 15 and the PRESETS in each bank are controlled by the note values in the clips in track 2 on channel 16.

So, if I want Bank 1, Lighting Configuration 2, I have a clip in Track 1 that fires off C-2 and one in track 2 that fires off a note on C#-2.

The Problem:

When I click the track title to switch between them while working with the tracks, 3 MIDI signals are sent on Network Session 1 to the other computer.

Source: From Session 1
Message: Control
Channel: 12
Data: Controller 118 64

Source: From Session 1
Message: Control
Channel: 3
Data: Bank Select (fine) 0

(the second message happens twice, seemingly simultaneously.

Now, I can't for the life of me figure out why Ableton Live is firing off MIDI notes when I switch tracks other than the fact that there's a MIDI Effect Rack in the track.

Ideas on how to stop it?
MacBook Air | Ableton Live 9.7.5 2017-10-02 | Advance 61 Keybaord w/VIP 3.0 | Launchpad Mini | Scarlett Focusrite 18i8 | iPad Pro / OnSong | Allen & Heath QU-32

Post Reply