Ableton 10.0.2 performance loss.

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Reemo
Posts: 16
Joined: Tue Mar 13, 2018 6:52 pm

Re: Ableton 10.0.2 performance loss.

Post by Reemo » Thu May 31, 2018 1:04 pm

So I was playing with it a bit. And my GUI freezes randomly and also when drag&dropping some VST synths. Minimizing and maximizing makes it work again.

daizok
Posts: 57
Joined: Fri Oct 27, 2017 9:05 am

Re: Ableton 10.0.2 performance loss.

Post by daizok » Thu May 31, 2018 2:51 pm

The lag in GUI processing on 4K screens has been present since the first 10 release. Improvements were introduced in beta releases, but the lag has not been eradicated or significantly reduced yet. This issue is on the radar.

daizok
Posts: 57
Joined: Fri Oct 27, 2017 9:05 am

Re: Ableton 10.0.2 performance loss.

Post by daizok » Thu May 31, 2018 2:52 pm

Reemo wrote:So I was playing with it a bit. And my GUI freezes randomly and also when drag&dropping some VST synths. Minimizing and maximizing makes it work again.
Are you using (very) high refresh rates?

Reemo
Posts: 16
Joined: Tue Mar 13, 2018 6:52 pm

Re: Ableton 10.0.2 performance loss.

Post by Reemo » Thu May 31, 2018 3:34 pm

daizok wrote:
Reemo wrote:So I was playing with it a bit. And my GUI freezes randomly and also when drag&dropping some VST synths. Minimizing and maximizing makes it work again.
Are you using (very) high refresh rates?
Not sure if very high, but I am using full HD, 144Hz. Also GUI doesn't lag. It just freezes when I add a new track, but ableton works ok. Minimizing and maximizing solves it and it didn't happen in 10.0.1. I've sent it to support, so hopefully this will get noticed.

Tarekith
Posts: 17348
Joined: Fri Jan 07, 2005 11:46 pm
Location: Ableton Forum Administrator
Contact:

Re: Ableton 10.0.2 performance loss.

Post by Tarekith » Thu May 31, 2018 3:52 pm

Setting the refresh rate back to 60Hz or lower seems to be fixing this for people.

paradiddle
Posts: 506
Joined: Wed Jul 14, 2004 12:21 am
Location: mtl

Re: Ableton 10.0.2 performance loss.

Post by paradiddle » Thu May 31, 2018 10:54 pm

Everything is slower now on windows 7 64 bit when browsing either from the desktop or using push 2. All was fine on the previous release.

edit: So is this related to the refresh rate issue everybody is having? I'm using a pretty old display.

solar28
Posts: 60
Joined: Mon Jul 25, 2005 7:43 am
Contact:

Re: Ableton 10.0.2 performance loss.

Post by solar28 » Sat Jun 02, 2018 1:40 pm

Echoing what Tarekith said, in my case setting my refresh rate to 60 HZ fixed all gui lag for me. Hopefully Windows or Ableton will find a long term fix, though I think this might be a windows issue.

paradiddle
Posts: 506
Joined: Wed Jul 14, 2004 12:21 am
Location: mtl

Re: Ableton 10.0.2 performance loss.

Post by paradiddle » Sat Jun 02, 2018 5:51 pm

It was fine in the first version 10 release and now it's not. It's not a windows issue.

kitekrazy
Posts: 731
Joined: Sat Jan 16, 2010 7:16 pm

Re: Ableton 10.0.2 performance loss.

Post by kitekrazy » Sat Jun 02, 2018 6:13 pm

Angstrom wrote:
Muze wrote:The library is what seems to slow everything down for me. I click on a section and it takes a few seconds to a few minutes for anything to actually appear, then if I click on another section I get the same, it only seems to retain one section at a time. The places/packs section is fine and opens instantly, it's just this constant need it has to scan in the background, I would rather just have a normal drive location based browser like the places section than this useless library.
make sure you haven't added any huuuuge locations to Places. If you add your entire computer to places then the library constantly scans your entire computer, every single file.
My places are: Audio, Music, Live Songs. which probably covers half a terabyte or so. But if I allowed places to index my whole machine it would be about 8 terabytes.
I don't know why they did this library scan. It was a big complaint when 9 came out. No other DAW does this.

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Ableton 10.0.2 performance loss.

Post by Stromkraft » Sat Jun 02, 2018 9:39 pm

konovalovua wrote: No, its not a Windows problem.
What makes you believe that? Even if Live is at fault it could be because an Windows API Live calls in the way it was declared. Ableton said for years OS X was at fault for some audio performance issues (OS X 10.9 to 10.11). Turns out they were right.

Don't assume.
Make some music!

Muze
Posts: 168
Joined: Fri Jul 16, 2010 6:01 am

Re: Ableton 10.0.2 performance loss.

Post by Muze » Sat Jun 02, 2018 10:53 pm

kitekrazy wrote:
Angstrom wrote:
Muze wrote:The library is what seems to slow everything down for me. I click on a section and it takes a few seconds to a few minutes for anything to actually appear, then if I click on another section I get the same, it only seems to retain one section at a time. The places/packs section is fine and opens instantly, it's just this constant need it has to scan in the background, I would rather just have a normal drive location based browser like the places section than this useless library.
make sure you haven't added any huuuuge locations to Places. If you add your entire computer to places then the library constantly scans your entire computer, every single file.
My places are: Audio, Music, Live Songs. which probably covers half a terabyte or so. But if I allowed places to index my whole machine it would be about 8 terabytes.
I don't know why they did this library scan. It was a big complaint when 9 came out. No other DAW does this.
Me neither, I'd rather it was not doing this.

spagbol
Posts: 121
Joined: Thu Feb 19, 2015 8:04 am

Re: Ableton 10.0.2 performance loss.

Post by spagbol » Sun Jun 03, 2018 1:12 pm

another one here experiencing laggy GUI with 10.0.2.
...not having a mid-life crisis....just don't give a fuck about shit i don't give a fuck about anymore.....

Joshua Boden
Posts: 110
Joined: Sun Dec 26, 2004 2:14 am
Location: NOVA/DC
Contact:

Re: Ableton 10.0.2 performance loss.

Post by Joshua Boden » Sun Jun 03, 2018 6:27 pm

YES!!!!

I have been working with Live since V4 - and this is the BUGGIEST update I have ever dealt with. The 10 BETA didnt have these issues.

You are not alone.....


The struggle is real..... :|

cane creek music
Posts: 7
Joined: Sun Jan 28, 2018 9:24 am

Re: Ableton 10.0.2 performance loss.

Post by cane creek music » Sun Jun 03, 2018 7:24 pm

10.0.2 is very troublesome for me, is there anywhere i can download 10.0.1?,
I went into my account and looked at the download archive but there were only versions of live 9.

daizok
Posts: 57
Joined: Fri Oct 27, 2017 9:05 am

Re: Ableton 10.0.2 performance loss.

Post by daizok » Sun Jun 03, 2018 7:32 pm

cane creek music wrote:10.0.2 is very troublesome for me, is there anywhere i can download 10.0.1?,
I went into my account and looked at the download archive but there were only versions of live 9.
http://downloads.ableton.com/channels/1 ... 0.1_64.dmg

Post Reply