Page 2 of 8

Re: Ableton 10.0.2 performance loss.

Posted: Thu May 31, 2018 1:04 pm
by Reemo
So I was playing with it a bit. And my GUI freezes randomly and also when drag&dropping some VST synths. Minimizing and maximizing makes it work again.

Re: Ableton 10.0.2 performance loss.

Posted: Thu May 31, 2018 2:51 pm
by daizok
The lag in GUI processing on 4K screens has been present since the first 10 release. Improvements were introduced in beta releases, but the lag has not been eradicated or significantly reduced yet. This issue is on the radar.

Re: Ableton 10.0.2 performance loss.

Posted: Thu May 31, 2018 2:52 pm
by daizok
Reemo wrote:So I was playing with it a bit. And my GUI freezes randomly and also when drag&dropping some VST synths. Minimizing and maximizing makes it work again.
Are you using (very) high refresh rates?

Re: Ableton 10.0.2 performance loss.

Posted: Thu May 31, 2018 3:34 pm
by Reemo
daizok wrote:
Reemo wrote:So I was playing with it a bit. And my GUI freezes randomly and also when drag&dropping some VST synths. Minimizing and maximizing makes it work again.
Are you using (very) high refresh rates?
Not sure if very high, but I am using full HD, 144Hz. Also GUI doesn't lag. It just freezes when I add a new track, but ableton works ok. Minimizing and maximizing solves it and it didn't happen in 10.0.1. I've sent it to support, so hopefully this will get noticed.

Re: Ableton 10.0.2 performance loss.

Posted: Thu May 31, 2018 3:52 pm
by Tarekith
Setting the refresh rate back to 60Hz or lower seems to be fixing this for people.

Re: Ableton 10.0.2 performance loss.

Posted: Thu May 31, 2018 10:54 pm
by paradiddle
Everything is slower now on windows 7 64 bit when browsing either from the desktop or using push 2. All was fine on the previous release.

edit: So is this related to the refresh rate issue everybody is having? I'm using a pretty old display.

Re: Ableton 10.0.2 performance loss.

Posted: Sat Jun 02, 2018 1:40 pm
by solar28
Echoing what Tarekith said, in my case setting my refresh rate to 60 HZ fixed all gui lag for me. Hopefully Windows or Ableton will find a long term fix, though I think this might be a windows issue.

Re: Ableton 10.0.2 performance loss.

Posted: Sat Jun 02, 2018 5:51 pm
by paradiddle
It was fine in the first version 10 release and now it's not. It's not a windows issue.

Re: Ableton 10.0.2 performance loss.

Posted: Sat Jun 02, 2018 6:13 pm
by kitekrazy
Angstrom wrote:
Muze wrote:The library is what seems to slow everything down for me. I click on a section and it takes a few seconds to a few minutes for anything to actually appear, then if I click on another section I get the same, it only seems to retain one section at a time. The places/packs section is fine and opens instantly, it's just this constant need it has to scan in the background, I would rather just have a normal drive location based browser like the places section than this useless library.
make sure you haven't added any huuuuge locations to Places. If you add your entire computer to places then the library constantly scans your entire computer, every single file.
My places are: Audio, Music, Live Songs. which probably covers half a terabyte or so. But if I allowed places to index my whole machine it would be about 8 terabytes.
I don't know why they did this library scan. It was a big complaint when 9 came out. No other DAW does this.

Re: Ableton 10.0.2 performance loss.

Posted: Sat Jun 02, 2018 9:39 pm
by Stromkraft
konovalovua wrote: No, its not a Windows problem.
What makes you believe that? Even if Live is at fault it could be because an Windows API Live calls in the way it was declared. Ableton said for years OS X was at fault for some audio performance issues (OS X 10.9 to 10.11). Turns out they were right.

Don't assume.

Re: Ableton 10.0.2 performance loss.

Posted: Sat Jun 02, 2018 10:53 pm
by Muze
kitekrazy wrote:
Angstrom wrote:
Muze wrote:The library is what seems to slow everything down for me. I click on a section and it takes a few seconds to a few minutes for anything to actually appear, then if I click on another section I get the same, it only seems to retain one section at a time. The places/packs section is fine and opens instantly, it's just this constant need it has to scan in the background, I would rather just have a normal drive location based browser like the places section than this useless library.
make sure you haven't added any huuuuge locations to Places. If you add your entire computer to places then the library constantly scans your entire computer, every single file.
My places are: Audio, Music, Live Songs. which probably covers half a terabyte or so. But if I allowed places to index my whole machine it would be about 8 terabytes.
I don't know why they did this library scan. It was a big complaint when 9 came out. No other DAW does this.
Me neither, I'd rather it was not doing this.

Re: Ableton 10.0.2 performance loss.

Posted: Sun Jun 03, 2018 1:12 pm
by spagbol
another one here experiencing laggy GUI with 10.0.2.

Re: Ableton 10.0.2 performance loss.

Posted: Sun Jun 03, 2018 6:27 pm
by Joshua Boden
YES!!!!

I have been working with Live since V4 - and this is the BUGGIEST update I have ever dealt with. The 10 BETA didnt have these issues.

You are not alone.....


The struggle is real..... :|

Re: Ableton 10.0.2 performance loss.

Posted: Sun Jun 03, 2018 7:24 pm
by cane creek music
10.0.2 is very troublesome for me, is there anywhere i can download 10.0.1?,
I went into my account and looked at the download archive but there were only versions of live 9.

Re: Ableton 10.0.2 performance loss.

Posted: Sun Jun 03, 2018 7:32 pm
by daizok
cane creek music wrote:10.0.2 is very troublesome for me, is there anywhere i can download 10.0.1?,
I went into my account and looked at the download archive but there were only versions of live 9.
http://downloads.ableton.com/channels/1 ... 0.1_64.dmg