Ableton 10.0.2 performance loss.

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
H20nly
Posts: 15838
Joined: Sat Oct 27, 2007 9:15 pm
Location: The Wild West

Re: Ableton 10.0.2 performance loss.

Post by H20nly » Thu Jun 14, 2018 11:32 pm

Stromkraft wrote:
spendthrift2 wrote:Apparently there was a default setting on my laptop (It's a Dell Latitude E6410 w/ i5 processor 2.4GHz and 8GB RAM) that had the processor set to perform at 5% on battery and when plugged in. The name of the setting within advanced power settings was: Processor power management > then access minimum processor state & maximum power state > change both to 100% on both battery & when plugged in.
The first thing to check in these types of cases. It should be in the first display when opening Live for the first time.
people will still rationalize blaming Ableton when they miss it there

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Ableton 10.0.2 performance loss.

Post by Stromkraft » Fri Jun 15, 2018 7:38 am

H20nly wrote:
Stromkraft wrote:
spendthrift2 wrote:Apparently there was a default setting on my laptop (It's a Dell Latitude E6410 w/ i5 processor 2.4GHz and 8GB RAM) that had the processor set to perform at 5% on battery and when plugged in. The name of the setting within advanced power settings was: Processor power management > then access minimum processor state & maximum power state > change both to 100% on both battery & when plugged in.
The first thing to check in these types of cases. It should be in the first display when opening Live for the first time.
people will still rationalize blaming Ableton when they miss it there
That's a given, but it wouldn't hurt Ableton to be more helpful with suggestions about hardware resources.
Make some music!

H20nly
Posts: 15838
Joined: Sat Oct 27, 2007 9:15 pm
Location: The Wild West

Re: Ableton 10.0.2 performance loss.

Post by H20nly » Tue Jun 19, 2018 5:02 pm

Agreed.

al_yell
Posts: 4
Joined: Wed Jun 06, 2018 5:15 pm

Re: Ableton 10.0.2 performance loss.

Post by al_yell » Wed Jun 20, 2018 12:33 am

For weeks I've been experiencing the freezing GUI as described throughout. Changing my monitor's refresh rate from 144 to 120Hz appears to have helped. The app still hiccups but is usable.

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Ableton 10.0.2 performance loss.

Post by Stromkraft » Wed Jun 20, 2018 6:22 am

al_yell wrote:For weeks I've been experiencing the freezing GUI as described throughout. Changing my monitor's refresh rate from 144 to 120Hz appears to have helped.
Really? Could you share more details about the graphics card, drivers used, cabling and the display? You have any frame sync functionality active, like G-Sync or Freesync?
Make some music!

al_yell
Posts: 4
Joined: Wed Jun 06, 2018 5:15 pm

Re: Ableton 10.0.2 performance loss.

Post by al_yell » Wed Jun 20, 2018 1:27 pm

Stromkraft wrote:
al_yell wrote:For weeks I've been experiencing the freezing GUI as described throughout. Changing my monitor's refresh rate from 144 to 120Hz appears to have helped.
Really? Could you share more details about the graphics card, drivers used, cabling and the display? You have any frame sync functionality active, like G-Sync or Freesync?
Graphics card: (NVIDIA) GeForce GTX 1070
Display 1: ASUS VG248; DVI
Display 2: Dell ST2420L; HDMI
Also own a Push2..

In the NVIDIA control panel I generally have things set to favor performance over quality, and V-sync is off. My monitors don't feature G-sync.

After a few more hours of use since lowering the refresh rate, I've had minor hiccups. The GUI still freezes on occasion, and rarely displays a newly loaded project properly. But, overall, it isn't as stubborn as before; it can be immediately reset by minimizing + opening the app. I haven't spent nearly as much time working in the Beta, but from what I can tell, 10.0.3b is more stable despite also hanging now and again.

EDIT (few hours later): the performance improvement must have been a coincidence. As though having tempted the Ableton gods, the app has reverted to being virtually unusable. It's disappointing as much as it is enigmatic.

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Ableton 10.0.2 performance loss.

Post by Stromkraft » Wed Jun 20, 2018 8:35 pm

@al_yell, thanks for sharing.

I do think there is a bug somewhere there, though I think it could be something in your system that doesn't behave to spec. At least this would seem likely given we haven't seen others with exactly the same issue yet. Right?

I did have a recurring extremely odd graphic issue with Live 9 for multiple years that never got worked out. It happened once after each update when I opened certain projects mostly and then not at all until the next update. The last year, like two years ago or so, it recurred more often and I found an odd way to trigger it. Then I think I reinstalled everything in OS X and haven't seen this since 9.7 or so.

While I don't think this is the same you can check by opening a second window from the menu and see if the controls work there. In my case it did when this issue appeared. The fix was a restart.
Make some music!

al_yell
Posts: 4
Joined: Wed Jun 06, 2018 5:15 pm

Re: Ableton 10.0.2 performance loss.

Post by al_yell » Thu Jun 21, 2018 5:02 am

Stromkraft wrote:...it could be something in your system that doesn't behave to spec....we haven't seen others with exactly the same issue yet. Right?
konovalovua (OP) wrote:Playback line is blinking and it feels like I'm trying to play a video game, but my video card can't give me enough FPS.
Precisely my issue as well. And, like in @konovalovua's case, it's isolated to Ableton.

Phreebass
Posts: 3
Joined: Thu Jun 21, 2018 12:47 pm

Re: Ableton 10.0.2 performance loss.

Post by Phreebass » Fri Jun 22, 2018 12:44 pm

Precisely my issue as well. And, like in @konovalovua's case, it's isolated to Ableton.
Same here. 10.0.1 ran great, this latest version is really sluggish on the GUI, sometimes have to minimise then maximise the screen to get it to refresh!

Nvidia 1080GTX on 100hz Ultra Widescreen (G-sync)
i7 @ 4GHz, 32GB RAM
Windows 10 64bit 1803.

Everything else is running fine, so definitely Ableton's issue.

Tarekith
Posts: 17347
Joined: Fri Jan 07, 2005 11:46 pm
Location: Ableton Forum Administrator
Contact:

Re: Ableton 10.0.2 performance loss.

Post by Tarekith » Fri Jun 22, 2018 2:31 pm

Try setting the refresh rate of your screen to 60Hz, does that fix the minimizing issue?

Phreebass
Posts: 3
Joined: Thu Jun 21, 2018 12:47 pm

Re: Ableton 10.0.2 performance loss.

Post by Phreebass » Fri Jun 22, 2018 5:09 pm

Try setting the refresh rate of your screen to 60Hz, does that fix the minimizing issue?
Seems to so far, but it's only a workaround, does need a proper fix in the next version!
The play marker line is pretty jerky now too.

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Ableton 10.0.2 performance loss.

Post by Stromkraft » Sat Jun 23, 2018 4:35 pm

al_yell wrote: Precisely my issue as well. And, like in @konovalovua's case, it's isolated to Ableton.
Can you guys share all your hardware info and other set up info of Live? Certainly to Ableton, unless you haven't already.

Of course, it's the responsibility of a maker of software to make their software compatible with a wide variety of hardware. But all applications relies on a system of hardware together with an OS at a minimum.

Personally I wish the process of rectifying issues like yours had grown into deeper analytical and streamlined methodology countering the fact that real time applications do as many advanced tasks as they do. It's still the simplistic, find the steps causing the issue > report these > attempt to recreate by the developer > further discussion > update is shared > tests are made by the reporter at best > other tests for side-effects need to be run before a release fix is possible.
Make some music!

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Ableton 10.0.2 performance loss.

Post by Stromkraft » Sat Jun 23, 2018 4:37 pm

Phreebass wrote:[
Nvidia 1080GTX on 100hz Ultra Widescreen (G-sync)
You do know you can turn off G-sync for specific apps right? While I'd assume this is ignored if the app doesn't support G-sync that would still be the first thing to try.
Make some music!

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Ableton 10.0.2 performance loss.

Post by Stromkraft » Sat Jun 23, 2018 4:45 pm

Stromkraft wrote: I did have a recurring extremely odd graphic issue with Live 9 for multiple years that never got worked out.
This issue that no-one else had is outlined here in "Unresponsive GUI once in a while? Sounds familiar?.
Make some music!

Phreebass
Posts: 3
Joined: Thu Jun 21, 2018 12:47 pm

Re: Ableton 10.0.2 performance loss.

Post by Phreebass » Sun Jun 24, 2018 11:15 am

You do know you can turn off G-sync for specific apps right? While I'd assume this is ignored if the app doesn't support G-sync that would still be the first thing to try.
Yes I am aware of the g-sync settings, but this is a bug introduced in 10.0.2.
I don't think it's related to that, my mate has a Mac without g-sync and is having the same issues with 10.0.2...

Post Reply