Page 1 of 1

Ableton 10 & NI Komplete Audio 6 - no input signal

Posted: Tue Nov 27, 2018 5:25 pm
by Iamgeert
Hi forum,

I apologize in advance if I missed existing topics about this due to my inexperience with the search function (heck, with the whole forum tbh..).

I recently purchased Ableton 10 for my new setup on a Mac (previously, I was using ableton 9 on a windows machine). So far so good, very happy with it, but I can't seem to get the input channels of my NI Komplete Audio 6 interface working.

Everything seems in order, but for some reason, Ableton 10 doesnt receive any input signal through either of the RCA inputs on my KA6. The synths/drum machines do their work; the KA9 unit indicates incoming audio signal by flashing it's LEDs, but Ableton; nothing.
Drivers for the NI unit are installed, the input config is in order (exactly like proposed here https://support.native-instruments.com/ ... leton-Live), the soundcard and its channels are recognized by Ableton selected, all input channels are activated. Also, the routing on the track & master is configured fine. But I'm not even getting a signal read-out on the level-indicators per channel..

I've found a similar post on the NI forums, but it's dead after people referring to the input config setup. No anwers there..

Hope I'm just missing something obvious!

Re: Ableton 10 & NI Komplete Audio 6 - no input signal

Posted: Tue Nov 27, 2018 9:18 pm
by jestermgee
In Lives preferences have you enabled the audio inputs for the audio interface you want to use?

Re: Ableton 10 & NI Komplete Audio 6 - no input signal

Posted: Tue Nov 27, 2018 11:21 pm
by Iamgeert
Yeah, I configured everything as I had it in ableton 9 and according to the link I've posted in the OP

So the soundcard is selected as input and output device, and all input channels are recognized and activated.. unfortunately it wasn't something simple as that :)

Re: Ableton 10 & NI Komplete Audio 6 - no input signal

Posted: Tue Dec 04, 2018 7:18 pm
by Iamgeert
Ok, figured it out.. Apparently after the OSX 10.14 Mojave update you have to reset the permits for Live to use line-in channels.

It's found here;
- System Preferences
- Security & Privacy
- Tab: Privacy, select Microphone and enable Ableton there.

https://i.imgur.com/q7UBj9m.png

Worked for me :)