Page 1 of 1

Operator and MIDI Velocity

Posted: Thu Jan 31, 2019 3:45 pm
by SmileDog77
I have been dabbling with Ableton's operator for awhile now and realized a small problem with it regarding the velocity. There are some operator presets, including self-made presets via dabbling with operator, that cannot be affected by the MIDI effect "velocity" and even the "velocity" control in the arpeggiator However, most presets of operator can be affected by the "velocity" midi effect, Acid Bass is one example.

I have tried comparing two operator presets side by side, one which cannot be affected by velocity (Bass Housy) and the other which can (Acid Bass), tried tweaking Bass Housy towards Acid Bass but still cannot get it to be affected by "Velocity" no matter what, meaning that I still cannot pinpoint what exactly in operator is disallowing it to be affected by MIDI Effect's Velocity.

This is really important to me, if anyone out there can assist me, I'd really appreciate it, as I'd really really really wanna be able to design my own sound with operator AND be able to use Velocity based MIDI and Audio effects. Thank You.

Re: Operator and MIDI Velocity

Posted: Thu Jan 31, 2019 4:34 pm
by wearemindflux
Hi, you have to make sure the parameter to velocities is set up. For example vel>freq

Re: Operator and MIDI Velocity

Posted: Thu Jan 31, 2019 4:59 pm
by chrk
There's your velocity midi routing:


Pick your target(s) from the Connection A/B (e.g. Volume) and set an amount.

Re: Operator and MIDI Velocity

Posted: Thu Jan 31, 2019 5:58 pm
by yur2die4
Also there should be velocity settings in each page for controlling various parameters like envelope amount for the operators, filter, LFO, pitch, etc. there is velocity control all over the place.

Re: Operator and MIDI Velocity

Posted: Fri Feb 01, 2019 9:58 am
by SmileDog77
Well thanks so much guys, turns out I need to route Velocity in operator to Vol or Osc A, B, C, D Vol to get it to work. Even though, for some reason, Acid Bass preset does not route yet can be affected by Velocity Randomizer, for that I also found out why by dabbling with the pure operator and tweaking it to become more like the Acid Bass preset: it is due to this parameter labelled Freq<Vel under the Global Filter's envelop section in Operator, it has to be higher than 0% I think. Anyways, thanks guys who replied, really appreciate it!