My CMD+OPT+L and CMD+OPT+I are broken

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
jpallarest
Posts: 18
Joined: Thu Feb 14, 2019 2:14 pm

My CMD+OPT+L and CMD+OPT+I are broken

Post by jpallarest » Wed Feb 27, 2019 9:05 pm

No idea why these 2 keyboard shortcuts don't work: CMD+OPT+L (to show or hide detail view), and CMD+OPT+I (to show or hide in/out section).

The rest CMD+OPT commands do. Like CMD+OPT+B to show or hide browser and such.

Any ideas how could I fix this?
Anyone here can reproduce the same issue?

fishmonkey
Posts: 4119
Joined: Wed Oct 24, 2007 4:50 am

Re: My CMD+OPT+L and CMD+OPT+I are broken

Post by fishmonkey » Wed Feb 27, 2019 9:57 pm

they work fine here in Live 10. most likely cause is that they have been re-mapped to something else in the keyboard system preferences, or by some other app you have installed...
badbrainz wrote: I'm a drummer, so I'm already at an intellectual disadvantage here

jpallarest
Posts: 18
Joined: Thu Feb 14, 2019 2:14 pm

Re: My CMD+OPT+L and CMD+OPT+I are broken

Post by jpallarest » Wed Feb 27, 2019 10:01 pm

fishmonkey wrote:
Wed Feb 27, 2019 9:57 pm
they work fine here in Live 10. most likely cause is that they have been re-mapped to something else in the keyboard system preferences, or by some other app you have installed...
Weird, I've not remapped keyboard to any other setting than defaults (new-ish Mac, switched from years of PC Windows use). If it's the second case..how would I know?

jpallarest
Posts: 18
Joined: Thu Feb 14, 2019 2:14 pm

Re: My CMD+OPT+L and CMD+OPT+I are broken

Post by jpallarest » Wed Feb 27, 2019 10:33 pm

EDIT: I already found what's causing the issue. It's because I'm using 'Español - ISO' input source in the keyboard preferences. I hope Ableton provided a way to solve the issue without having to switch to another keyboard layout. Yo hablo español.

fishmonkey
Posts: 4119
Joined: Wed Oct 24, 2007 4:50 am

Re: My CMD+OPT+L and CMD+OPT+I are broken

Post by fishmonkey » Wed Feb 27, 2019 10:39 pm

try re-mapping the Live shortcuts using the keyboard system preferences:

https://support.apple.com/en-au/guide/m ... lp2271/mac

note that for this to work you need copy the function name from the Live menu exactly. also, watch out for conflicts with existing shortcuts—they also mess things up...
badbrainz wrote: I'm a drummer, so I'm already at an intellectual disadvantage here

Post Reply